Support us on Patreon to keep GamingOnLinux alive. This ensures we have no timed articles and no paywalls. Just good, fresh content! Alternatively, you can donate through Paypal, Flattr and Liberapay!

Humble Indie Bundle 14 Adds New Games For Linux Including Contraption Maker

Posted by , | Views: 8,613
It's so damn good to see Humble back on form with a true Humble Indie Bundle, we just gained access to new games too!

New Games
140
MirrorMoon EP
Contraption Maker

Even with the new games, it's worth it for Outlast and Shadow Warrior too!

Check out Humble Indie Bundle 14 right here.
https://www.youtube.com/watch?v=1eaf131KjPk

If you don't pick up this bundle, I'm just going to assume you're insane. Article taken from GamingOnLinux.com.
0 Likes
We do often include affiliate links to earn us some pennies. We are currently affiliated with GOG, Humble Store and Paradox Interactive. See more information here.
The comments on this article are closed.
15 comments
Page: 1/2»
  Go to:

flesk 7 April 2015 at 6:45 pm UTC
View PC info
  • Contributing Editor
  • Supporter
  • Top Supporter
I've been waiting for the Linux version of Contraption Maker, so that's very welcome. And 140 is an excellent rhythm platformer.
leillo1975 7 April 2015 at 6:51 pm UTC
Contraption Maker is not listed in my Linux Steam Library, only for Windows
WorMzy 7 April 2015 at 6:54 pm UTC
View PC info
  • Supporter
  • Top Supporter
<usual rant about Giana Sisters>
linux93 7 April 2015 at 6:54 pm UTC
who has a key of deponia? i have a key of super splatter for you!
aL 7 April 2015 at 7:44 pm UTC
leillo1975Contraption Maker is not listed in my Linux Steam Library, only for Windows
On top of that I get this error in the drm-free version

$ ./ContraptionMakerLauncher 
Set log file to /home/aL/.config/spotkincm//cmpatcher.logInitializing services...[loom.application] Initializing services...[loom.application]    o performance[loom.application]    o RNG[loom.application]    o time[loom.application]    o stringtable[loom.application]    o network[loom.application]    o http[loom.application]    o assets[asset.core] Current working directory ='.'[cocos] Entering CMSpotkinWorkshop[cocos] Can't open database: unable to open database file
[cocos] SQL error: (null)
[cocos] Can't open database: unable to open database file
[cocos] SQL error: (null)
[cocos] Can't open database: unable to open database file
[cocos] SQL error: (null)
[cocos] Can't open database: unable to open database file
[cocos] SQL error: (null)
libGL error: dlopen /usr/lib/x86_64-linux-gnu/dri/swrast_dri.so failed (/home/aL/games/ContraptionMaker/lib/libstdc++.so.6: version `GLIBCXX_3.4.20' not found (required by /usr/lib/x86_64-linux-gnu/dri/swrast_dri.so))
libGL error: dlopen ${ORIGIN}/dri/swrast_dri.so failed (${ORIGIN}/dri/swrast_dri.so: cannot open shared object file: No such file or directory)
libGL error: dlopen /usr/lib/dri/swrast_dri.so failed (/usr/lib/dri/swrast_dri.so: cannot open shared object file: No such file or directory)
libGL error: unable to load driver: swrast_dri.so
libGL error: failed to load driver: swrast
[cocos] GLFWError #65544 Happen, GLX: Failed to create context: BadValue (integer parameter out of range for operation)
[cocos] Assert failed: Main window is nullContraptionMakerLauncher: /home/kjohnston/spotkin/ContraptionMaker/vendor/cocos2dx/cocos/platform/desktop/CCGLViewImpl-desktop.cpp:399: bool cocos2d::GLViewImpl::initWithRect(const string&, cocos2d::Rect, float): Assertion `_mainWindow!=__null' failed.
Aborted


I dont know who /home/kjohnston is btw
Ivancillo 7 April 2015 at 8:18 pm UTC
QuoteIf you don't pick up this bundle, I'm just going to assume you're insane.

This!
Pit 7 April 2015 at 9:08 pm UTC
aL
leillo1975Contraption Maker is not listed in my Linux Steam Library, only for Windows
On top
of that I get this error in the drm-free version
.....

Indeed, a completely messed up build. Seems to insist in finding its 64bit libraries under /usr/lib. But this is the libraries that come with the game, so I could get it to start moving ContraptionMaker/lib out of the way so that it uses my system libraries instead.
It then spits out thousands of errors that it cannot find assets/data/defaults.data (indeed not there) and finally dies with
OpenGL version too old: OpenGL 1.5 or higher is required (your version is 1.4 (2.1.2 NVIDIA 340.76)). Please upgrade the driver of your video card.
Very funny. This is the latest driver for my card.

So f.... this game.

Oh, and look at that. It uncompresses the whole game data in $HOME/.config/spotkincm:
snoopy:~% du -hs /home/pit/.config/spotkincm
494M    /home/pit/.config/spotkincm


I rather stop here, else I start getting really unpolite.
leillo1975 7 April 2015 at 9:31 pm UTC
leillo1975Contraption Maker is not listed in my Linux Steam Library, only for Windows

Autoquote:

http://steamcommunity.com/app/241240/discussions/1/864977479806835438/#c618458030674238421
Pozzuoli 8 April 2015 at 6:21 am UTC
@Pit for me, that directory is fairly small.

$ du -hs ~/.config/spotkincm
248K /home/poz/.config/spotkincm

=EDIT=

I downloaded a few user inventions, and now it's 1.9 MB. However, I think it's reasonable enough for devs to put this kind of file there, isn't it? Perhaps better in a cache directory, but this isn't horrible, IMO.
Eike 8 April 2015 at 10:45 am UTC
WorMzy&lt;usual rant about Giana Sisters&gt;

Humble Bundle page says Giana Sisters: Twisted Dreams will be available for Mac and Linux later this year.
They did not need to change the text... ;)
  Go to:
While you're here, please consider supporting GamingOnLinux on Patreon, Liberapay or Paypal. We have no adverts, no paywalls, no timed exclusive articles. Just good, fresh content. Without your continued support, we simply could not continue!

You can find even more ways to support us on this dedicated page any time. If you already are, thank you!
Livestreams & Videos
Community Livestreams
  • Story Time: „Ankh 2: Heart of Osiris“ (via Proton)
  • Date:
See more!
Popular this week
View by Category
Contact
Latest Comments
Latest Forum Posts