You can sign up to get a daily email of our articles, see the Mailing List page!
Support us on Patreon to keep GamingOnLinux alive. This ensures we have no timed articles and no paywalls. Just good, fresh content! Alternatively, you can support us on Paypal and Liberapay!
Feral Interactive have now pushed out the Foundation Update and the Norsca Race Pack for Linux getting our version of The Total War: WARHAMMER [Steam, Feral Store] up to scratch.

Here's the Norsca launch trailer:

The Foundation Update "supercharges the foundation races" making them up to date against new DLC races and gives them a little spit and polish. You can read more details on that in this blog post.

You can also grab 30 free elite units, through Total War Access which requires you to register for access.

If you're interested, you can support Feral Interactive directly by buying the DLC from their store.
4 Likes, Who?
FredO 24 August 2017 at 2:06 pm UTC
Feral delivers again!
lucifertdark 24 August 2017 at 2:11 pm UTC
According to the launcher my machine is no longer up to the task after this latest patch.
Whitewolfe80 24 August 2017 at 2:56 pm UTC
I am really hoping that this means Warhammer 2 is coming as this was a pre order bonus dlc until now
edddeduck_feral 24 August 2017 at 3:46 pm UTC
lucifertdarkAccording to the launcher my machine is no longer up to the task after this latest patch.

It's likely you're using Nvidia drivers which have a bug needing you to downgrade the drivers to an older stable branch that don't experience the performance issue. 381.22 and newer has a performance issue that the older drivers don't experience.
lucifertdark 24 August 2017 at 3:55 pm UTC
edddeduck_feral
lucifertdarkAccording to the launcher my machine is no longer up to the task after this latest patch.

It's likely you're using Nvidia drivers which have a bug needing you to downgrade the drivers to an older stable branch that don't experience the performance issue. 381.22 and newer has a performance issue that the older drivers don't experience.
Thanks for the info Eddd, so the 384.59 drivers are broken? neat! lol, here we go with the downgrade upgrade roundabout again. The 378 drivers are ok to use?


Last edited by lucifertdark at 24 August 2017 at 3:55 pm UTC
skinnyraf 25 August 2017 at 7:48 am UTC
edddeduck_feral
lucifertdarkAccording to the launcher my machine is no longer up to the task after this latest patch.

It's likely you're using Nvidia drivers which have a bug needing you to downgrade the drivers to an older stable branch that don't experience the performance issue. 381.22 and newer has a performance issue that the older drivers don't experience.

So all SteamOS users (all three of us ) should wait for Nvidia to fix the bug and the for Valve to update SteamOS?
edddeduck_feral 25 August 2017 at 10:10 am UTC
lucifertdark
edddeduck_feral
lucifertdarkAccording to the launcher my machine is no longer up to the task after this latest patch.

It's likely you're using Nvidia drivers which have a bug needing you to downgrade the drivers to an older stable branch that don't experience the performance issue. 381.22 and newer has a performance issue that the older drivers don't experience.
Thanks for the info Eddd, so the 384.59 drivers are broken? neat! lol, here we go with the downgrade upgrade roundabout again. The 378 drivers are ok to use?

I would load the game to check before downgrading to 378 but the issue can drop the in game fps down to 5fps so it's pretty noticeable as soon as you start playing. This also effected the game before Norsca was released so it's not specific to the update. If you where playing find just before the update you should be fine after updating too.

If you DONT get a regression on Nvidia please do contact our support and let us know the Nvidia driver version you're using, your exact GPU model as cases which run just fine are just as useful as ones that don't as it's means more data we can use when working with partners to get this driver issue resolved.
lucifertdark 26 August 2017 at 10:35 am UTC
I'm using the Nvidia 384.69 drivers with my GTX 770 & there's no drop in performance since the patch even though I'm getting the message in the launcher, I just tested it with an Empire army against the Greenskins & got sent home on my shield, proof that I'm rubbish at the game but at least it's running just fine with my setup.
edddeduck_feral 29 August 2017 at 10:58 am UTC
lucifertdarkI'm using the Nvidia 384.69 drivers with my GTX 770 & there's no drop in performance since the patch even though I'm getting the message in the launcher, I just tested it with an Empire army against the Greenskins & got sent home on my shield, proof that I'm rubbish at the game but at least it's running just fine with my setup.

Thanks for the feedback!
While you're here, please consider supporting GamingOnLinux on Patreon or Liberapay. We have no adverts, no paywalls, no timed exclusive articles. Just good, fresh content. Without your continued support, we simply could not continue!

We also accept Paypal donations and subscriptions! If you already are, thank you!

Due to spam you need to Register and Login to comment.


Or login with...

Livestreams & Videos
Official Livestreams
  • Borderlands: The Pre-Sequel continued again
  • Date:
Community Livestreams
  • RPGoodness: "Dragon Age Origins" (via Wine)
  • Date:
See more!
Popular this week
View by Category
Contact
Latest Forum Posts
Facebook