Check out our Monthly Survey Page to see what our users are running.
How to get a 32bit JVM running on a 64bit Linux OS via Steam Client?
Page: «2/2
  Go to:
wojtek88 24 Apr, 2016
Hi @noblemaster, I gave a try your game. Below is my system information:
Spoiler, click me

Computer Information:
Manufacturer: Unknown
Model: Unknown
No Touch Input Detected

Processor Information:
CPU Vendor: GenuineIntel
CPU Family: 0x6
CPU Model: 0x2a
CPU Stepping: 0x7
CPU Type: 0x0
Speed: 2900 Mhz
4 logical processors
2 physical processors
HyperThreading: Supported
FCMOV: Supported
SSE2: Supported
SSE3: Supported
SSSE3: Supported
SSE4a: Unsupported
SSE41: Supported
SSE42: Supported
AES: Unsupported
AVX: Supported
CMPXCHG16B: Supported
LAHF/SAHF: Supported
PrefetchW: Unsupported

Network Information:
Network Speed:

Operating System Version:
Ubuntu 15.04 (64 bit)
Kernel Name: Linux
Kernel Version: 3.19.0-25-generic
X Server Vendor: The X.Org Foundation
X Server Release: 11701000
X Window Manager: Compiz
Steam Runtime Version: steam-runtime-release_2016-02-23

Video Card:
Driver: NVIDIA Corporation GeForce GT 540M/PCIe/SSE2

Driver Version: 4.5.0 NVIDIA 361.18
OpenGL Version: 4.5
Desktop Color Depth: 24 bits per pixel
Monitor Refresh Rate: 60 Hz
VendorID: 0x10de
DeviceID: 0xdf4
Number of Monitors: 1
Number of Logical Video Cards: 2
Primary Display Resolution: 1600 x 900
Desktop Resolution: 1600 x 900
Primary Display Size: 15,04" x 8,43" (17,20" diag)
38,2cm x 21,4cm (43,7cm diag)
Primary Bus: PCI Express 16x
Primary VRAM: 1024 MB
Supported MSAA Modes: 2x 4x 8x 16x

Sound card:
Audio device: Intel CougarPoint HDMI

RAM: 9910 Mb

UI Language: English
Microphone: Not set
Total Hard Disk Space Available: 100662 Mb
Largest Free Hard Disk Block: 4909 Mb
VR Headset: None detected
As you can see it is a 64bit Linux system (Ubuntu 15.04). Your game runs very well on my setup (the only annoying thing is that it does not remember fullscreen setting, so it always runs in windowed mode).
According to what you wrote, you call 32bit API, and for me it works. So it does not look like the issue you're trying to fix is connected to fact that on 64bit system you call 32bit Steam API.
If you need any log of your game or any additional testing just drop me a line.
noblemaster 26 Apr, 2016
Thanks for testing! You can make the game startup in fullscreen mode via [Settings]. Enable the "Fullscreen-Mode at Startup" option. I hope that works.

QuoteSo, it's SteamOS on your machine and a Linux distro with the Steam client on your customer's side, is that it?

Also, the game comes bundled with the JVM. I cannot provide different apps with different JVMs for different Linux distributions in Steam. Not as far as I can tell? The goal is to fix the error, whatever the cause. The question is what is causing it?

QuoteOn your side, you can try to boot a different distro as live version, like Ubuntu, if your game is not too graphic intensive (as you won't be able to install eventual proprietary GPU drivers). You'll have to install Steam and maybe Java on it but it's in RAM, you don't install anything on your HD and don't mess with your current setup. That might allow you to check if you can reproduce the issue outside of SteamOS.
I tried VM before but it's difficult to always make it work. Not sure, but sometimes it just doesn't run due to some graphic card problems. It's an on/off. Also, it doesn't emulate the customer's machine if I cannot reproduce the error. In the end I still don't know what the problem is.
noblemaster 26 Apr, 2016
Just got it in: the machine is running Ubuntu 16.04 64bit, Nvidia 980ti. That's where it doesn't work. Given it worked in Ubuntu 15.04 for wojtek88, the question is, what's the difference? Did you install any compatibility libraries or such? Did Ubuntu change that much?
wojtek88 26 Apr, 2016
Hmmm, I will try to install Ubuntu 16.04 this week and will let you know. AFAIK a lot of software has some compatibility issues with Ubuntu 16.04, so It is possible that the problem lies here.
Quoting: noblemasterDid you install any compatibility libraries or such?
I don't recall such a thing. I will get back to you when I have 16.04 (I will do fresh install on other disk, for now I don't want to update) ;)
noblemaster 27 Apr, 2016
I got a new binary with an updated JVM launcher. Unfortunately, it seems the customer has decided to change to Mint leaving me without options to test it :-/

Here is the new binary for anyone running 16.04:

I think this should work, but it's difficult to confirm now?
While you're here, please consider supporting GamingOnLinux on:

Reward Tiers: Patreon. Plain Donations: PayPal.

This ensures all of our main content remains totally free for everyone with no article paywalls. We also don't have tons of adverts, there's also no tracking and we respect your privacy. Just good, fresh content. Without your continued support, we simply could not continue!

You can find even more ways to support us on this dedicated page any time. If you already are, thank you!
Login / Register

Or login with...
Sign in with Steam Sign in with Google
Social logins require cookies to stay logged in.