You can sign up to get a daily email of our articles, see the Mailing List page.
Sound Issue's on Xubuntu 16.04, Just Me Or?
Rob-Retro 24 Apr, 2016
Ok nuked my drives 1tb for boot, 2tb for home, Then install Kubuntu 16.04, which after an hour or so i gave up, Far to much broken (example: Driver manager does nothing/shows nothing), so again nuked my drives and install Xubuntu 16.04, a few small problems thunar file manager crashes a lot (but was as bad on 14.04 as well), replaced with nemo file manager, arc manager also keeps crashing (again same as 14.04), vlc video player is errr freaking out with strange graphic glitches when playing videos, but gnome mplayer is working normal?, On with the real problem:

Games and Sound, Quake 4 and ET Quake Wars will not play sound at all, run from terminal and something on the lines of no sound driver found, padsp and aoss does nothing still no sound, but Prey (same id engine) runs fine with sound?.
Ok these are old games so it's tuff luck for me, but here is the bigger problem:

Installed steam, had the error pop up, removed steam and installed from apt-get as its not in the new software centre app?
Started downloading a fair few games, then started testing:

Interstellar Marines - No sound at all, uninstalled before testing a few things.
Ravensword: Shadowlands - No sound at all but will work if i run from terminal with "padsp ./rs2.x86"?
Shadow Warrior 2013 - Starts with sound on menu but no sound once you start a game, again padsp saved the day??
Shatter - No sound at all and padsp will not work as it throws up the elf class error???

Now is it just Xubuntu 16.04, or is it all 16.04 *ubuntu os's, or is it just mine?
So if someone is running 16.04 of some sort and have these games then could you at some point do a test and see if you have the same problem.

SystemShock 25 Apr, 2016
Hi, what SoundCard do you use ?
Maybe you can give us some more Specs of your PC ?

And btw, why 1TB only for Boot ?
Maybe you should check your partition Sizes ?

Rob-Retro 25 Apr, 2016
AMD FX 8350, 8 Core @ 4.0ghz per core (No overclocking)
12gb Ram
Nvidia GTX 960 2gb Driver 364.19 (No overclocking, HDMI Sound turned off)
SoundBlaster X-Fi Pro USB.
Asus Motherboard (getting on now, one of the first motherboards with USB 3.0 Ports)
2 Hard drives 1tb and 2tb.

Ok just so you know the SoundBlaster X-Fi Pro USB is now over 2 years old, and has worked with xubuntu 12.04 and xubuntu 14.04 without a single problem, also run great on other distros including OpenSuse, Debian, and Manjaro Linux, etc, It still runs fine on my ubuntu 14.04.4 laptop, no sound problems at all, so its not the X-Fi, This has only started with the install of 16.04, which leaves me to think that either the pulseaudio sound server is maybe broken, or pulseaudio has been updated and lost some driver features which some game's still need, Ravensword and Interstellar Marines are Unity 3D but use an older Unity engine, most other unity games run without sound problem but are newer unity engine, but the one that has me beat was Shadow Warrior 2013 sound was fine though intro videos and the main menu but once you start a game and the game engine starts i have no sound at all, but if i use padsp before the executable from a terminal sound works as it should, but i never had to do this before 16.04.

Also anyone recommend openSUSE tumbleweed or leap 42.1 for gaming and day to day desktop apps like gnucash, handbrake video converter, etc.
Rob-Retro 29 Apr, 2016
So i messed around so much on Xubuntu 16.04 sound that i broke it beyond repair, So.....

Ok tested some other Distros which all worked without sound problems?, So i installed Ubuntu Gnome 16.04, And once again no sound on games listed above, so as Tomb Raider was out and that works with sound i stuck to using Ubuntu Gnome (I really like it), so tonight i install crossover (wine) and guess what, you guessed it, no sound :'( , so went into wine config and to the audio tab which is set to winealsa and system default, i changed system default to my SoundBlaster X-Fi card hit Apply and then test button, oh my god it made a noise, tested the game i had just installed and yes i have sound, so trying to fix pulse audio before was a waste of time as the problem is Alsa audio (which i forgot all about), quick vist to alsa audio website and then i find my answer:

New update:

Deleted last fix from post as it did not work:

last fix did not work, it just made alsa audio use USB Sound and pulse audio got pushed to HDMI Audio, it was better as alsa audio seems to run on a lot more apps and games, Shadow Warrior had no audio when playing videos but the game now had sound (other way around before), but game also locked up when trying to exit back to desktop, It was Turok running with Crossover/wine that made me notice something was wrong as it had Music but no sound effects, cut a long story short, the answer was simple once i read up about alsa-pulse plugin, and the fix seems to be as simple as:

sudo apt-get install libasound2-plugins:i386

I had this package installed for x64 but was missing i386 version, so now its fixed, Turok works as it should with both sound and music, just going to test Shadow Warrior now and some other games.
While you're here, please consider supporting GamingOnLinux on:

Reward Tiers: Patreon. Plain Donations: PayPal.

This ensures all of our main content remains totally free for everyone with no article paywalls. We also don't have tons of adverts, there's also no tracking and we respect your privacy. Just good, fresh content. Without your continued support, we simply could not continue!

You can find even more ways to support us on this dedicated page any time. If you already are, thank you!
Login / Register

Or login with...
Sign in with Steam Sign in with Twitter Sign in with Google
Social logins require cookies to stay logged in.