Support us on Patreon to keep GamingOnLinux alive. This ensures we have no timed articles and no paywalls. Just good, fresh content! Alternatively, you can donate through Paypal, Flattr and Liberapay!
  Go to:
Tomb Raider won't start
mirv commented on 6 July 2016 at 7:35 pm UTC

I've had issues with the feral launcher and amdgpu-pro. Feral are aware of the problem, but no idea of a fix date yet. The latest Mesa works just fine, so I'd recommend that if possible. This is assuming that amdgpu-pro is in use; if you're using fglrx, seriously consider switching to Mesa anyway!

donbastiano commented on 6 July 2016 at 9:12 pm UTC

Thank you again

Info of my card and driver:
$ fglrxinfo
OpenGL vendor string: Advanced Micro Devices, Inc.
OpenGL renderer string: AMD Radeon 6600M and 6700M Series
OpenGL version string: 4.5.13399 Compatibility Profile Context 15.201.1151

With Mesa I had some performance issue, some game was unplayable

As I said I know the game could not start, I was curious also because, with surprise, I was able to play and enjoy Bioshock Infinite, mostly on medium thanks to my low resolution

At the moment I don't think problems are related to the card/driver in use and I just would like to solve them (probably to finally get the crash of the system due to my card/driver ;) )

So, for the first of the errors, gameoverlayrenderer.so, I tried to disable the steam overlay from the game property but nothing changed.

For the libasound.so.2, I tried to create a symbolic link in ~/.steam/steamapps/common/Tomb Raider/lib/i686
$ file libasound.so.2
libasound.so.2: symbolic link to `/home/donbastiano/.steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/libasound.so.2.0.0' 

(OT: is it normal that steam install lot of things/bin in the home?)
ldd now shows that the lib is found, before was "=> not found"
$ ldd TombRaider | grep asou
libasound.so.2 => /home/donbastiano/.steam/steamapps/common/Tomb Raider/bin/./../lib/i686/libasound.so.2 (0xf05c5000)

but I presume that in the terminal the environment/PATH is different, the error is still the same.
Why the symbolic link did not work?



(and sorry for my bad "English"...)

pete910 commented on 7 July 2016 at 8:17 pm UTC

PangachatFglrx patched out from the game, you must use the opensource driver (MESA 11.2)

What are you saying?

That they've patched out fglrx from working in TR?

donbastiano commented on 8 July 2016 at 1:43 pm UTC

Small update, I installed the 32 bit version
$ find ./ -name libasound.so*
./i386-linux-gnu/libasound.so.2.0.0
./i386-linux-gnu/libasound.so.2
./x86_64-linux-gnu/libasound.so.2.0.0
./x86_64-linux-gnu/libasound.so.2

but still the same error
ERROR: ld.so: object '/usr/lib/x86_64-linux-gnu/libasound.so.2' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS64): ignored.

while moving the x86_64, does not found the file
ERROR: ld.so: object '/usr/lib/x86_64-linux-gnu/libasound.so.2' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.

strange...

I think I posted in the wrong section of the forum, sorry

mirv commented on 8 July 2016 at 5:36 pm UTC

I don't think Feral support fglrx, so future patches may break things. There's a chance that another patch may fix this issue again, depending on what the cause is. I doubt it's libasound, but...well...never know really! Steam likes to complain about a few things, which can generally be safely ignored.
Mesa is also generally better to play games with at this point; devs will try to at least test internally with it more than fglrx, even if there's no official support listed in the game specs. That the Feral launcher doesn't appear just sounds too similar to my own problem, so it might get corrected soon.
Otherwise, try get as close to bleeding edge with Mesa and LLVM as you can, and use those. I think your chipset uses the r600 "drivers" (stack) - which, sadly, aren't as good as radeonsi. I suspect you'll still be able to get the game playable however, one way or another.

The only other option you might want to try, given enough days to ensure it's a GNU/Linux sale, is with with wine & gallium9. You'll need Mesa support for it, however that's done with your distro (can't help there sorry, unless you have Gentoo). I doubt you'll get any better performance, if it runs at all, but it's worth a shot if you're out of other options.

donbastiano commented on 8 July 2016 at 7:50 pm UTC

Thank you, so you suggest that the real problem can be different and related to the driver/card. What about install another distro (maybe Ubuntu 16.04) in another partition and share the home for this test? Anyone can see particular problem with steam?
I think the same about the driver, r600.

I'm on Ubuntu 14.04, I left Gentoo maybe a couple of year ago.

donbastiano commented on 9 September 2016 at 8:30 am UTC

Just a small update, after moving to 16.04 so open driver and deleting the .steam folder (except the userdata and steamapps forlders) the game now starts. It is impossible to play also on all minimum/off, the benchmark returns min 1.4 avg 8.4 max 11.4. A little strange is that also the initial video is lagging.

manero666 commented on 9 September 2016 at 1:32 pm UTC

I saw on another post that you installed the Oibaf PPA.
You can install a Gallium Nine patched Wine and try the game with it.
This can be a solution while waiting the open-source drivers to mature a bit more

You will miss some Linux and Dx11 specific graphical settings but I guess you won't need them anyway

donbastiano commented on 9 September 2016 at 2:27 pm UTC

Thank you, for this game it was just a test, my hardware is not good enough. As said, I was just curious because I was able to play Bioschock Infinite without problem.
I can wait to play it, I'm thinking to buy a new pc hoping to resist until zen/vega but it is hard...

  Go to:

You need to Register and Login to comment, submit articles and more.


Or login with...

Livestreams & Videos
Community Livestreams
See more!
Popular this week
View by Category
Contact
Latest Comments
Latest Forum Posts