You can sign up to get a daily email of our articles, see the Mailing List page!
New laptop with performance problems (Nvidia?)
Page: «2/2
  Go to:
damarrin 28 Dec, 2016
OFC the res is lower; I set it to 1920x1080 fullscreen but it looks like it ignored the setting. Re-ran it windowed at 1080p and:

FPS:
4.4
Score:
186
Min FPS:
3.0
Max FPS:
7.5

Personally, I've never had performance problems with Nvidia drivers. Have you looked at the Nvidia control panel to see if some setting seems off?
Xpander 28 Dec, 2016
well normal numbers for 330M, but 965M should have the performance of the desktop GTX 950 or similar. even my 660Ti got over 40 fps in valley as average and 660Ti should be slighly slower. something is seriously odd in the system.
Liam Dawe 28 Dec, 2016
Are you sure it's actually using the NVIDIA GPU and not the Intel one? What are you using to access the NVIDIA chip? PRIME from the Nvidia driver options, or bumblebee?
rodvil 29 Dec, 2016
I'm using Prime from the Nvidia options. And it's always set for Nvidia because when I set it to intel Unity doesn't start.
Regarding the Nvidia settengs I didn't touch it from the beginning. I tried turning off the "Sync to VBlack" but I didn't feel any change so I turned it back on. Shcoul I check any other setting options?

Also, could it be from something other than the graphic driver?
While you're here, please consider supporting GamingOnLinux on:

Patreon, Liberapay or PayPal Donation.

We have no adverts, no paywalls, no timed exclusive articles. Just good, fresh content. Without your continued support, we simply could not continue!

You can find even more ways to support us on this dedicated page any time. If you already are, thank you!
Login / Register

Or login with...
Sign in with Steam Sign in with Twitter Sign in with Google
Social logins require cookies to stay logged in.

Livestreams & Videos
Community Livestreams