Use Reddit? Join us on our very own subreddit: https://www.reddit.com/r/Linuxstuff/
You can sign up to get a daily email of our articles, see the Mailing List page!
Support us on Patreon to keep GamingOnLinux alive. This ensures we have no timed articles and no paywalls. Just good, fresh content! Alternatively, you can support us on Paypal and Liberapay!
  Go to:
The Witcher 3 in Wine
Shmerl commented on 19 March 2018 at 8:49 pm UTC

sebishI test the jaen's procedure, and same problem...
In the debian depot, two driver exist :
- nvidia-vulkan-icd
and
- nvidia-nonglvnd-vulkan-icd

What is the différent ?

I'm not using Nvidia, so not sure, but I thought glvnd in general is needed for OpenGL loader. Why is it connected to Vulkan?

Try each of those see if it makes any difference.

mmtrt commented on 20 March 2018 at 8:05 am UTC

Pependos
jaen7. at this point you should be able to run
WINEPREFIX=where/you/want/to/put/it wine where/you/want/to/put/it/drive_c/VulkanSDK/YOUR_VERSION_HERE/Bin/cube.exe

If I launch cube.exe with double-click:
image

And via terminal:
bash: /home/dron/.wine/drive_c/VulkanSDK/1.0.68.0/Bin/cube.exe: can not run a binary file: Error in the format of the executable file

Don't use wine-devel 3.4 it does not work I had same issue yesterday installed it I was having same error as you also non of other wine setups that I had on different directories were working with wine-devel installed so I purged wine-devel and remove any prefixes folders from home then rebooted system and finally setup wine from directory with thanks for @Shmerl scripts I slightly modified for my needs and now I can run cube.exe 32bit and 64bit version without any issue.

Shmerl commented on 20 March 2018 at 3:56 pm UTC

Yes, all these issues are likely wine versions confusion, messing up the prefix.

sebish commented on 20 March 2018 at 5:16 pm UTC

QuoteDon't use wine-devel 3.4 it does not work I had same issue yesterday installed it I was having same error as you also non of other wine setups that I had on different directories were working with wine-devel installed so I purged wine-devel and remove any prefixes folders from home then rebooted system and finally setup wine from directory with thanks for @Shmerl scripts I slightly modified for my needs and now I can run cube.exe 32bit and 64bit version without any issue.

You don't use wine-devel 3.4 from depot and compil wine 3.4 or wine-vulkan ?

pingubot commented on 20 March 2018 at 6:20 pm UTC

Hi all,

for those guys which have troubles with wine vulkan, please check if you have other vulkan drivers in addition to the nvidia one on your systems. I had the problem in the past that wine-vulkan did not work on my system with a nvidia card until i uninstalled the intel and amd vulkan drivers (libvulkan_intel.so / libvulkan_radeon.so). In theory this should not cause issues but it does, roderickc confirmed that.


Cu,
Christian

Shmerl commented on 20 March 2018 at 6:58 pm UTC

If that's the case, you can explicitly set the variable to point to the correct Vulkan driver.

VK_ICD_FILENAMES=<path_to_your_system_icd.json>

mmtrt commented on 21 March 2018 at 8:11 am UTC

sebishYou don't use wine-devel 3.4 from depot and compil wine 3.4 or wine-vulkan ?
I'm using wine-stagging tar from lutris and installed wine deps of both arch.

lod commented on 21 March 2018 at 3:49 pm UTC

any idea whats happening here?
image

http://ix.io/10v5

YoRHa-2B commented on 21 March 2018 at 3:50 pm UTC

Try mesa-git.

Shmerl commented on 21 March 2018 at 3:51 pm UTC

Seems similar to the water bug. Could be a radv issue: https://bugs.freedesktop.org/show_bug.cgi?id=105464

  Go to:

Due to spam you need to Register and Login to comment.


Or login with...

Livestreams & Videos
None currently, submit yours here!
See more!
Popular this week
View by Category
Contact
Latest Forum Posts