Confused on Steam Play and Proton? Be sure to check out our guide.
Linux (with Steam) on GPDWin handheld
Page: «4/4
  Go to:
Julius Feb 10, 2020
Ah, yeah that feature request is from me actually.

When I was on an older stock Kernel the 8GB SD card I had worked, although sometimes it required a few attempts to get recognized. But maybe this got even more broken with later releases or your hardware is indeed slightly different.

Hmm, but maybe check the formatting of these cards. Exfat might not work out of the box.

Sorry to not be of more help for now, but I hope you can enjoy your GPDWin1 with Linux never the less.
greytega Feb 10, 2020
Oh Absolutely, I've already been really enjoying it. Thanks to Ubuntu only really taking up around 5GB (compared to Windows 30+) The onboard 64GB is actually pretty good, and since there are a ton of Steam games native to Linux along with Proton & GOG having linux games. Include all the free/cheap : having a handheld x86 based machine is just amazing. I'm very happy with Linux running on this even if I never get the SD card reader working.
Julius Apr 17, 2022
Updating to Ubuntu 22.04 worked fine (which stock 5.15 Kernel), but I decided to try switching it to Manjaro to "SteamDeckify" it. It seems to boot the Manjaro install USB fine, so I will give it a try later today.

This seems to be a nice guide to get the SteamDeck UI to work on Manjaro:

EDIT: ehh, I forgot that these Cherry Trail devices seem to have 32bit UEFI which makes installing normal 64bit Manjaro a chore... but I only remembered after wiping the build in emmc etc. and having the install fail :( I guess this will take a bit longer to fix.

Edit2: Ok I guess the easiest way will be to reinstall the Ubuntu Mate for GPDPocket image:
And then follow this guide to get Manjaro installed (Edit doesn't work for me):

A bit annoying that I messed this up because I knew previously that this was an issue *face palm*

Edit3: that Manjaro Forum tutorial didn't work, but after installing the Ubuntu Mate version I could over-write the Installatiion via the official Manjaro boot iso by selecting manual partition and there mount the existing fat32 as /boot/efi and the rest mounted as /
Works now, but I still need to look into getting Gamescope and the SteamDeck UI to work.

Last edited by Julius on 17 April 2022 at 9:53 pm UTC
Julius Mar 28
Fedora 38 beta installs and runs in the GPD Win 1 out of the box without any issues, quite a surprise after the installation issues I had with other distributions.
While you're here, please consider supporting GamingOnLinux on:

Reward Tiers: Patreon. Plain Donations: PayPal.

This ensures all of our main content remains totally free for everyone with no article paywalls. We also don't have tons of adverts, there's also no tracking and we respect your privacy. Just good, fresh content. Without your continued support, we simply could not continue!

You can find even more ways to support us on this dedicated page any time. If you already are, thank you!
Login / Register

Or login with...
Sign in with Steam Sign in with Google
Social logins require cookies to stay logged in.