Support me on Patreon to keep GamingOnLinux (and me) alive. Funding me on Patreon allows us to have no adverts, no paywalls, no timed articles. Just good content for you to keep up with Linux gaming. Alternatively, you can support me on Paypal.
Performance issues in some games only
fryk commented on 19 June 2017 at 10:33 am UTC

Hi there!
I'm having performance issues on my new (well, not so new anymore) PC.

Specs:
- Ubuntu 16.04.2
- Intel Core i7-6700 3,4 GHz
- 32 GB RAM
- MSI GeForce GTX 1070 ARMOR 8G OC (381.22 driver)
- ASUS PG27AQ G-SYNC UHD Monitor (3840 Ă— 2160 px)
- SSD and HDD

There are some games that have massive performance issues while in full screen mode. Windowed (same resolution, same settings) they run really smooth. Setting the resolution down to full HD or setting graphics to "low" doesn't change anything as well as whether the games are installed on SSD or HDD. It feels a bit like watching online videos with a really bad connection.... :-/ ... game is loading for many seconds, and then go on a tiny little bit. Here is a list of the games that make problems:
Stardew Valley (The mines are kind of impossible to walk in, the rest works most of the time.)
Dying Light (intros / videos are laging really bad. Some areasin the game work fine, some don't)
Sanctum 2 (the whole game is not performing well)
Dungeon Defenders (the whole game is not performing well)

On many other games, even with higher requirements, I don't have these issues.

Does anyone else have these problems? Is there a solution? I searched the internet for a while but didn't find anything similar (maybe used the wrong terms?).

Thanks a lot!

Ehvis commented on 19 June 2017 at 11:02 am UTC

I think you're running into the G-SYNC problem. This is why it only happens on fullscreen. According to NVIDIA, some games don't do their implementation of flipping correctly (or using a frame limiter), which makes it interfere with the VSYNC setting. The net effect is that when VSYNC and G-SYNC are both turned on, the driver gets heavily confused and massacres your framerate.

Unfortunately, the only fix is to turn off either VSYNC or G-SYNC for that particular game. Or the actual devs of the game need to fix their engine.

Off the top of my head, I have these problems with the following games:

Rocket League
Dead Island DE
Euro Truck Simulator 2
American Truck Simulator

Probably a few more, but I can't recall at this time.

fryk commented on 19 June 2017 at 11:19 am UTC

Thanks a lot! I'll check it out later when I'm at home.

fryk commented on 19 June 2017 at 9:39 pm UTC

Yes! Awesome! Turning off gsync or vsync really does help!

Due to spam you need to Register and Login to comment.


Or login with...

Games & Release Calendar
Livestreams & Videos
Popular this week
View by Category
Contact
Latest Forum Posts
Facebook