You can sign up to get a daily email of our articles, see the Mailing List page!
Support me on Patreon to keep GamingOnLinux alive. Funding me on Patreon allows us to have no adverts, no paywalls, no timed articles. Just good content for you to keep up with Linux gaming. Alternatively, you can support me on Paypal.
RX Vega 56 - No 3D hardware accelleration?
elo commented on 14 September 2017 at 5:51 am UTC

Hello all!

As I've been a Nvidia user for a long, long time I must admit that I find AMD on linux kind of confusing. Of course, the fact that support isn't in the kernel yet does complicated things a little bit.

So, yesterday I installed archlinux and did something along the lines of:
Add mesa-git repo Install mesa-git and lib32-mesa-git Install linux-amd-staging

After a the reboot I was so happy! It booted into gnome desktop with no problems at all. No tearing. No issues what so ever. I can also confirm that amdgpu is the driver in use.

However, my happiness quickly turned into confusion as any 3d game seems to run with software rendering or at least doesn't utilize much of the GPU at all. (Rust for instance was pretty much locked to less than 1 fps)

Running radeon-profile the GPU utilization graph is flat. No matter what game I try.

So, to me, it feels like 2d accelleration works but 3d doesn't. Am I missing something crucial to make it work?

Today I plan on testing on Windows (just to make sure it works as expected) and on Ubuntu with amdgpu-pro.

elo commented on 14 September 2017 at 11:25 am UTC

Little update: Card works really well in windows, ignoring the fact that windows is absolutely terrible

Tried in Ubuntu with linux-amd-staging and mesa-git, 1 fps kind of performance still. Something isn't right here.

Might try amdgpupro next.

elo commented on 15 September 2017 at 11:04 am UTC

AMDGPU Pro worked better - but still not really successfully.

Gave up yesterday and went back to my old nvidia card, but we are carrying on with the testing after some motivation from the GoL discord!

So, after some more fiddling we've finally managed to make a difference, at least. No video output what so ever! At least it's a step in some direction.

pete910 commented on 16 September 2017 at 2:25 pm UTC

Isn't llvm 5 needed for vega and mesa ?

elo commented on 18 September 2017 at 5:17 am UTC

llvm 5 is indeed needed but that wasn't the issue.

Still not 100% sure of what went wrong the first few times but we do have it running now. It's rather unstable (system lockups) but it works, I'm so happy!

For now I'll dualboot for gaming (still just linux compatible games of course) as freezing in certain situations sucks a bit too much


So, long story short: Switched to ubuntu and the M-Bab kernel and followed the m-bab instructions. Everything works.

Due to spam you need to Register and Login to comment.


Or login with...

Popular this week
View by Category
Contact
Latest Forum Posts
Facebook