You can sign up to get a daily email of our articles, see the Mailing List page!
Support us on Patreon to keep GamingOnLinux alive. This ensures we have no timed articles and no paywalls. Just good, fresh content! Alternatively, you can support us on Paypal and Liberapay!
  Go to:
[Solved] Stalled requests with high paging settings
jens commented on 12 October 2017 at 7:29 pm UTC

Hi,

Within my profile I have set the following:
Comments & forum posts per-page: 50
Articles per-page, for homepage and category (tag) view: 25

After doing that some links, e.g. jumping from a notification directly to a message, are very very slow. The request, e.g. https://www.gamingonlinux.com/index.php?module=articles_full&aid=10447&comment_id=105433&clear_note=51266 seems to stall. I have to close and open my browser to navigate again. The site though is fast when navigating from the front page and not by notifications. I experience the same when posting a reply to a longer thread. My message got posted, but redirecting to the result seem to stall.

liamdawe commented on 12 October 2017 at 7:51 pm UTC

Interesting, just to check something, do you have any users blocked? Don't need names, even if it's just one person a yes or no will do. Just to narrow it down.

jens commented on 12 October 2017 at 8:00 pm UTC

liamdaweInteresting, just to check something, do you have any users blocked? Don't need names, even if it's just one person a yes or no will do. Just to narrow it down.
Nope, no blocked user(s).

liamdawe commented on 12 October 2017 at 8:08 pm UTC

Okay, I did an adjustment for when you're hitting a notification. Can you re-test?

jens commented on 12 October 2017 at 8:28 pm UTC

No, sorry ,still the same.

liamdawe commented on 12 October 2017 at 8:32 pm UTC

How long are we talking? For me it's practically instant.

jens commented on 12 October 2017 at 8:41 pm UTC

OK, eventually something was still cached om my side, seems a lot faster now. Thanks!

liamdawe commented on 12 October 2017 at 9:50 pm UTC

Glad to hear it, as if it's fine my end then it can't have been the code, unless you did have hundreds of people blocked it had to remove posts for before displaying

jens commented on 13 October 2017 at 3:04 pm UTC

No, sorry, it is still broken for new notifications. I guess the issue happens when first something needs to be updated in your database (marking a notification as read). It's not just seconds, the request seems to hang forever.

liamdawe commented on 13 October 2017 at 7:24 pm UTC

Since I have never encountered the issue and no one else has reported it, it's going to be hard to track down.

What browser and what plugins are you using?

Considering the amount of topics i end up following and the amount of notifications I get constantly, it's been tested extensively.

Edit: I just made a minor improvement to the handling. Who knows, maybe it will help.
Edit #2: Okay, I've made another adjustment that actually reduces the amount of MySQL queries it needs to do, by cutting one out completely.

jens commented on 13 October 2017 at 8:52 pm UTC

Thanks, I'll report back. I don't get that much notifications
To clarify: I never had this before I changed my paging settings, so quite sure it's related to that.

PS: I do see notifications in the notification center for regular threads, but not from the forum here. is this correct? I'm "subscribed without e-mail".

  Go to:

Due to spam you need to Register and Login to comment.


Or login with...

Livestreams & Videos
None currently, submit yours here!
See more!
Popular this week
View by Category
Contact
Latest Forum Posts
Facebook