Check out our Monthly Survey Page to see what our users are running.
Dying Light requires OpenGL 3.3 found 3.0 | Please upgrade OpenGL
SkaMan commented on 22 November 2017 at 10:46 pm UTC

Fair warning, I'm a gaming on Linux noob.

So, as the title suggests, when I try to launch Dying Light through Steam, I get a warning about my OpenGL version. The game then launches, but all I get is a black screen and some sound. I tried finding some articles about upgrading OpenGL on Ubuntu, though most of them were for 14 LTS or earlier.

System:
Xubuntu 17.10
AMD R9 270

I installed Mesa running:
sudo add-apt-repository ppa:ubuntu-x-swat/updates
sudo apt update && sudo apt dist-upgrade


OpenGL version (short)
:~$ glxinfo | grep "OpenGL version"
OpenGL version string: 3.0 Mesa 17.2.4


OpenGL version (long)
:~$ glxinfo | grep OpenGL
OpenGL vendor string: X.Org
OpenGL renderer string: AMD PITCAIRN (DRM 2.50.0 / 4.13.0-17-generic, LLVM 5.0.0)
OpenGL core profile version string: 4.5 (Core Profile) Mesa 17.2.4
OpenGL core profile shading language version string: 4.50
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.0 Mesa 17.2.4
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.1 Mesa 17.2.4
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.10
OpenGL ES profile extensions:


Is there anything I can do? Is it worth trying to uninstall the Mesa drivers by removing the mesa ppa and do another dist-upgrade? Can I upgrade OpenGL desperately from Mesa?

Thanks in advance for any help

crt0mega commented on 23 November 2017 at 6:52 pm UTC

Dying Light has some issues with Mesa, especially for detecting the right Open GL Version which is 4.5 with GLSL 4.50 in your case:

SkaManOpenGL core profile version string: 4.5 (Core Profile) Mesa 17.2.4
OpenGL core profile shading language version string: 4.50
According to the wiki Dying Light might run with some version overrides:

wikiWith OpenGL core profile 4.5 and OpenGL version string 3.0, game opens a pop up saying OpenGL has to be 3.3 at least and it detects 3.0. Launching with MESA_GL_VERSION_OVERRIDE=4.5 MESA_GLSL_VERSION_OVERRIDE=450 fixes it. I tried with override 3.3 and 330 but it didn't work.
To get Dying Light running you just need to put this to Dying Light's launch options in steam:
MESA_GL_VERSION_OVERRIDE=4.5 MESA_GLSL_VERSION_OVERRIDE=450 %command%

SkaManIs there anything I can do? Is it worth trying to uninstall the Mesa drivers by removing the mesa ppa and do another dist-upgrade? Can I upgrade OpenGL desperately from Mesa?
There are some PPAs with newer and/or development versions of Mesa. 17.2.4 is just slightly outdated, current stable Version is 17.2.5.

SkaManFair warning, I'm a gaming on Linux noob.
We've all been Linux gaming noobs in the past Don't worry. It may take some time, but you'll get used to it. It's not as hard as it has been a decade ago.

pete910 commented on 23 November 2017 at 7:58 pm UTC

Unfortunate it only works on *buntu/Mint on AMD

No clue why it refuses on other distros even with same mesa version ect

crt0mega commented on 23 November 2017 at 8:58 pm UTC

pete910Unfortunate it only works on *buntu/Mint on AMD

No clue why it refuses on other distros even with same mesa version ect
Hmmm, that's weird O.o These environment variables should be distro-agnostic ...

You need to Register and Login to comment, submit articles and more.


Or login with...

Livestreams & Videos
None currently, submit yours here!
Popular this week
View by Category
Contact
Latest Comments
Latest Forum Posts