You can sign up to get a daily email of our articles, see the Mailing List page!
Support us on Patreon to keep GamingOnLinux alive. This ensures we have no timed articles and no paywalls. Just good, fresh content! Alternatively, you can support us on Paypal and Liberapay!
  Go to:
Nvidia : fast games, sluggish kwin, noisy :-(
Bidinou commented on 13 January 2018 at 9:46 am UTC

Hi everyone !

I'm a KDE Neon user and both long term KDE and Nvidia user.

Until recently, I always found the performance of kwin & other desktop environments to be OK. Usually I found it even better with KWin. That is to say, animations are overall smooth, but some not so much, and it usually is quite responsive although maybe it could be a little bit better. I use proprietary drivers and use the tweak to prevent vsync issues with kwin + nvidia.

I decided to drop my GTX 1050 and try with the built-in Intel HD Graphics HD 530. Not so much time to play anymore.

I was SHOCKED : Kwin is so butter smooth with it, it feels way more responsive and smooth. It was not that bad before but it's absolutely perfect with no tweak at all with a much much slower piece of hardware. I would say in one case it is acceptable and in the other it is perfect.

Then I tried a 1060 GTX. I thought it would probably not be that bad. I must say that meanwhile I had got so used to the Intel HD Graphics performance. Now I cannot stand the kwin performance anymore with Nvidia !

Games run stellar with the Nvidia while I can just play simple ones with the Intel. On the other hand I'm just a casual gamer, I enjoy indie, 2D titles and emulators and the desktop feels so much better with the IHD.

Is there anything at all I can do to improve the performance of kwin ? I know the kwin dev struggles with nvidia boards because of their being closed source, but still... That's quite frustrating.

BTW : my GTX 1060 ZOTAC AMP! edition is supposed to be 100% silent outside of games, it's clearly specified in the reviews I read. The fan is not supposed to spin unless you're playing. On my desktop it's constantly spinning at 40% which makes a lot of noise considering I have a quite silent machine (fanless :-) i3, not too noisy power supply, a couple of big & slow case fans). Anything to do about it ? With coolbits ?

Thanks everyone :-)

tuubi commented on 13 January 2018 at 10:50 am UTC

No recent experience with kwin, but you're absolutely right that Nvidia is worse for non-game use on Linux. The Xfce+Compton desktop on my gaming box is quite smooth (with a custom Compton config), but not as smooth as my other machines on Intel.

Have you checked the temperature of your GPU in the Nvidia settings? If the case is constantly hot due to insufficient cooling, the fans on your GPU will have to compensate. At idle my GTX 960 (Asus Strix) stays around 34c and the fans don't spin up.

Bidinou commented on 13 January 2018 at 2:21 pm UTC

Hi ! Thank for your reply !

That's really frustrating... I cannot believe they've not addressed this general performance issue in years. As if they didn't care (but they do as they provide use with updates constantly). There is also this Wayland EGLStreams controversy. I remember there were tweaks that could be used under KDE (like Raster mode in Qt but I don't know if it's still valid ; or setting "export __GL_YIELD=USLEEP", or forcing triple buffering, or even disabling Twinview (also valid for Compiz)... It's been a decade and a half I've been trying to work around those same issues and remained faithful to Nvidia because their GPUs really rock for gaming under Linux.

But seeing some 5 year-old Intel HD Graphics perform way better for desktop use could be the last straw for me.

Still, as I have this 1060 GTX, I wish I could find yet another work-around. Or I'll sell it.

Regarding fans, the temperature is quite low and they spin right from the start. This specific Zotac 1060 is supposed no to need to have them turned on. It's also frustrating to see the Nvidia control panel just enabled to manually set a constant fan speed.

Some people wrote simple scripts to set the fan speed depending on the temperature. Yet another work around

Cheers !

Xpander commented on 13 January 2018 at 2:46 pm UTC

weird, no issues here, but then again i don't use kwin. Just marco + compton. Desktop is super responsive and smooth, i do have 144hz monitor so would notice any lag if it isn't working as expected. The only thing that nvidia driver sucks is the performance of TTY's. In that area AMD GPUs are much much better.


edit: Noise thing depends on the model i guess. My EvGA GTX 1070 is super quite in every scenario, on desktop its 139mhz core and 405mhz memory only and super quiet, goes up to 1980mhz core in gaming and ramps up the fans a bit but still staying really quiet.

tuubi commented on 13 January 2018 at 3:02 pm UTC

As I said, the desktop is fast and smooth enough for me on Nvidia, but the experience is slightly better on open drivers. No issues with noise or temperatures with my GTX 960 though. Might be a problem with that particular Zotac.

Bidinou commented on 13 January 2018 at 3:31 pm UTC

I guess it's good enough... for them not to bother improve the situation. Well... It's mostly smooth as I said but feels perfect with the Intel HD.

Regarding the gpu fans, is it up to the drivers or to the card firmware ? I really read in reviews they were not supposed to spin when idle... I also bought it because my case has a specific form factor. Couldnt close it due to the pcie power suply with the gigabyte 1060 !

Edit : BTW desktop effects are smooth with the Nouveau driver than with Nvidia's :-/

Bidinou commented on 13 January 2018 at 4:12 pm UTC

OMG ! I downgraded from Nvidia 390.x to 387.x, and it seems to feel smoother (and maybe a little less noisy too)... Still not as perfect as with the Intel driver, but better...

What the hell !

edit : false hope, see below

riusma commented on 13 January 2018 at 4:16 pm UTC

BidinouRegarding the gpu fans, is it up to the drivers or to the card firmware ? I really read in reviews they were not supposed to spin when idle... I also bought it because my case has a specific form factor. Couldnt close it due to the pcie power suply with the gigabyte 1060 !

I've the MSI 1060 6Go Gaming and the fans are in idle state bellow 60 °C (above 60 °C you can hear a very soft noise from the fans as it's not a noisy GPU), which you can checked with P-sensor (and ears obviously ^^). At least in this case the two mods (fanless or not) come from the card firmware (not the drivers) according the documentation.

Bidinou commented on 13 January 2018 at 4:19 pm UTC

@riusma : thanks ! At this very moment, nvidia-settings reports : 42°C, fans at 38% speed. Does it report 0% speed for you then ?

@all : after applying the v-sync Tweak, actually, I'm not that sure that's smoother :-/
This one : https://forum.manjaro.org/t/screen-tearing-in-kde-with-nvidia-card/7956/12
Is there a better one ? It must be placebo but I even feel there is a very slight lag even when I'm just typing text ! Does any of you force triple buffering instead (in xorg.conf and/or as an env variable ?)

Bidinou commented on 13 January 2018 at 4:29 pm UTC

Oh no it's worse than I thought. Framerate on the desktop is unstable. You can see it by just raising the start menu or pulling the Yakuake terminal... It's not "horrible" but...

riusma commented on 13 January 2018 at 4:30 pm UTC

Bidinou@riusma : thanks ! At this very moment, nvidia-settings reports : 42°C, fans at 38% speed. Does it report 0% speed for you then ?

From P-sensor (which probably make use of Nvidia proprietary drivers to access data) my GTX 1060 6Go gives me 37 °C and fans rpm at 0 Tr / min! (for the record nvidia-settings gives me the same values but I don't use that software that much as it doesn't play well with the calibration profiles of my displays).

Generally my GPU is in fanless mod when I'm not gaming.

  Go to:

Due to spam you need to Register and Login to comment.


Or login with...

Livestreams & Videos
Community Livestreams
See more!
Popular this week
View by Category
Contact
Latest Forum Posts
Facebook