You can sign up to get a daily email of our articles, see the Mailing List page!
Support us on Patreon to keep GamingOnLinux alive. This ensures we have no timed articles and no paywalls. Just good, fresh content! Alternatively, you can donate through Paypal, Flattr and Liberapay.!
  Go to:
SteamPlay compatibility list
rcgamer commented on 19 November 2018 at 2:47 am UTC

DoctorJunglistSomeone on ProtonDB posted a really nice guide to get GTA IV running.

It's nice to finally be able to play my Steam version of the game (before, only the pirated version would run via Wine for me).

Nice, it works great.

emaniter commented on 20 November 2018 at 6:18 pm UTC

Hi guys,

I don't know if this is the right place to request some input but here it goes. I bought Frostpunk (id 323190) a couple of months ago and I'm struggling to get it to work with Proton. I submitted my original issue to Proton's github repo:

https://github.com/ValveSoftware/Proton/issues/412#issuecomment-421671114

I updated my system in the meantime so I'm now on 4.19.2-arch1-1-ARCH with Proton 3.16-4 Beta, but still no dice. The nvidia driver version is 410.73. I've tried different launch options like the ones described here: https://bbs.archlinux.org/viewtopic.php?id=227149

Or removing some legacy libraries as described here:

https://github.com/ValveSoftware/steam-for-linux/issues/3820#issuecomment-150706996

https://bbs.archlinux.org/viewtopic.php?pid=1417306#p1417306

Or even installing .NET as described here:

https://www.reddit.com/r/wine_gaming/comments/8r6low/guide_how_to_install_net_45_on_64bit_prefixes/

https://github.com/ValveSoftware/Proton/issues/18

https://github.com/Winetricks/winetricks/issues/917

Also tried uninstalling and reinstalling. Just wondering if anyone here encountered the same issues and found a feasible workaround. The suggestion on that github issue to remove autosaves didn't do it either.

Thanks

Comandante Ñoñardo commented on 22 November 2018 at 5:08 am UTC

Aaaand... I created another Steam account related with this.
Now I have to add funds and start to buy games that fits with the criteria.

bintsmok commented on 27 November 2018 at 10:42 am UTC

Anyone here tried Darksiders III on Linux through Steam Play 2.0 ? How was it?

Comandante Ñoñardo commented on 27 November 2018 at 7:33 pm UTC

I would like to see Dishonored 2 and Middle Earth: Shadow of War testings with 3.16-4

All tests available at ProtonDB were made with old versions of Proton. Maybe the new version works.

debianxfce commented on 29 November 2018 at 10:05 am UTC

emaniterI bought Frostpunk (id 323190) a couple of months ago and I'm struggling to get it to work with Proton.

There are many games that do not work with Proton but works with latest wine-staging and dxvk. Use the windows Steam client.

winehq

legluondunet commented on 29 November 2018 at 10:13 am UTC

So much time without Steamplay news, I'm like an addict without his drug.

bintsmok commented on 3 December 2018 at 6:13 am UTC

To those using Radeon GPU + Mesa, Doom 3 BFG Edition runs on Linux through Steam Play but you need the Steam Launch Option below.

MESA_GL_VERSION_OVERRIDE=4.5COMPAT allow_glsl_builtin_variable_redeclaration=true force_glsl_extensions_warn=true PROTON_NO_ESYNC=1 %command%

Almost all of the reports at ProtonDB using Radeon + Mesa rated Doom 3 BFG Edition as BORKED. The game runs but main menu is displayed as a white screen only. There is one report using Radeon HD 7900 + Mesa 19.0.0 that shared the Steam Launch Option and it rated the game as SILVER.

I tried that Steam Launch Option and the game displayed correctly and I was able to play it. My PC has Radeon RX 580 + Mesa 18.2.4.

I hope this helps.

bintsmok commented on 5 December 2018 at 7:16 am UTC

Just Cause 4 now has a GOLD rating at ProtonDB - 2 PLATINUM reports and 1 BORKED report.

One of the PLATINUM reports used Mesa 19.0.0 + Proton 3.16-4 beta.

https://www.protondb.com/app/517630

Comandante Ñoñardo commented on 8 December 2018 at 5:15 am UTC

As You must know, Shadow of the tomb Raider now has a TRIAL version...
I downloaded it and it works out of the box...
And, like the previous games, it has a Benchmark.

image

image

image

image

image
image
image

I hope the new Nvidia driver improve performance

  Go to:

Due to spam you need to Register and Login to comment.


Or login with...

Livestreams & Videos
Community Livestreams
  • Story Time: „Neofeud“
  • Date:
See more!
Popular this week
View by Category
Contact
Latest Comments
Latest Forum Posts