Support us on Patreon to keep GamingOnLinux alive. This ensures we have no timed articles and no paywalls. Just good, fresh content! Alternatively, you can donate through Paypal, Flattr and Liberapay!
  Go to:
USB errors at bootup after new motherboard, cpu, and video card
rcgamer commented on 6 October 2018 at 4:04 am UTC

Just upgraded almost everything and everything seems to work fine but on boot-up I keep getting a series of usb errors from port 12. I even unplugged everything and it still reported errors on this port (though fewer of them). When I use command lsusb -t no errors show at all. All devices are working fine. I'm stumped.

Guppy commented on 6 October 2018 at 4:41 am UTC

Gonna need a bit more information;

When is the issue reported; Bios or OS?

If OS have you tried booting a livecd with another os?

What exactly is the error?

It could either be a HW fault or a missing/bad driver

liamdawe commented on 6 October 2018 at 8:23 am UTC

Hmm, can you show us what the errors are? Perhaps use a phone camera if it doesn't output to a log?

tuxintuxedo commented on 6 October 2018 at 9:26 am UTC

Without any specifics it is hard to say. But just to tell you, on some kernels I get usb errors for my mouse, some kind of descriptor error. But this is nothing serious. It should be some kind of communication error on the software layer. It doesn't change anything, nor stops it from working.
You know, that the kernel likes to show us every tiny problem or bug, instead of hiding it. That's natural. If there is a certain issue (problem), that's a different matter.

rcgamer commented on 6 October 2018 at 3:51 pm UTC

liamdaweHmm, can you show us what the errors are? Perhaps use a phone camera if it doesn't output to a log?

Seems to be different messages but this last time it was" usb1 port 12 cannot enable: maybe the usb cable is bad ? " it says that 4 times then it says that same port is unable to enumerate device, then the same port connect-debounce fail. Well, here ya go

image


Maybe I missed a wire but I don't think so. I'll have to open it back up I guess to double check but I all usb ports seem to be working fine.

rcgamer commented on 6 October 2018 at 3:55 pm UTC

GuppyGonna need a bit more information;

When is the issue reported; Bios or OS?

If OS have you tried booting a livecd with another os?

What exactly is the error?

It could either be a HW fault or a missing/bad driver

It's an OS error, bios doesn't report any problem. The OS boots and works fine just the error is kind of annoying.

rcgamer commented on 6 October 2018 at 6:09 pm UTC

Updated mobo bios-didn't help
I have plugged my keyboard into every usb port and it worked with all of them.
everything works fine, bluetooth, wifi, audio in front and back ports, led on the new processor works fine also.
Anyway, system runs fine and everything, seeing those messages at bootup is just going to be one of those things that bug me.
Maybe I need to update grub, hmm.

slaapliedje commented on 6 October 2018 at 7:42 pm UTC

Internal USB port going out to the case maybe?

rcgamer commented on 6 October 2018 at 8:25 pm UTC

slaapliedjeInternal USB port going out to the case maybe?
That would be the two front ports and they work fine. Power and hdd leds and buttons work fine, mic and headphone ports also. I don't see anything not working so I guess I'll just ignore it for now.

madchaotikan commented on 6 October 2018 at 8:26 pm UTC

The error is from Linux Mint, right?

Could you try to live boot from the latest ubuntu iso (or arch or what ever is easiest for you) to see if the issue is occuring there as well?

By doing so we should be able to sort out if it is and hardware/firmware or software issue.

rcgamer commented on 6 October 2018 at 8:31 pm UTC

madchaotikanThe error is from Linux Mint, right?

Could you try to live boot from the latest ubuntu iso (or arch or what ever is easiest for you) to see if the issue is occuring there as well?

By doing so we should be able to sort out if it is and hardware/firmware or software issue.

I was just about to dl a livecd . lol. I'll report back. Yes, it's linux Mint reporting the errors at bootup. No bios problems.

  Go to:

Due to spam you need to Register and Login to comment.


Or login with...

Livestreams & Videos
Community Livestreams
  • Turn Around: „Shadowrun: Hong Kong“
  • Date:
See more!
Popular this week
View by Category
Contact
Latest Comments
Latest Forum Posts