You can sign up to get a daily email of our articles, see the Mailing List page!
Support us on Patreon to keep GamingOnLinux alive. This ensures we have no timed articles and no paywalls. Just good, fresh content! Alternatively, you can donate through Paypal, Flattr and Liberapay.!
Old Wine Wrapped Games no longer work with latest Steam beta client
Lin_Soldar commented on 10 October 2018 at 5:24 pm UTC

Hi all, not sure whether others here have tried but myself I tried to run some old wine wrapped games under the latest steam beta client namely : Iron Sky Invasion and System Shock 2 without success, the games just would not start at all and immediately closed. Wondered if this could be an issue with Proton / Steam Play so decided to opt out of the beta version of the Steam client and after restarting and downloading the updates, I was presented with an error of missing libraries, tried re-installing to no avail. So for now am busy copying 1.2Tb of my steamapps folder across the network at a lousy 100mb/s as that PC don't have a gigabit network. Hoping not to lose all my months of downloads and am only currently on a 4mb/s line to try save with our currency being flushed down the toilet.

I should have backed up those games before Steam died on me, anyway it seems the Steam runtime is missing so will use synaptic to completely remove Steam then try re-install unless there's another way?

tuxintuxedo commented on 10 October 2018 at 5:38 pm UTC

Can you elaborate?
A Wine-wrapped game doesn't need you to have Wine (or Proton) installed, they are not related.

fnordianslip commented on 10 October 2018 at 6:16 pm UTC

Hmm. I had a problem with missing i386 libraries after downgrading from the Steam beta that introduced SteamPlay back to the main branch, which by that point also supported SteamPlay.
This was on Ubuntu 16.04 x86_64.
I've had a gander in my bash history and I think that this lot fixed it for me.

735 sudo apt install libxtst6:i386
736 sudo apt install libva:i386
740 sudo apt install libvdpau1:i386
742 sudo apt install libva-x11-1:i386
746 sudo apt install libbz2-1.0:i386

There was some more cruft that I trimmed out of this list that looked like failed attempts with incorrect package names.
Hope this helps.

UPDATE: Oh, I also had to reinstall the Steam package too, but it picked up my existing Steam library in ~/.steam and worked properly again.

Edit: Removed following line from list, which doesn't seem like a valid package:
745 sudo apt install libbz2-1:i386

Xpander commented on 10 October 2018 at 6:21 pm UTC

it might be that those games use wine built against old freetype and its possibly that mint finally also updated to freetype2.8+ or 2.9+, i think old wine versions required 2.7 iirc

damarrin commented on 10 October 2018 at 9:02 pm UTC

Yeah, SS2 doesn't start for me either and I'm not on beta Steam. Ubuntu 18.04.

Lin_Soldar commented on 11 October 2018 at 3:30 am UTC

Thanks for all the support guys!

At fnordianslip unfortunately I had cleared all my cache with bleachbit just the day prior as was running out of space on my /root partition, turns out it was Timeshift chewing up all my space so have now disabled it and deleted any old backups as had no space left to even attempt doing a restore.

Thinking to spend this coming weekend doing a complete re-install and use the BtrFS file system as that apparently uses less space and is faster?

At Xpander, after the re-install will look into the possibility of the old freetype fonts being the issue.

Thanks again.

Update : Instead a doing a complete re-install of entire OS tried several times to re-install via Linux Mint's package manager with same issue of missing libraries so thought to download the installer direct from Steam and that has worked!

Still have issues with System shock 2 and Iron Sky Invasion not running but have checked in the discussions on Steam to find a work around for System Shock 2 : https://steamcommunity.com/games/221410#announcements/detail/1696055855739350561

There are most definitely issues with updates breaking things on once functioning games/software. Wish there was a way to roll back to a previous version of a game / software per title in Steam client. Seems some updates get pushed out, things no longer work for a certain platform and that's that, seems that any fixes are up to the community to try figure out.

dubigrasu commented on 12 October 2018 at 4:43 am UTC

All Wine-wrapped games from Topware (Iron Sky, Enclave, X-Blades, etc) are no longer working on newer distributions due to (like Xpander said) the older Wine used on those games conflicting with new libraries. Still working on older/stable distros like SteamOS or stable Debian, but that's no consolation for you

For Iron Sky (or other Topware games affected) you can download an older version of libfreetype6 (i386) from here: https://packages.ubuntu.com/xenial-updates/i386/libfreetype6/download (or from Mint repos eventually)
extract it somewhere (don't try to install it) and export it or preload it before running the game.
Or just copy the extracted files: libfreetype.so.6.12.1 and libfreetype.so.6 to "...steamapps/common/Iron Sky Invasion/Wine/lib" folder, next to the libwine.so* libraries.

As for System Shock 2, again, some conflicting libraries or others not found.
Try to:
Copy the file libsteam_api.so from:
"...steamapps/common/SS2/bin"
to:
"...steamapps/common/SS2"

Then add this in the launch options:
LD_PRELOAD='/usr/$LIB/libxcb.so.1' %command%

Lin_Soldar commented on 14 October 2018 at 7:01 am UTC

Thanks again dubigrasu, your help is most valued!

Actually own a few Topware titles so will try apply your same fixes mentioned here.

Would you perhaps consider a rough how to guide on problem solving and fixing issues like these? So many talented people here! Thanks to all at Gaming on Linux, what an Awesome community!

Due to spam you need to Register and Login to comment.


Or login with...

Livestreams & Videos
Community Livestreams
See more!
Popular this week
View by Category
Contact
Latest Comments
Latest Forum Posts