You can sign up to get a daily email of our articles, see the Mailing List page!
Support us on Patreon to keep GamingOnLinux alive. This ensures we have no timed articles and no paywalls. Just good, fresh content! Alternatively, you can donate through Paypal, Flattr and Liberapay.!
How to get a triple-buffering/fast-sync like setting for (at least) ROTTR (kwin)
kokoko3k commented on 15 October 2018 at 2:51 pm UTC

In the past i struggled to play in a smooth way to rottr; my setup includes a 1600x1200 screen resolution and a gtx1060
Fps at high settings were between 40 and 80, a big range!
Sadly, activating vsync in the game locked the fps to 30 or 60 and force nvidia composition pipeline ended up in a jerky motion even when using strangle.

So... by pure mistake, i left the kwin opengl compositor enabled (with vsync on/full scene repaint) *AND* enabled vsync in the game too.
Then i started the game with strangle to lock the fps to 60, and, to my great surprise, the fps in the game was not locked to 15/30/60; there was no tearing, and the game was incredibly smooth at 60fps, and good at 50fps too!
The downside is 1 or 2 frame lagging, and the usual 5% performance loss due to the compositor running (but force full composition pipeline has the same overhead, so...)

I've yet to try this with other vulkan games

I don't know if this could be compared to the old opengl triplebuffering or to fast-sync by nvidia because i just did not understood why all of this happened, maybe somebody could explain it?

stan commented on 15 October 2018 at 6:53 pm UTC

I’ve tried libstrangle with ROTTR but it did nothing, despite the new vulkan support. (On nvidia too, but not kwin, Openbox/compton.) I’m still waiting for a good solution to play that game…

kokoko3k commented on 15 October 2018 at 8:09 pm UTC

Strangle does limit the fps for me in vulkan too, maybe you need to rebuild it?

kokoko3k commented on 17 October 2018 at 4:26 pm UTC

I just found another trick, this one mimics adaptive-vsync found on windows drivers.

On nvidia cards, if you unckeck "allow flipping", in the driver configuration gui (or just do nvidia-settings -a AllowFlipping=0), and enable vsync in the game options, you actually get vsynced motion when fps is >= than the refresh rate, and tearing when it goes down; no compositor have to be running.
Actually i'm playing with this settings; plus i lowered the refresh of my monitor to 50hz to get a more solid/yet still smooth framerate.
Works in mad max too.

Due to spam you need to Register and Login to comment.


Or login with...

Livestreams & Videos
Community Livestreams
See more!
Popular this week
View by Category
Contact
Latest Comments
Latest Forum Posts