You can sign up to get a daily email of our articles, see the Mailing List page!
Support us on Patreon to keep GamingOnLinux alive. This ensures we have no timed articles and no paywalls. Just good, fresh content! Alternatively, you can donate through Paypal, Flattr and Liberapay.!
  Go to:
Nvidia 415.18 is out
rcgamer commented on 20 November 2018 at 8:00 pm UTC

Today there is a new driver out.
https://www.nvidia.com/Download/driverResults.aspx/140282/en-us

Fixed a bug that caused corruption on vkCmdCopyImage calls for non-2D texture targets.
Fixed a bug that caused mode switches to fail when an SDI output board was connected.
Fixed a bug that could cause rendering corruption in Vulkan programs.
Added a new hook script, "pre-unload", to the nvidia-installer hook script system. This script, if present, will be executed before nvidia-installer attempts to unload existing NVIDIA kernel modules.
Fixed a bug that caused vkGetPhysicalDeviceDisplayPropertiesKHR() to occasionally return incorrect values for physicalResolution.
Added the synchronization state for PRIME Displays to nvidia-settings.
Improved error reporting in eglSwapBuffers() by generating codes for some missing error types, and adding additional detail to the already existing ones.
Improved the appearance and functionality of the nvidia-settings control panel when it is resized to small sizes.
Updated the nvidia-settings control panel to prevent some icons from being displayed incorrectly while using some GTK+ themes.
Fixed a bug that could cause WINE to crash on recent OS releases.
Fixed a bug that could cause an X server crash when exiting Vulkan applications running on X servers with UBB enabled.
Fixed an X driver bug that caused the "NoEdidModes" token of the "ModeValidation" X configuration option to reject non-EDID modes whose timings matched EDID modes.
Changed the NvEncCreateBitstreamBuffer API call in the NvEncodeAPI library to return NV_ENC_ERR_UNIMPLEMENTED instead of NV_ENC_SUCCESS when the encoder instance is configured to run in motion estimation-only mode. As an indirect consequence of this change, users running the AppEncME sample application from the Video Codec SDK prior to SDK version 8.2.16 will observe a segmentation fault due to bugs in the NvEncoder class. It is recommended that users download the latest version of the SDK, where these bugs have been fixed, from https://developer.nvidia.com/nvidia-video-codec-sdk.
Fixed an OpenGL driver bug that caused the upper bounds of floating-point viewports, specified through the ARB_viewport_array extension, to be clipped incorrectly.
Added a new X configuration option "HardDPMS" which is disabled by default, but can be enabled to put displays to sleep with modesets rather than VESA DPMS. This may fix some displays that fail to sleep when DPMS becomes active. "HardDPMS" will be enabled by default in a future release.
Raised the minimum supported X.Org xserver version to 1.5 (video driver ABI version 4).
Enabled the NVreg_EnableBacklightHandler kernel module option by default.
Removed the LinuxThreads version of the /usr/lib/libnvidia-tls.so library and replaced it with the NPTL one that was previously installed in /usr/lib/tls/. This fixes crashes on Debian systems when the /etc/ld.so.nohwcap file is present.
Updated nvidia-installer to allow the --no-cc-version-check option to disable the compiler version check when installing with DKMS.
Changed the minimum required Linux kernel version from 2.6.9 to 2.6.32.
Fixed an OpenGL bug where conditional rendering (NV_conditional_render) was incorrectly affecting mipmap generation.
Fixed a bug that could cause the X server to hang on systems booted in legacy VGA mode when using a DisplayPort Multi-Stream link.

mrdeathjr commented on 20 November 2018 at 9:09 pm UTC

According nvidia_icd_json_template shows this:

{ "fileformatversion" : "1.0.0", "ICD": { "library_path": "NV_VK_ICD", "api_version" : "1.1.84" } }

Again no stream output support for turing for now aka Another Meh Driver TM

jens commented on 20 November 2018 at 9:32 pm UTC

You should run vulkaninfo with this driver installed and check the listed instance and device extensions to really be sure what the driver contains or not. The specification number can be a little bit misleading and doesn't tell the whole story afaik.

That said, considering the short time between 415.13 beta and this 415.18 release I guess the vulkan support is on the same level as the 396.54.06 driver and does not yet contains transform feedback. Though not sure until someone confirms what vulkaninfo reports.

Xpander commented on 28 November 2018 at 7:58 am UTC

Has someone tried this driver? Yesterday, Kallestofeles (who is also the member of this site) updated his wine and dxvk and tried to play ARK: Survival Evolved and complained about stuttering, lots of it. We tried many obvious, wine environment settings as well as dxvk settings and some nvidia-settings and forcing GPU/CPU to performance mode with no help. Me and Woox2k played just fine without stuttering, we have 396.54.09 drivers. So Kalle went on to downgrade the driver as well and stuttering was gone. Has anyone noticed it? Is it just this 1 game?

liamdawe commented on 28 November 2018 at 9:38 am UTC

After using it last night to play Rocket League, it did feel like it wasn't as smooth as usual.

FredO commented on 28 November 2018 at 11:34 am UTC

This Nvidia 415.18 version broke a bunch of Steam Play games for me, where they come with the error that the video card is not supported. "Ryse: Son of Rome" and "Batman: Arkham Origins" have that issue, and the Witcher 3 is failing before the main menu. Rolling back to the 410 branch resolved those issues. In summary, 415.18 does not look like a good version.

Schattenspiegel commented on 28 November 2018 at 12:52 pm UTC

steamplay: endless legend and endless space2 do not start with this driver

liamdawe commented on 28 November 2018 at 1:26 pm UTC

You're both using the NVIDIA PPA here I assume? https://launchpad.net/~graphics-drivers/+archive/ubuntu/ppa

It also broke Vulkan for me, had to purge it and re-installed it. I talked about it on Twitter:
https://twitter.com/thenaughtysquid/status/1067521500545208320
https://twitter.com/thenaughtysquid/status/1067525651761176576

I spoke to one of the people behind the PPA, from what they say no verification is being done on it as they don't have the resources. This isn't the first time it has happened.

Also made a Reddit post: https://www.reddit.com/r/linux_gaming/comments/a0zii8/updating_from_the_ubuntu_nvidia_ppa_did_it_break/ others also had the issue.

Schattenspiegel commented on 28 November 2018 at 1:50 pm UTC

liamdaweYou're both using the NVIDIA PPA here I assume? https://launchpad.net/~graphics-drivers/+archive/ubuntu/ppa

Jupp using that PPA.
So reinstalling solved the issue?
But driver performance still feels sluggish or is that also solved?

Lin_Soldar commented on 28 November 2018 at 3:04 pm UTC

Can confirm here too that the 415.18 PPA driver broke a few games that originally worked.

Native games being Mad Max with the Vulkan(Beta) option and Rise of the Tomb Raider would crash very often.
Steam Play games that would no longer start : Far Cry 1 & 2 and Burnout Paradise.

There's also a definite performance penalty when running the Superposition Benchmark.

Have reverted back to 396.54 driver.

ageres commented on 28 November 2018 at 3:29 pm UTC

Now I have hiccups in Starcraft Remastered. I'm not sure if it's because of this driver of Wine, I upgraded both simultaneously and now cannot launch Battle.net and Origin. I run it with Lutris and its default Wine 3.12 Staging. DXVK and Vulkan don't work as well (I like to test it with this: https://www.reddit.com/r/wine_gaming/comments/8f57xc/whats_the_easiest_way_to_test_if_dxvk_is_working/).

My next graphics card surely won't be Nvidia. Too many times they ruined something with their Linux drivers.

  Go to:

Due to spam you need to Register and Login to comment.


Or login with...

Livestreams & Videos
Community Livestreams
  • Slash 'Em: „Torchlight II“
  • Date:
See more!
Popular this week
View by Category
Contact
Latest Comments
Latest Forum Posts