You can sign up to get a daily email of our articles, see the Mailing List page!
Support us on Patreon to keep GamingOnLinux alive. This ensures we have no timed articles and no paywalls. Just good, fresh content! Alternatively, you can donate through Paypal, Flattr and Liberapay!
  Go to:
[Steam] [Rocket League] Impossible to play, game's window is black and the system freezes after 30s, forcing to hard reboot
Massinissa commented on 22 January 2019 at 8:17 pm UTC

Ok, out of rage, I tried several distributions (debian, manjaro, ubuntu), wwithout success. And when I tried solus again, it worked out of the box. Loading times are a nightmare. This is solved.

Massinissa commented on 24 January 2019 at 12:04 am UTC

Guest
MassinissaLoading times are a nightmare.

Rocket League is one of my fastest starting games. You can use the following commands to check possible memory overruns:
RAM: free -m
VRAM: glxinfo -B
When I tried Rocket League, I closed every other applications, only a gnome-terminal was open. And it's not really the launch, which is quite the same as in windows, but loading games takes forever, and I don't even have the loading screen, it just goes full back screen

for the memory I have 4 GB of RAM and 8 GB of swap.

Here's the output of glxinfo -B

Quoteme@gilgamesh ~ $ glxinfo -B
name of display: :0
display: :0 screen: 0
direct rendering: Yes
Extended renderer info (GLX_MESA_query_renderer):
Vendor: Intel Open Source Technology Center (0x8086)
Device: Mesa DRI Intel(R) HD Graphics 5600 (Broadwell GT2) (0x1612)
Version: 18.3.1
Accelerated: yes
Video memory: 3072MB
Unified memory: yes
Preferred profile: core (0x1)
Max core profile version: 4.5
Max compat profile version: 3.0
Max GLES1 profile version: 1.1
Max GLES[23] profile version: 3.1
OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) HD Graphics 5600 (Broadwell GT2)
OpenGL core profile version string: 4.5 (Core Profile) Mesa 18.3.1
OpenGL core profile shading language version string: 4.50
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile

OpenGL version string: 3.0 Mesa 18.3.1
OpenGL shading language version string: 1.30
OpenGL context flags: (none)

OpenGL ES profile version string: OpenGL ES 3.1 Mesa 18.3.1
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.10

me@gilgamesh ~ $

Massinissa commented on 24 January 2019 at 1:26 pm UTC

GuestIf the Intel GPU uses 3 GB of shared memory no wonder you computer is slow, it is swapping with 1 GB of RAM. Go into Bios and use 1 GB of shared memory for the GPU.
There's no option for this in my bios, the only things outside usb configuration is battery related.

  Go to:

Due to spam you need to Register and Login to comment.


Or login with...

Livestreams & Videos
Community Livestreams
  • Story Time: „Syberia“ (via Wine)
  • Date:
See more!
Popular this week
View by Category
Contact
Latest Comments
Latest Forum Posts