You can sign up to get a daily email of our articles, see the Mailing List page!
Anthem
entropie commented on 18 March 2019 at 2:40 pm UTC

Hey there,

I am playing the game on an undervolted and watercooled Vega 64 set to 225W with padoka-devel on Linux 5.0 and Ubuntu 18.04.1. There seems to be a problem with the game fully utilizing the GPU. When in the city it runs on like 20 Watts, what is almost idle power and frames drop to 15 fps at times. When in game, it never gets past 80 W with frames being like you can see in the video. It doesnt matter, whether I run in windowed/borderless or fullscreen, the result is the same, but I figured, if I maximize the window in windowed mode, its like the GPU gives up completly and drops to 20 W max, what results in an unplayable stuttering game.

Here I have some footage: Anthem 1080p - Ultra

I tried installing FAudio but that didnt change a thing. Thought it may be a network thing and pinged the server for a solid 100 ms over 1 minute, so that cant be it. Seeing the GPU doesnt get used much, I rather think the problem lies there. I have checked for a CPU bottleneck (R5 1600x) but this aint the case, CPU is not running at its limits. Could be tho that the game wants multithreaded rendering and thats not working. I dunno.

It says around 52000 graphics pipelines thats pretty much, in Star Citizen I run at 2000 max.

Maybe you have a hint?
Thx in advance,
Greetings ~ent

YoRHa-2B commented on 18 March 2019 at 6:45 pm UTC

Sounds like you don't have esync enabled.

entropie commented on 19 March 2019 at 7:05 am UTC

Enabled it is, not sure tho if its working. I tried several tkg builds in Lutris, using the latest now, 4.3-tkg with esync enabled and DefaultLimitNOFILE=524288 set in systemd user.conf and system.conf. "ulimit -Hn" gives the value back, so that looks good.

I partially solved part of my problem yesterday and that could play a role for the rest of the game. While in the free World of the game or when playing missions, the GPU is barely maxed out (30%) and the CPU runs at half speed. But in the menu or in the starting city, the CPU is dieing. I get load averages of 21 on a 12 threaded core and of course there is a lot of lagging. I tried different things, until I saw briefly in Steam overlay that it would peak to 2500 fps, while in the menu/city. So I strangled the game to 60 fps with libstrangle by Björn Spindel from Gitlab. That did not work from Lutris, cause loading the lib dies when the Origin launcher is started, at that moment the lib doesnt find libvulkan.so, but it worked starting the game as a non-steam game with the strangle command. So I put that to 60 fps et voila, menu and city are working like a charm. Only the low fps remain. But the pressure on the CPU is gone, its down to reasonable values now, like when in the free World. This seems to be a game-related issue, the game seems to be in heavy need of optimisation, Windows user have the same issues and wonder about heavy lag and burning CPUs while on a RTX 2080. VSync of course is enabled, at least in the game menu.

I have set Anti-Aliasing to TAA now, that HBAO+ thing to SSAO, I set the mesh detail to low and the post-processing to high, that makes the game well playable. Yet only 20 - 30 fps, while Vega 64 users on windows report a steady 50 - 60 fps on ultra settings, so I suspect running it at 35 - 45 fps in Linux is possible (especially cause the GPU gets barely used).
I've made a second video with libstrangle enabled, maybe you can have a look. There is a bit of shader stuttering and some graphics glitches. In the beginning of the free Worlds scene the birds look pretty neon and sometimes I get graphical artifacts that look like missing textures, in explosions for instance.

Anthem with libstrangle 60 fps
(Sadly missing the HUD here, but there is the Steam fps counter in the lower left corner)

P.S.: if its helping I could file an issue report with an apitrace on DXVK github on the weekend or in the next days.

YoRHa-2B commented on 19 March 2019 at 9:12 am UTC

This isn't necessarily a DXVK bug though, especially since it usually is on par with or faster than AMD's Windows driver when CPU bound (which you seem to be).

Could be similar to Resident Evil 2 which runs ~2x as fast on Windows in the CPU-bound case due to thread synchronization bottlenecks - esync is good, but not perfect. Can you check perf top while running the game?

entropie commented on 19 March 2019 at 7:47 pm UTC

Yea, shit you are right, it's CPU-bottlenecked for me, Anthem.exe runs at 90 % :/. I thought 'well CPU only says 40%, the game must use at least 2 cores and I should have enough overhead left' but I am used to 4 core CPUs, got a 6 core now, when 40 % would be 2 full cores.
I looked at wattmanGTK and the Vega is running around P-state 3 that's just wow. Given it goes till P-State 6.5 pretty stable on my setup, you prolly need a good 4.2 Ghz and more for this game. Just crazy... I could put my CPU to 3.8 Ghz but that's not worth it, game is not that good and it runs stable at 35 fps. If I go down to medium settings from ultra, things should get even better.

I'll nevertheless write a winehq entry for the fps strangle thing to get rid of menu stuttering. That maybe helps others.

On Computerbase they benchmarked my CPU for Anthem on a Titan RTX and it got to 65 fps on average in Windows, while I only hit 35 fps with the same settings. Is that delta lost due to the translation layers and maybe GPU drivers not being perfect yet? If you dont think that is possible, it could be that they benchmarked before the Day 1 patch, cause after that things went down the road for a lot of people.

Thanks for your help, I owe you a beer again ;).


image

Due to spam you need to Register and Login to comment.


Or login with...

Livestreams & Videos
Community Livestreams
  • Story Time: „The Book of Unwritten Tales“
  • Date:
See more!
Popular this week
View by Category
Contact
Latest Comments
Latest Forum Posts