Support us on Patreon to keep GamingOnLinux alive. This ensures we have no timed articles and no paywalls. Just good, fresh content! Alternatively, you can donate through PayPal, Flattr, Liberapay or Buy us a Coffee. You can also buy games using our partner links for GOG and Humble Store.
Doom 2016 stop working?
TheReaperUK 31 July 2019 at 3:22 pm UTC

I have not played Doom 2016 for over a Month now and tried to play again this week and now it does not work, Doom is running on Proton 3.16 as that is Steam recommendation, but have tested with 4.2 and the new 4.11 and still does the samething,
It loads up and plays the intro videos but at the first loading screen it sits at 99% and never loads the game, sometimes it will give me the force close/wait option.

I am running Manjaro Gnome Edition with Intel I7 and Nvidia Geforce, Lastest 5.2 kernel and Nvidia driver 430.26.

Now i'm not sure if the problem is with the Game or Some Driver/Kernel update to my system, all other games running on Proton are still working great.

If you have Doom 2016 installed can someone test to see if it working for them and want OS, Hardware you are using.

Thanks.

andy155 31 July 2019 at 5:56 pm UTC

it works as usual tested with 4.2 and 4.11

TheReaperUK 1 August 2019 at 12:09 am UTC

Update:

If i force Doom 2016 into OpenGL (+r_renderapi 0)mode it works and plays, so my problem seems to be with a Vulkan ICD update or my Nvidia driver has a bug??

I'll wait for another ICD update and/or Nvidia driver update and see if the Game+Vulkan still has the same problem.

Well least i can still play the game with OpenGL for now.

P.S. All other Vulkan Games F1-2017,Rise of the Tomb Raider, Etc and Proton using dxvk all still work.

chui2ch 1 August 2019 at 12:49 am UTC

Are you getting sound when you are at the 99%? I have the same issue. It works well under opengl. This is using the Nvidia 430.40 driver on Ubuntu 18.04.

Edit: Disable the steam overlay. Fixed the issue for me.

TheReaperUK 1 August 2019 at 2:06 am UTC

chui2chAre you getting sound when you are at the 99%? I have the same issue. It works well under opengl. This is using the Nvidia 430.40 driver on Ubuntu 18.04.

Edit: Disable the steam overlay. Fixed the issue for me.

Yes i had sound, The one thing i forgot to try was to disable the overlay, Thanks i will test this later today.

andy155 1 August 2019 at 7:51 am UTC
TheReaperUK 1 August 2019 at 10:41 am UTC

andy155https://youtu.be/IdheTot4DFU

Thanks for the video, i can now see that the problem may be caused by a newer Vulkan ICD Loader as you are running an older version 1.1.99 and mine is 1.1.115, That would explain why it was running great using Vulkan about a month ago but now has a problem, but OpenGL works flawless, still need to test with no steam overlay later today.

chui2ch 1 August 2019 at 10:58 am UTC

TheReaperUK
andy155https://youtu.be/IdheTot4DFU

Thanks for the video, i can now see that the problem may be caused by a newer Vulkan ICD Loader as you are running an older version 1.1.99 and mine is 1.1.115, That would explain why it was running great using Vulkan about a month ago but now has a problem, but OpenGL works flawless, still need to test with no steam overlay later today.


I am on version 1.1.99 and if I have the overlay turned on it does not work. There were a lot of people with the same problem on protondb when I looked the game up this morning.

TheReaperUK 1 August 2019 at 10:31 pm UTC

It's just so strange, as about a month ago it was working for me with overlay using Vulkan but now it don't, I know the game itself has not had an update so i fear it may be down to some system OS update's, so i was hoping it was just ICD Loader and may be fixed in the next update.

As you said, if i disable steam overlay then the game works again using Vulkan, so thanks for that information

lejimster 2 August 2019 at 10:23 pm UTC

Probably an nvidia vulkan driver issue, did you update your drivers since it last worked? Maybe roll them back to an earlier version if possible? I was playing the game just the other day with Vulkan no problems. But I do have AMD hardware using open source drivers mesa+aco.

You need to Register and Login to comment, submit articles and more.


Or login with...

Livestreams & Videos
Community Livestreams
  • GTFO - R2C1 - Work Together Or Die Together [GER/ENG]
Popular this week
View by Category
Contact
Latest Comments
Latest Forum Posts