You can sign up to get a daily email of our articles, see the Mailing List page!
Everspace on Linux using bumblebee
segfault_ii commented on 17 September 2019 at 8:51 pm UTC

Hello!
I tried to run Everspace on my Fedora 30 x64 system using bumblebee and optirun/primusrun (Nvidia GTX 1060).
I tried several combinations of "optirun/primusrun" commands, with LD_PRELOAD-variable set or without, using --syslibs or without.
Combinations I tried:

Unmodified start scripts:
optirun start.sh: faulted
optirun start.sh --syslibs: faulted
primusrun start.sh: faulted
primusrun start.sh --syslibs: faulted
optirun xterm -e start.sh: faulted
primusrun xterm -e start.sh: faulted

Modified start scripts (EverspaceWithSystemLibraries.sh, EverspaceWithShippedLibraries.sh), adding a LD_PRELOAD variable like explained: here
optirun start.sh: faulted
optirun start.sh --syslibs: faulted
primusrun start.sh: faulted
primusrun start.sh --syslibs: faulted

Modified start scripts, adding optirun/primusrun in the command:
optirun: faulted
optirun: faulted

The only combination that actually worked was
optirun -b primus start.sh --syslibs

I found the hint to get it running here.

I post this just in case anyone else is trying to get this up and running.
Oh - I used the Gog.com version 1.3.4.

Hope this is of any help

You need to Register and Login to comment, submit articles and more.


Or login with...

Livestreams & Videos
Community Livestreams
  • Grand Theft Auto San Andreas, Proton, Pleb
  • Date:
See more!
Popular this week
View by Category
Contact
Latest Comments
Latest Forum Posts