Support us on Patreon to keep GamingOnLinux alive. This ensures all of our main content remains free for everyone with no article paywalls. Just good, fresh content! Alternatively, you can donate through PayPal, Liberapay or Buy us a Coffee. You can also buy games using our partner links for GOG and Humble Store.
Joypad not recognized unless steam is running.
kokoko3k 12 Oct, 2019
Hi guys,
i'm facing a strange problem with my joypad.
I use a Triolinker adapter that allows me to connect PS2, dreamcast and Gamecube controllers to my PC.
Works flawlessly on linux and even support rumble.
Today, i tried to start "celeste" via lutris and epic game store, and it was unable to detect any controller.
Then, by pure luck, i started steam, then lutris, and controller started to work in "celeste" with full rumble support.
So the question is: "what does steam to fix controller support in "celeste", which is running outside it?"
I tried to emulate an xbox360 controller via userspace xboxdrv, mapped all the things, and i was able to make it work in "celeste", but no rumble support (tried --force-feedback option).

Anybody has an explaination? I basically would like to do what steam is doing, but without firing it up.

Limbo (from Epic strore) does the same.

Thanks!


-EDIT-
It seems "desktop confiuguration" in steam controller configuration must not be "disabled"
(wth?)
DaiKaiser93 12 Oct, 2019
Steam is probably making your controller appear as an official Xbox 360 gamepad, so you starting Steam first, then starting Lutris is basically first changing your gamepad to a 360 one then Lutris is able to detect it when is launched.

I have had a similar experience with both The Witcher 3 & Warframe in Lutris, except I was using SC-Controller not Steam. If I didn't run SC-Controller first then I wouldn't have controller support in Lutris.
kokoko3k 12 Oct, 2019
Indeed i think so, that's why i tried via xboxdrv and it works too.
But rumble support is not working via xboxdrv.
kokoko3k 13 Oct, 2019
Or, probably, by enabling a steam "desktop configuration", steam emulates keystrokes and so the controller worked in the game? (but then why rumble worked? bah!)

Anyway i solved by using https://github.com/kozec/dumbxinputemu
Now controller AND rumble works.
While you're here, please consider supporting GamingOnLinux on:

Patreon, Liberapay or PayPal Donation.

This ensures all of our main content remains totally free for everyone with no article paywalls. We also don't have tons of adverts, there's also no tracking and we respect your privacy. Just good, fresh content. Without your continued support, we simply could not continue!

You can find even more ways to support us on this dedicated page any time. If you already are, thank you!
Login / Register

Or login with...
Sign in with Steam Sign in with Twitter Sign in with Google
Social logins require cookies to stay logged in.