You can sign up to get a daily email of our articles, see the Mailing List page!
Crusader Kings II stopped working after updating Pop!_OS to 19.10
zerosapte commented on 20 October 2019 at 10:33 am UTC

Yesterday I was binging on the game. This morning I took the update to 19.10 and the game stopped working.

It will launch just fine but as soon as I make my first click, anywhere, any button, it doesn't matter, after the first click it will freeze completely, taking the whole system with it. The sound will continue playing, the water in the menu is still animating but no input will go through, no keystrokes, not mouse clicks, nothing.

At this point the only option is a long press of the power button.

I tried verifying local files in Steam, uninstalling and reinstalling the game, I have even tried doing a clean install of Pop!_OS 19.10, updating nVidia drivers to 440.26, I tried various version of the game, 64 bit and 32 bit, current and old. I tried all I could think of, nothing gets the game past the first click.

Anyone able to offer any help?


Later edit: I got it to run eventually by forcing Proton on it in Steam. Pfew, at least I can game, but I'm still looking for a better solution as running it via Proton is a tiny bit slower.

You need to Register and Login to comment, submit articles and more.


Or login with...

Livestreams & Videos
Community Livestreams
See more!
Popular this week
View by Category
Contact
Latest Comments
Latest Forum Posts