Check out our Monthly Survey Page to see what our users are running.
[Solved] Star Wars Jedi: Fallen Order does not run, as EA Origin detects no Internet
Page: 1/5»
  Go to:
LordDaveTheKind 28 Jun, 2020
Hello fellow Linux Gamers,
recently I decided to give a try to Star Wars Jedi: Fallen Order, as it was on a 50% discount on Steam. The latest reports on ProtonDB.com were enough reassuring, so I decided to give it a try.

To my (not that much) surprise, any time I try to run the game (mandatory via EA Origin), I always face the following error message:

"We've noticed your computer is currently offline. To activate your game on this computer using your EA Account, you'll need to connect to the Internet"

Error message screeenshot

Closing the message window will exit the game execution.

Needless to say, the computer is definitely connected to the Internet, and the same EA Origin can browse all the pages displayed in the client with no errors. Furthermore, there isn't that much related to previous Linux/Wine issues with the same error message if I try to google it.

This issue has been experienced with all the know running methods:
  • SteamPlay (out of the box);
  • Steam on Wine;
  • Origin on Wine.


Several versions of Wine have been tried:
  • lutris-5.6-5 (in Lutris environment)
  • lutris-5.6-2 (in Lutris environment)
  • lutris-jedi-4.20 (in Lutris environment)
  • Proton-GE-5.6-2 (in Lutris environment)
  • Proton-GE-5.8-2 (in both Lutris and SteamPlay environment)
  • Proton-GE-5.11-1 (in both Lutris and SteamPlay environment)
  • Proton-5.0 (in both Lutris and SteamPlay environment)
  • Proton-4.11 (in both Lutris and SteamPlay environment)


All of the above are stuck at the same point.

In addition, all the following workarounds have been tried, without any success:


Full log is available here: https://pastebin.com/g4WhhsjM. What concerns me about it are the lines at the bottom, which I can't understand if they might be related with the allegedly missing Internet connection:
00e1:fixme:shell:CustomDestinationList_BeginList 0x1edb540 (0xb5afbac {92ca9dcd-5622-4bba-a805-5e9f541bd8c9} 0xb5afbb8): stub
024d:fixme:crypt:CRYPT_CheckUsages unimplemented for RequestedIssuancePolicy
001c:fixme:netprofm:list_manager_GetConnectivity 00F0A5B0, 0178DB44


Do you have any advice, or any idea on any additional test I could try for figuring out the root cause?

Cheers,
Dave

Last edited by LordDaveTheKind on 1 September 2020 at 4:05 pm UTC
omicron-b 28 Jun, 2020
This may be a new issue due to some changes on EA servers. There is kinda relevant bugreport for Titanfall 2 (which I was unpleasantly surprised with today): https://github.com/ValveSoftware/Proton/issues/4001#issuecomment-650615187
m2mg2 28 Jun, 2020
Quoting: omicron-bThis may be a new issue due to some changes on EA servers. There is kinda relevant bugreport for Titanfall 2 (which I was unpleasantly surprised with today): https://github.com/ValveSoftware/Proton/issues/4001#issuecomment-650615187

That error says displayname missing from registry. Have you looked into what registry entry it may be looking for and creating it in the wine registry?
LordDaveTheKind 28 Jun, 2020
Quoting: omicron-bThis may be a new issue due to some changes on EA servers. There is kinda relevant bugreport for Titanfall 2 (which I was unpleasantly surprised with today): https://github.com/ValveSoftware/Proton/issues/4001#issuecomment-650615187
I was of the same idea, although I successfully installed and ran it on my Windows laptop, from the same network connection.
Even after running it on Windows, the error message in my Linux system is still displayed every time.
omicron-b 28 Jun, 2020
Quoting: m2mg2
Quoting: omicron-bThis may be a new issue due to some changes on EA servers. There is kinda relevant bugreport for Titanfall 2 (which I was unpleasantly surprised with today): https://github.com/ValveSoftware/Proton/issues/4001#issuecomment-650615187

That error says displayname missing from registry. Have you looked into what registry entry it may be looking for and creating it in the wine registry?
It took me some time to understand, but the error actually is "unable to connect to EA servers to activate your game on this account", and "Displayname field missing from registry." must be a placeholder for game title, in this case Titanfall 2.
m2mg2 28 Jun, 2020
Quoting: omicron-b
Quoting: m2mg2
Quoting: omicron-bThis may be a new issue due to some changes on EA servers. There is kinda relevant bugreport for Titanfall 2 (which I was unpleasantly surprised with today): https://github.com/ValveSoftware/Proton/issues/4001#issuecomment-650615187

That error says displayname missing from registry. Have you looked into what registry entry it may be looking for and creating it in the wine registry?
It took me some time to understand, but the error actually is "unable to connect to EA servers to activate your game on this account", and "Displayname field missing from registry." must be a placeholder for game title, in this case Titanfall 2.

Yeah. It wasn't easy to identify what registry entry it was referring to. If it is just a missing registry it may be resolved by creating it, determining exactly what registry entry is needed could be difficult. Hopefully either on the proton side or the origin side it will get fixed soon.

Last edited by m2mg2 on 28 June 2020 at 8:51 pm UTC
omicron-b 29 Jun, 2020
Quoting: LordDaveTheKind
Quoting: omicron-bThis may be a new issue due to some changes on EA servers. There is kinda relevant bugreport for Titanfall 2 (which I was unpleasantly surprised with today): https://github.com/ValveSoftware/Proton/issues/4001#issuecomment-650615187
I was of the same idea, although I successfully installed and ran it on my Windows laptop, from the same network connection.
Even after running it on Windows, the error message in my Linux system is still displayed every time.

My issue is fixed by running Titanfall 2 on another system (Ubuntu) where I have wine and it's deps installed. Do you have wine on your Debian installed?
LordDaveTheKind 29 Jun, 2020
Quoting: omicron-bMy issue is fixed by running Titanfall 2 on another system (Ubuntu) where I have wine and it's deps installed. Do you have wine on your Debian installed?
Yes, I have wine-5.0.1 (stable branch) installed, from the winehq repository.
omicron-b 4 Jul, 2020
Some people in the thread I mentioned had success with Steam as Flatpak.
I just updated my Debian Testing today and the game starts fine now.
LordDaveTheKind 5 Jul, 2020
Quoting: omicron-bSome people in the thread I mentioned had success with Steam as Flatpak.
I just updated my Debian Testing today and the game starts fine now.
In these days I installed a sandbox Pop_OS! for a check, and it works successfully there.

I tried then to update Debian to Bullseye/Testing, and repeated the test, but I got the same error message. Here below a summary of my new tests:

  • Pop_OS! 2004, kernel 5.7.0: success;
  • Debian 10 (Stable), kernel 5.6.17: fail (no internet error popup);
  • Debian Testing, kernel 5.7.7: fail (no internet error popup)

All the cases above used the NVidia Graphics driver version 440.100.

Anything I could check in the packages list? Maybe some of them are in an older version, although I did perform a dist-upgrade and full-upgrade.

Last edited by LordDaveTheKind on 5 July 2020 at 12:27 pm UTC
omicron-b 6 Jul, 2020
Well, that's unfortunate.
There is no agreement why this issue occured on Debian with Titanfall 2.
One person in the thread blames an older version of p11-kit, but two other (including me) already had that updated to latest 0.23.20 when the issue first occured.

Do you wish to try Flatpak version of Steam? It has some quirks (installing games outside of home folder requires some configuration) and strange bugs (on one of my machines, it did not detect one button of an Xbox controller) - that's why I stopped using it, but you may be lucky with that.
Be careful migrating though, I learned the hard way that some games that don't use Steam cloud keep their savegames in Steam folder instead of usual ~/.local/share/
While you're here, please consider supporting GamingOnLinux on:

Patreon, Liberapay or PayPal Donation.

This ensures all of our main content remains totally free for everyone with no article paywalls. We also don't have tons of adverts, there's also no tracking and we respect your privacy. Just good, fresh content. Without your continued support, we simply could not continue!

You can find even more ways to support us on this dedicated page any time. If you already are, thank you!
Login / Register

Or login with...
Sign in with Steam Sign in with Twitter Sign in with Google
Social logins require cookies to stay logged in.