Support us on Patreon to keep GamingOnLinux alive. This ensures we have no timed articles and no paywalls. Just good, fresh content! Alternatively, you can donate through PayPal, Liberapay or Buy us a Coffee. You can also buy games using our partner links for GOG and Humble Store.
[Solved] Star Wars Jedi: Fallen Order does not run, as EA Origin detects no Internet
Page: «4/4
  Go to:

Quoting: LordDaveTheKindI will apply this workaround in the next weeks, and keep everyone posted in case works.

It works. Marking this discussion as Solved.

All the best,
Dave

Quoting: LordDaveTheKind
Quoting: The_Aquabatso I still couldn't figured out the origin not downloading error. But here is my take on this, with Mesa 20.2git performance is getting there, I think that I should wait some months, for final optimizations since mine is a weak card for this game, on more powerful hardware like a navi 5700xt/5600xt, nvidia 1080, the game should play excelent when mesa 20.2 is releasead.

What is your current Hw?

so I updated my hardware and now the game runs just the same, this game is not well optimized. This is a Navi 5600xt somehow similar to a nvidia 2060. There's quite a lot of stutter on cutscenes specially. It was not a hardware problem as this card is 80% faster than my previous one, and performance is still bad.

Last edited by The_Aquabat on 1 September 2020 at 5:21 pm UTC

Quoting: The_Aquabatso I updated my hardware and now the game runs just the same, this game is not well optimized. This is a Navi 5600xt somehow similar to a nvidia 2060. There's quite a lot of stutter on cutscenes specially. It was not a hardware problem as this card is 80% faster than my previous one, and performance is still bad.

CPU and OS?

Quoting: LordDaveTheKind
Quoting: The_Aquabatso I updated my hardware and now the game runs just the same, this game is not well optimized. This is a Navi 5600xt somehow similar to a nvidia 2060. There's quite a lot of stutter on cutscenes specially. It was not a hardware problem as this card is 80% faster than my previous one, and performance is still bad.

CPU and OS?

Kubuntu 20.04
Cpu Ryzen 2600
16GB RAM DDR4

Quoting: The_AquabatKubuntu 20.04
Cpu Ryzen 2600
16GB RAM DDR4

Something that improved a lot my computer performance (which I still stick to) is the Linux Kernel release: I'm still with the 4.9, and it works better than any 5.*

Quoting: LordDaveTheKind
Quoting: The_AquabatKubuntu 20.04
Cpu Ryzen 2600
16GB RAM DDR4

Something that improved a lot my computer performance (which I still stick to) is the Linux Kernel release: I'm still with the 4.9, and it works better than any 5.*

I can't use that kernel because there's no NAVI support. Has to be 5.6 or newer.

Quoting: The_AquabatI can't use that kernel because there's no NAVI support. Has to be 5.6 or newer.

In the last couple of days I have built and deployed a vanilla release 5.8.7 (current stable branch) from kernel.org in my gaming pc, and it seems to have surprisingly similar performance to my old 4.9 release. Have you tried this one too?

Quoting: LordDaveTheKindHave you tried this one too?
yes thanks nvm , I have other games to play right now, probably some bug on AMD hope it get fixed soon.

While you're here, please consider supporting GamingOnLinux on:

Patreon, Liberapay or PayPal Donation.

We have no adverts, no paywalls, no timed exclusive articles. Just good, fresh content. Without your continued support, we simply could not continue!

You can find even more ways to support us on this dedicated page any time. If you already are, thank you!
Login / Register

Or login with...
Sign in with Steam Sign in with Twitter Sign in with Google
Social logins require cookies to stay logged in.

Livestreams & Videos
Official Livestreams
Community Livestreams
Latest Forum Posts