Join us on our own very special Reddit: /r/Linuxers
Problem about Ragnarok online private server clients
sharkdeed 30 Jul

Hi all,

I have been trying to run private Ragnarok Online clients on my Manjaro with Lutris. I could find one private server client that has a Lutris installer on the which runs perfectly but its not the server that i would like to play. I have tried 2 different clients (which are pretty similar) one is from ShiningMoonRO and the other is Ragna0 and i couldn't run neither of them and the problem looks like quite similar.

My system specs:
OS: Manjaro Linux x86_64
Kernel: 5.6.16-1-MANJARO
Shell: bash 5.0.17
Resolution: 1920x1080
DE: kde
WM: i3
CPU: Intel i7-5820K (12) @ 3.600GHz
GPU: NVIDIA GeForce GTX 980
Memory: 2570MiB / 15912MiB
Lutris Version: 0.5.6
Wine Prefix Arch: 32bit(tried 64bit as well)
Wine version: 5.9 staging(tried tkg4.6, lutris4.12, lutris5.7.3, lutris5.7.5, lutris5.7.8 as well)
DXVK version: 1.7L-3322da4-2


Note: all my wine games are installed on an hard drive while my main system runs on a SSD.

Problem:
When i run the client, i first run the game launcher for both of these clients which gets updates and patches them. That step runs flawlessly. However, when i click start i get a message that says(i know it does not mean that much and probably a game specific error but it might help for some people)
 
[string "buf"]:1: unexpected symbol


so i have gone into the console. When i execute the game with WINEDEBUG=warn+all the log is like below(put it inside of spoilers cuz its kinda long):
002c:fixme:winediag:__wine_start_process Wine Staging 5.9 is a testing version containing experimental patches.
002c:fixme:winediag:__wine_start_process Please mention your exact version when filing bug reports on winehq.org.
0024:fixme:ntdll:NtQuerySystemInformation SystemCodeIntegrityInformation, len 8, buffer 0x31ea58, stub!
0024:fixme:wtsapi:WTSEnumerateProcessesA Stub 00000000 0x00000000 0x00000001 0031EA24 0031EA30
0024:fixme:ddraw:DirectDrawEnumerateExA flags 0x00000006 not handled
0024:fixme:ntdll:NtQuerySystemInformation info_class SYSTEM_PERFORMANCE_INFORMATION
0024:fixme:ddraw:ddraw7_Initialize Ignoring guid {aeb2cdd4-6e41-43ea-941c-8361cc760781}.
00cc:fixme:fltlib:FilterFindFirst (0, 02284020, 216, 0339F1B4, 0339F1B0) stub
00cc:fixme:fltlib:FilterFindClose (00000202) stu


However, i have noticed some things when i execute the game with WINEDEBUG=warn+all and the log is like in the pastebin url below:
Log for WINEDEBUG=warn+all

I know that my problem can be too specific to the game but i just wanted to see if anybody was able to fix this.

Please let me know if you need more information
Thanks

Last edited by sharkdeed on 30 July 2020 at 2:53 pm UTC

While you're here, please consider supporting GamingOnLinux on:

Patreon, Liberapay or PayPal Donation.

We have no adverts, no paywalls, no timed exclusive articles. Just good, fresh content. Without your continued support, we simply could not continue!

You can find even more ways to support us on this dedicated page any time. If you already are, thank you!

You need to Register and Login to comment, submit articles and more.


Or login with...