Check out our Monthly Survey Page to see what our users are running.
Ubuntu focal 32 bit Steam doomsday
The_Aquabat 5 days ago

so some proton games are not running for me (access violation crash) because I'm quite sure of 32bits libs missing on my system. When I try to run Wine version of steam I get this error.

QuoteAssertion Failed: ClientAPI_InitGlobalInstance: InternalAPI_Init_Internal failed, most likely because you are missing a 32-bit dependency of steamclient.dll (the Steam client is a 32-bit app).

here's ldd info that might be relevant... can't find those missing packages.
ldd ~/.local/share/Steam/ubuntu12_32/                             (0xf7f8f000) => /usr/lib/i386-linux-gnu/ (0xf662f000) => not found => not found => /lib/i386-linux-gnu/ (0xf6624000) => /usr/lib/i386-linux-gnu/ (0xf6615000) => /usr/lib/i386-linux-gnu/ (0xf65fe000) => /usr/lib/i386-linux-gnu/ (0xf65e9000) => /usr/lib/i386-linux-gnu/ (0xf657c000) => /usr/lib/i386-linux-gnu/ (0xf642d000) => /usr/lib/i386-linux-gnu/ (0xf6425000) => /lib/i386-linux-gnu/ (0xf6405000) => /usr/lib/i386-linux-gnu/ (0xf630f000) => /usr/lib/i386-linux-gnu/ (0xf62b1000) => /usr/lib/i386-linux-gnu/ (0xf6241000) => /usr/lib/i386-linux-gnu/ (0xf60ff000) => /usr/lib/i386-linux-gnu/ (0xf60d1000) => not found => not found => not found => /usr/lib/i386-linux-gnu/ (0xf5ea6000) => /lib/i386-linux-gnu/ (0xf5e9e000) => /usr/lib/i386-linux-gnu/ (0xf5cc0000) => /lib/i386-linux-gnu/ (0xf5c9d000)
        /lib/ (0xf7f91000) => /lib/i386-linux-gnu/ (0xf5b98000) => /lib/i386-linux-gnu/ (0xf59aa000) => /usr/lib/i386-linux-gnu/ (0xf599e000) => /usr/lib/i386-linux-gnu/ (0xf5921000) => /usr/lib/i386-linux-gnu/ (0xf58e5000) => /usr/lib/i386-linux-gnu/ (0xf58b6000) => /lib/i386-linux-gnu/ (0xf5889000) => /usr/lib/i386-linux-gnu/ (0xf5874000) => /usr/lib/i386-linux-gnu/pulseaudio/ (0xf57e6000) => /lib/i386-linux-gnu/ (0xf5788000) => /usr/lib/i386-linux-gnu/ (0xf577e000) => /lib/i386-linux-gnu/ (0xf5707000) => /usr/lib/i386-linux-gnu/ (0xf5701000) => /lib/i386-linux-gnu/ (0xf56e3000) => /lib/i386-linux-gnu/ (0xf5675000) => /lib/i386-linux-gnu/ (0xf5647000) => /lib/i386-linux-gnu/ (0xf562e000) => /lib/i386-linux-gnu/ (0xf560d000) => /usr/lib/i386-linux-gnu/ (0xf5607000) => /usr/lib/i386-linux-gnu/ (0xf55ff000) => /usr/lib/i386-linux-gnu/ (0xf54ee000) => /usr/lib/i386-linux-gnu/ (0xf54cf000) => /lib/i386-linux-gnu/ (0xf5414000) => /usr/lib/i386-linux-gnu/ (0xf5408000) => /usr/lib/i386-linux-gnu/ (0xf5376000) => /usr/lib/i386-linux-gnu/ (0xf536f000) => /lib/i386-linux-gnu/ (0xf530f000) => /usr/lib/i386-linux-gnu/ (0xf5276000) => /lib/i386-linux-gnu/ (0xf524a000) => /usr/lib/i386-linux-gnu/ (0xf5227000) => /usr/lib/i386-linux-gnu/ (0xf5144000) => /lib/i386-linux-gnu/ (0xf5127000) => /usr/lib/i386-linux-gnu/ (0xf50ec000) => /usr/lib/i386-linux-gnu/ (0xf50e0000) => /usr/lib/i386-linux-gnu/ (0xf50b3000) => /usr/lib/i386-linux-gnu/ (0xf5026000) => /lib/i386-linux-gnu/ (0xf5000000)

Last edited by The_Aquabat on 31 July 2020 at 2:07 pm UTC

The_Aquabat 5 days ago

as expected with Flatpak the game runs fine, so it is a dependency problem, not sure if I should report this, maybe I messed up my system dependencies. The game is Dirt Rally 2.0, all other games I tried run fine.

The_Aquabat 4 days ago

I ended up removing all i386 libraries like this

sudo apt-get purge ".*:i386"

then removing the steam folder in ~/.steam and ~/.local/share and then reinstalling steam!
Now it works

While you're here, please consider supporting GamingOnLinux on:

Patreon, Liberapay or PayPal Donation.

We have no adverts, no paywalls, no timed exclusive articles. Just good, fresh content. Without your continued support, we simply could not continue!

You can find even more ways to support us on this dedicated page any time. If you already are, thank you!

You need to Register and Login to comment, submit articles and more.

Or login with...