Support us on Patreon to keep GamingOnLinux alive. This ensures all of our main content remains free for everyone with no article paywalls. Just good, fresh content! Alternatively, you can donate through PayPal, Liberapay or Buy us a Coffee. You can also buy games using our partner links for GOG and Humble Store.
new 6900 xt, memory staying at 1000mhz
orlfman 3 Feb
so i noticed really high idle temps and power usage with my 6900 xt i just got. digging around i noticed that the memory frequency is being stuck at 1000mhz.

[orlfman@linux64: ~]$ sudo cat /sys/class/drm/card0/device/pp_dpm_mclk
[sudo] password for orlfman:
0: 96Mhz
1: 456Mhz
2: 673Mhz
3: 1000Mhz *
[orlfman@linux64: ~]$


i'm not sure if this is normal considering it is showing four power states for memory. anyone else with a 6900 xt or even a 6800 xt notice this behavior? I have the following:

Kernel: 5.10.11-arch1-1 Firmware: 20201218.646f159-1 Mesa: 20.3.4
i also have amdgpu added to /etc/mkinitcpio.conf for early KMS. at first i figured it might be my monitor, as i have a 165hz 1440p ips screen. but changing refresh rate down to 60hz doesn't change the memory clock.

outside that and the high idle temps plus power consumption (55-60c on core, hotspot, and memory, and 30-40 watts idle), so far its been running fine. just use to my previous nvidia card that dropped memory down along with core.
Samsai 3 Feb
Old knowledge says this is definitely expected behaviour if you are running the monitor at refresh rates other than 60 or 120 Hz or you have multiple monitors. But if you are on a single monitor and have it set to 60 Hz (don't know if a reboot is needed to get everything back in sync) then it's hard to say what is going on. Quick look up gets results of people talking about rather precise refresh rate and memory clock alignments.
Xpander 3 Feb
I'm quite sure its a bug... i have nvidia though and i have 1 monitor 144hz and other 60hz (both 2560x1440) and it goes nicely down to lowest clocks on idle. But when i hook up my TV (4K) also.. aka third one then it doesn't go to the lowest powerstate.

edit: now to think it might also be some sort of compositor bug maybe? maybe it somehow keeps the GPU awake all the time.

Last edited by Xpander on 3 February 2021 at 11:42 am UTC
dpanter 3 Feb
Same here, always 1000 MHz memory clock. I guess reclocking isn't implemented properly at this time. Can't change much of anything with either Radeon-profile or CoreCtrl really.
I don't know if this also affects RX 6800 (non XT) but I have a 1440p / 165hz monitor. Will run some digging myself. I didn't notice any abnormal temperatures so far though.
Same results here on a 6800 Xt. The card behave normally.

Maybe I'm totally wrong but could it behave like dual channel memory where the FSB was 800 Mhz with 2 ram sticks clocked at 400 Mhz ? So in this case, we have two vram lane each clocked at 1000 Mhz which comes close to the default 2000~ish Mhz.

Overdrive is planned for 5.12 btw.
Running OP's command my 6800 non-XT produces same results too. Temps are a few degrees lower. My card's fans only spin when it's at a high load.
orlfman 3 Feb
thank you guys for chiming in! nice to know i'm not the only one

from digging around some more:
[orlfman@linux64: ~]$ sudo cat /sys/class/drm/card0/device/power_dpm_state
[sudo] password for orlfman:
performance
[orlfman@linux64: ~]$

as you can see, it reports back performance for its power state. i think default should be balanced.
[orlfman@linux64: ~]$ sudo echo "balanced" > /sys/class/drm/card0/device/power_dpm_state
[sudo] password for orlfman:
[orlfman@linux64: ~]$ sudo cat /sys/class/drm/card0/device/power_dpm_state
balanced
[orlfman@linux64: ~]$

core frequency changes are as aggressive as performance, memory still stuck at 1000mhz. the card still behaves as performance.
echo "low" > /sys/class/drm/card0/device/power_dpm_force_performance_level
issuing low to force the lowest possible power state doesn't change anything either. i think as of right now, only the performance power mode is the only state supported. which can explain why the memory frequency doesn't change. only core frequency changes but it is more aggressive. hopefully we can get more power states in newer firmware or kernel drivers.

ultimately this isn't necessary bad. its not going to hurt the card. its no different than system memory that runs at its maximum speed 24/7. it just causes slightly higher power consumption and slightly more heat at idle.

i also "fixed" my high idle temps by "fixing" the fan stop problem.
[orlfman@linux64: ~]$ sudo echo "1" > /sys/class/drm/card0/device/hwmon/hwmon4/pwm1_enable
[sudo] password for orlfman:
[orlfman@linux64: ~]$ sudo echo "40" > /sys/class/drm/card0/device/hwmon/hwmon4/pwm1

40 sets the fan's to spin at 15% of their rated pwm speed. pwm = 255 for 100%. %*2.55 = pwm number. so 15*2.55 = 38.25. i just rounded off to 40. i don't mind doing this as if i used windows i would be using the control panel to take control of the fan speed too. i really don't like fan stop. when i game i'll just either reset it back to auto or set it to 70% (179).

to set fan control back to the cards vbios control issue:
sudo echo "2" > /sys/class/drm/card0/device/hwmon/hwmon4/pwm1_enable
or just reboot. all changes from everything above are reverted back to default after a reboot.

oh your card might not be hwmon4. it could be hwmon0, hwmon1, etc. it's whatever the kernel identifies it as.

edit:
oh, i have compositing disabled in xfce too. use to disabling it because it didn't play nice with Nvidia for me.

Last edited by orlfman on 3 February 2021 at 9:21 pm UTC
@orlfman

Thanks for the detailed guide, I was never a fan of the fans being completely off until a certain temperature, way before I moved to an AMD gpu. Will give your notes a shot :)
orlfman 3 Feb
Quoting: Avehicle7887@orlfman

Thanks for the detailed guide, I was never a fan of the fans being completely off until a certain temperature, way before I moved to an AMD gpu. Will give your notes a shot :)
np! even on nvidia i did the same too with enabling coolbits "4" in xorg.
orlfman 10 Feb
Hey guys, want to give an update. I installed windows on a secondary ssd to mess around with 3dmark, and I noticed something.. high idle power usage (same as Linux) and vram clocked at 1000mhz (2000mhz reported under windows, actually). So I want to say, this doesn't appear to be a Linux only issue. AMD must have a good reason why they are clocking the ram so high at idle on Navi 2.
While you're here, please consider supporting GamingOnLinux on:

Patreon, Liberapay or PayPal Donation.

We have no adverts, no paywalls, no timed exclusive articles. Just good, fresh content. Without your continued support, we simply could not continue!

You can find even more ways to support us on this dedicated page any time. If you already are, thank you!
Login / Register

Or login with...
Sign in with Steam Sign in with Twitter Sign in with Google
Social logins require cookies to stay logged in.