Join us on our own very special Reddit: /r/Linuxers
Somehow a partial fix for unstability on Navi hardware (ring_gfx timeout)
So I was reading the rather longish bug report of this issue

somehow a very common source on unstability on Navi hardware. One of the last comments suggests to clock the Gpu at 1620 (max clock) because that's the reference spec. (this is on 5600xt you would have to find out the reference clock yourself if you have a different card)
I've used corectrl to set the gpu clock about a week ago, and since then, I have almost no crashes, the only remaining crash for me is Golf with your friends... but anyway seems to do something and partially work. I would be interested if someone is having this issue and tries this fix to report back if it works for you .
tuubi 9 Feb
If I bought a GPU that wasn't stable at factory clocks, I'd RMA it. Unless it's a problem with your case cooling.
Quoting: tuubiIf I bought a GPU that wasn't stable at factory clocks, I'd RMA it. Unless it's a problem with your case cooling.
it only happens with the open source driver.

Besides it's not that easy to RMA something where I live, I wish I live in a country were they had "no questions asked" RMA. And also the 30 days guarantee of the seller is over so I would have to ask for a RMA to Gigabyte which is not easy, mainly because the issue is not reproducible on Windows so I highly doubt this will qualify as a RMA... here they test the hardware to confirm the issue.

Yes it is a harware bug that some Navi cards have, but all the drivers except the mesa open source driver, have figured a workaround to sort this out.

I once tried to RMA a motherboard that had broken IOMMU routing on Linux, and that gave disconnects with USB ports, and because the issue didn't happen on Windows ofc they did not RMA the mobo.

this suxxs man, makes me remember of the Ryzen 1 bug that gcc and linux had that gave pagefaults, seems it's the silicon lottery some cards have it some don't. And the bug didn't not happen on Windows... so for me it didn't not qualify as a RMA. But after several months the Ryzen bug was completely fixed but yeah it took some time like more than a year, maybe two years.

Last edited by The_Aquabat on 9 February 2021 at 3:13 pm UTC
Anarus 10 Feb
I have also had this problem with crashes ranging from once a day to several per hour. What worked for me was to force the GPU to use PCIe 3.0 in the BIOS. My theory is that the card was erroneously trying to use PCIe 4.0 which the motherboard (X470) didn't support.
Samsai 10 Feb
It probably doesn't really apply to these Navis, but I'll just point out that I fixed my RX580 not that long ago which was exhibiting these sorts of problems by replacing the thermal paste. If you have the chance to RMA definitely prefer to go that route since I don't know what the warranties say about popping the heat-sink off, but if you can't RMA and you've handled a screwdriver and thermal paste before, that might be an option.
The_Aquabat 10 Feb
the crash I'm talking about is documented on the wiki

when I bought the card I remember it was running flawlesly as the wiki suggest maybe some older kernel and drm drivers don't had this issue...
Don't know, now after 1 week I had another crash, at least it's running much stable imho but the crash is still there. The crash makes all the screen have green stripes (vertical and horizontal) and lots of green dots, seems like a memory issue imho. Sometimes I just can restart Xorg and the gpu resets and sometimes it's a hard freeze and I have to hard reboot.
While you're here, please consider supporting GamingOnLinux on:

Patreon, Liberapay or PayPal Donation.

We have no adverts, no paywalls, no timed exclusive articles. Just good, fresh content. Without your continued support, we simply could not continue!

You can find even more ways to support us on this dedicated page any time. If you already are, thank you!
Login / Register

Or login with...
Sign in with Steam Sign in with Twitter Sign in with Google
Social logins require cookies to stay logged in.

Livestreams & Videos
None currently, submit yours here!