You can sign up to get a daily email of our articles, see the Mailing List page!
Nvidia max clock speed wrong
Mohandevir 17 Sep
Here is the thing... I got an Asus Phoenix GTX 1660 Super (Yeah! That crappy card) which is very noisy (fans are always spinning at 75% to 100% no matter what game I play) and it generates a lot of heat.

Thing is, when I check the max graphic clock speed, the Nvidia control panel and GreenWithEnvy are telling me that it's set to 2100Mhz... I find that quite weird since that GPU is rated to 1830Mhz boost clock and 1800Mhz gaming mode... Is it the norm or could this explain my heat and noise issues on Linux? Out of curiosity, I tested it on Windows and it's not as noisy.

Right now, I'm using the coolbits -12 and reduced the clock speed by 270 in GreenWithEnvy... Is it the right thing to do? Is it how it works?

Any help or piece of advice would be appreciated.

Thanks!

Edit: I must add that there are no performance issues. It's just that the noise is unbearable; it sounds like a jet engine and destroys the experience.

Last edited by Mohandevir on 17 September 2021 at 4:04 pm UTC
tuxintuxedo 17 Sep
I never tried something like that, but one of the sources say that 2100 MHz is the overclock achieved by raising the power limit to maximum on this model (an MSI GPU, but the same model). Did you buy it from someone else? Maybe the power limit was set on it differently from the default value. I have no idea how to check it or reset it. Windows has overclocking softwares that can do things like this.

Last edited by tuxintuxedo on 17 September 2021 at 8:27 pm UTC
Mohandevir 17 Sep
Thanks! No, I bought it brand new. I have absolutely no clue when it comes to overclocking/underclocking. Usually I just put the thing in my case and play.
Alexander 18 Sep
Have you checked the actual clocks which are actually reached in Games? you can see them also in the Nvidia ui.
Mohandevir 25 Sep
Yep. It reaches 1965 Mhz with 85deg and 79% fan. I downclocked it by 135Mhz... It gives me the stock OC of 1830Mhz and lowers the temp to around 79deg and the fan load to 74%. It's slighlty better but still way too noisy.

On the other hand, I just found a much better workaround... AMD FidelityFX (FSR). With Proton-6.16-GE-1 and the launch option "WINE_FULLSCREEN_FSR=1 %command%", I reduce the in-game resolution to 1600 x 900 and I can't see any visual difference. In fact, imo it looks sharper/cleaner than native 1920*1080, my GPU never reaches more than 69deg and the fan load never gets above 56% in both tests I did in Witcher 3 and F1 2021. The problem seem solved.
Xpander 25 Sep
i personally wouldn't downlclock. The GPU usually just boosts as high as it can given the temp range and powerlimits its configured.

what you can do is just set the powerlimit a bit lower, if your GPU is way too noisy and hot.

basically: nvidia-smi -q | grep Power

and then run nvidia-smi -pl xxx

you could also add the nvidia-smi to sudoers or make polkit rule for it to add it to starup for example.

Last edited by Xpander on 25 September 2021 at 6:43 am UTC
While you're here, please consider supporting GamingOnLinux on:

Patreon, Liberapay or PayPal Donation.

This ensures all of our main content remains totally free for everyone with no article paywalls. We also don't have tons of adverts, there's also no tracking and we respect your privacy. Just good, fresh content. Without your continued support, we simply could not continue!

You can find even more ways to support us on this dedicated page any time. If you already are, thank you!
Login / Register

Or login with...
Sign in with Steam Sign in with Twitter Sign in with Google
Social logins require cookies to stay logged in.

Livestreams & Videos
Community Livestreams