Anyone having issues with Steam BPM and their controller?
denyasis Jan 21
So, this is a weird one....

I fired up Steam for the first time since last May via my Steam Link using a Steam controller.... And it didn't work in BPM!! The glyphs would change to the SC glyphs, but pushing "B" for back, seemed to scroll down and the other buttons didn't do what they should have according to the glyphs!

I realized the options for the controller to check and update firmware were missing (they haven't updated it in years anyway, but now you can't even do a factory reset!)

I realized after a while the controller was "working". It was running in its "Desktop" mode, with bindings that don't match the onscreen glyphs. Trying to change the bindings (make "B" be "B") does nothing. Even worse, this continues into any launches games. I tried it with Portal and the configuration remained the desktop configuration even though the "controller" profile showed different bindings.

I think BPM on the desktop thinks it's in Desktop mode even though BPM is in focus... So I'm not sure if it's a SC issue.

I tried streaming from my Deck. Everything works fine. I also tried it from Steam Flatpack and it works... But I'd rather not use the flat pack for a number of reasons (performance seems slower, using mods on a few games, etc).

Has anyone run into this?

Running Manjaro XFCE, latest kernel (6.x) and Nvidia stable driver (1070Ti) on an Intel (i-5 9600k). It's a stock install, only use it for Gaming and web browsing.

I know everything was fine around last May, so I'm not sure what happened?? Googling around seems to point to the new BPM, but no I've found real solutions so far.
minthenry Jan 22
I'm having this issue for two days now.

Left stick scrolls up and down, right stick moves the mouse, right trigger is left mouse button.

Can't give exact version information right now as I'm not at there computer.

Using Linux Mint 21.3 kernel version 6.4(?) and package version of steam beta. Controller is a wireless Xbox controller.
denyasis Jan 22
Thanks! Glad to know I'm not going crazy! Lol.

I'm pretty sure my SC is a similar configuration; it's the "Desktop mode" controller bindings.

I switched my controller over to BT and tried it locally and I noticed when switching to BPM, Steam seems to create and destroy a crap-ton of Windows on my desktop. I'm beginning to think BPM somehow thinks it's losing focus, switches to "Desktop mode" for the controller and then never switches back.

Even weirder, the glyphs change when I turn on/off the Controller, switching from rather useless Steam Deck glyphs to SC glyphs when I power it on, so I know Steam on some level is recognizing the controller is there.

On a side note, the flatpack version of Steam does not seem to have this issue, the controller works just fine in BPM (I've yet to try a game and I won't get a chance for a few days).
minthenry Jan 22
Did some quick testing today and the issue only occurs while streaming to steam link. At least with a steam controller it works fine on my computer.

So not a BPM issue but rather a steam link/streaming issue. Using a Xbox controller with steam link.

Last edited by minthenry on 23 January 2024 at 5:17 am UTC
While you're here, please consider supporting GamingOnLinux on:

Reward Tiers: Patreon. Plain Donations: PayPal.

This ensures all of our main content remains totally free for everyone! Patreon supporters can also remove all adverts and sponsors! Supporting us helps bring good, fresh content. Without your continued support, we simply could not continue!

You can find even more ways to support us on this dedicated page any time. If you already are, thank you!
Login / Register

Or login with...
Sign in with Steam Sign in with Google
Social logins require cookies to stay logged in.