Check out our Monthly Survey Page to see what our users are running.
Fedora repository for a few emulators
slavezeo 24 Sep, 2016

I mess with classic and retro gaming quite a bit, usually through emulators rather then actual hardware. I am also a Fedora Linux user. Due to the "free only" nature of Fedora there are very few emulators included in the default repositories. RPMFusion carries a larger selection of emulators but they generally package stable releases. This is where I decided to jump in and compile/package my favorite and most used emulators. Right now the selection is small, but I am looking into adding new packages all the time. There is no real method to what I add, just whatever I'm interested in at the time. I do try to keep the emulators I regularly use up to date with recent git builds.

The repository is housed on it's own hosting. I was going to host on COPR but they have some rules against emulators which require a BIOS to function. This clearly rules out most the emulators I enjoy.

If you want to enable the repository just issue the following command in a terminal. You'll also need to have the RPMFusion repository ( enabled as I use a couple of their packages to compile. These rpm packages are also GPG signed.

sudo dnf config-manager --add-repo

After the repository is added to dnf enter the normal dnf installation commands to install.

sudo dnf install <package name>

I am currently packaging PCSX2 git builds (pcsx2), Dolphin-Emu git builds (dolphin-emu), Mednafen latest source release (mednafen), and the Mednafen front end Mednaffe (mednaffe). I might also take requests to package others emulators provided I can get them to compile under Fedora. If you think of one which might be enjoyable then please leave a reply here and I'll see what I can do. Be polite though.

Right now I am building Packages for Fedora 24. When Fedora 25 is released in November I will drop support for 24 and move on to 25. I hope this helps other Fedora users get to try and have fun with current builds of my favorite emulators.

I'm pretty new to packaging and repository hosting. If you run into a glaring problem please reply to this thread to let me know.

m2mg2 25 Sep, 2016

sweet. Last time I compiled PCSX2 on Fedora it was a royal pain.

slavezeo 27 Sep, 2016

Yeah, I had the crap time with compiling PCSX2 under Fedora too. That was until I went against the grain and compiled it with Wx3.0 and SDL1.2. I couldn't get Wx2.8 and SDL2 to compile for the life of me. CMAKE just would not find my install of wX2.8 no matter what switches I passed. At that point I gave up and tried Wx3.0. Strangely it worked. I didn't even have problems with multi-lib compiling i686 on my x86_64 machine. I used to have to compile in a 32bit virtual machine, which was kinda a pain.

slavezeo 1 Oct, 2016

I updated the fedora 24 repository with the latest git build as of OCT 01 2016 (d8e0b9f). Since I'm not a master of the fedora repository yet you'll want to uninstall pcsx2 and reinstall it. I haven't quite figured out how to have dnf see my builds as an update to the older package.

To remove pcsx2 use the following command in a terminal. dnf will ask you to provide your password.
sudo dnf remove pcsx2

To reinstall pcsx2 use the following command in a terminal. Again dnf will ask you to provide your password.
sudo dnf install pcsx2

Thanks and enjoy.

slavezeo 2 Oct, 2016

A few moments ago I updated my repository with a current rpm of Dolphin-Emu, git build 5.0-754. This build is current as of OCT 02 2016.

In an effort to try and get the repository to update instead of require an uninstall and reinstall you can maybe try this command to force a reread of the repository manifests.

sudo dnf clean all

After you clean dnf's cache you can try upgrading dolphin-emu. This time it should (maybe) update to the newer build. Try this command to update.

sudo dnf update dolphin-emu

If not... well, I'm still working on figuring out this repository thing. You can always just remove and install dolphin-emu using dnf. I'm pretty sure you'll have to do the dnf clean all command anyway, though. Dnf doesn't seem to pick up on changes made to my repository. I am eading up on why right now, I'll have it ironed out soon.

slavezeo 28 Dec, 2016

Unfortunately I ended up axing the repository as I'm just not up to successfully running one. That and a bit of a lack of interest. It shouldn't affect much though, I'll still update and post Google Drive links to the new builds here and on the emulators respective official forums.


You need to Register and Login to comment, submit articles and more.

Or login with...