You can sign up to get a daily email of our articles, see the Mailing List page!
Support us on Patreon to keep GamingOnLinux alive. This ensures we have no timed articles and no paywalls. Just good, fresh content! Alternatively, you can support us on Paypal and Liberapay!
[Solved] Steam controller no longer work in most games? ( over steam link )
Guppy commented on 10 February 2017 at 10:01 pm UTC

I recently switched to Linux Mint 18.1, installed steam, copied my games over so I wouldn't have to re-download them. The games can be launched - so far so good.

Unfortunately most of my games no longer work with the steam controller, even games I played just before switching.

What works;

menus, slime rancher, portal 2

What doesn't work;

Action henk, Rocket league, Bastion


What I've tried to solve it;

1 Enabling beta in the steam client
2 updating the udev rules per this guide;
https://www.mleonarddesigns.com/blog-1/2016/12/25/fixing-the-steam-controller-udev-rules-after-linux-mint-181-upgrade
3 copying over 99-steam-perms.rules from the 16.04 system


I'm fairly sure 2 & 3 only for if your using it directly on the host system rather than via steamlink.

I'd verify that it's a mint issue ( rather than a whole pile of games breaking at once ) by booting the 16.04 system and running there but I'm not getting EFI disc errors when I boot that one -.-'

hAlp?

Guppy commented on 11 February 2017 at 12:16 am UTC

So I reinstalled Ubuntu 16.04 over the old non working version ( seperate disc, seperate /home partition from mint ) reinstalled all my packages thanks to aptik. updated steam ( now in /usr/games/steam rather than /usr/bin/steam.. ) none of my installed games could found ( steam have new default install directory as I found out on mint ). Just to verify that my games work on ubuntu I install one and try - sure enough it works.

Back to mint to try if reinstalling my games will make the controller work. Randomly I decide to test that it's still broken before un-/reinstalling all of my games, and it's not. all of the games now work again, and I've no idea why it stopped working or what made it work again.

Maybe my computer just hates me?

markackerman8@gmail.com commented on 22 November 2017 at 7:39 am UTC

The quick answer

sudo apt install steam-devices

The Long answer ...
Steam Controller "No Controller Found" and NO "Add Controller" Option Ubuntu - Solved!
Maleko, Thanks VERY MUCH for your input!

I haven't used the steam controller for half a year, and i Jjust tried to see if it was working with Ubuntu 17.10's awesome new OS. ..., and

"No Controller Detectyed" .... as well as
No "add Steam Controller" Option in BPMode - Unbeleivable!

all while 2 things:
1/ it worked in plugged in mode (stil undetected !!!!!)
2/ In wireless mode - totally unresponsive - EXCEPT - it lights up and lights off when restarting the computer
SO I KNEW it and the wireless dongel waere basically functional - again UNBELIEVABLE!

and just your command brought it back, Maleko

sudo apt install steam-devices

Thanks, Mark
p.s. This is worth its' own thread, as Googling for half an hour found no answer ... until yours MALEKO!

Guppy commented on 22 November 2017 at 8:12 am UTC

Spam much?
https://steamcommunity.com/app/221410/discussions/0/3183345176720737564/?ctp=2#c1489992080497436947
https://askubuntu.com/questions/920305/steam-controller-works-in-steam-but-not-in-games-under-ubuntu-17-04

I'm glad that you managed to get help with solving an issue, but necroing a 9 months old thread that's marked as solved with a solution to a different problem is spam pure and simple.

Due to spam you need to Register and Login to comment.


Or login with...

Livestreams & Videos
Official Livestreams
  • Borderlands: The Pre-Sequel - the final attempt?
  • Date:
Community Livestreams
  • RPGoodness: "Dragon Age Origins" (via Wine)
  • Date:
See more!
Popular this week
View by Category
Contact
Latest Forum Posts
Facebook