You can sign up to get a daily email of our articles, see the Mailing List page!
Support us on Patreon to keep GamingOnLinux alive. This ensures we have no timed articles and no paywalls. Just good, fresh content! Alternatively, you can donate through Paypal, Flattr and Liberapay.!
  Go to:
[League of Legend] Strange graphic behavior in game
DerpFox commented on 1 December 2018 at 3:10 pm UTC

Hello guys!

I've successfully installed LoL via Lutris. The game launcher start well download everything without a problem. Work as intended until I start a game.

image

As you can see the image is kind of shrinked and I don't know what to do with that.

An other strange behavior that occurs is with the cursor (on the picture just under the tower on the right), when I do any clicking the aera of action is far on the left. Here if I click where the cursor is to move Jinx the effect will take place at the feet of Jinx. If I'm not clear I'll try to record a video if you want.

So can some one help me with that?

I can provide you any log needed as long as you tell me where to get them.

Thank you.

DerpFox commented on 8 December 2018 at 10:23 am UTC

Any one?

That can't be that compliated , I'm ersonally unable to guess what is hapenning myself, I'm not a power user and I'm stuck.

sterky commented on 8 December 2018 at 10:56 am UTC

Hey,

League should update config from server, but maybe it can't update your local files?
Could perhaps check if file permissions are okay in league folder.

Also have you checked if league config file has correct resolution?
Mine:

In wine prefix navigate to league install dir (i don't have a clue where lutris holds the game, i have never used it before =) using custom paths and scripts for years to play league)

"League of Legends/Config/Game.cfg"
[General] Width=2560 Height=1440

Spoiler, click me

Just to be sure, maybe some other setting relevant there aswell i will add full section of my [general] section
This sets the game at medium settings tho, so might have to tweak if you want more eye candy =)
[General] HideEyeCandy=0 EnableTargetedAttackMove=1 RelativeTeamColors=1 x3d_use_cg=true ShowTurretRangeIndicators=1 SnapCameraOnRespawn=1 CfgVersion=5.15.333 WindowMode=0 BindSysKeys=0 OSXMouseAcceleration=0 AutoAcquireTarget=1 LanguageLocaleRegion=en_GB SystemMouseSpeed=0 GameMouseSpeed=0 Width=2560 Height=1440 Colors=32 WaitForVerticalSync=0 PredictMovement=0 Windowed=DEPRECATED EnableLightFx=0 BorderlessWindow=0 UserSetResolution=1

gl hf

DerpFox commented on 8 December 2018 at 12:53 pm UTC

Thank you for your help. No one seems to be interested in that problem in all the places I posted.

So unfortunatly tyhat didn't work. The width is set to 6400 and each time I manualy modify it to 2560 the game set it back to 6400.

That 6400 does come from nowhere its is exactly yhe witdh of my 3 screens combined 1920 + 2560 +1920. I don't understand why it use this width and not the primary screen witdth.

Xpander commented on 8 December 2018 at 2:05 pm UTC

do you have xinerama enabled by some reason?

whats inside your /etc/X11/xorg.conf or /etc/X11/xorg.conf.d/xx-nvidia.conf

you can also try to run it in wine virtual window (where you can set the desired resolution), you can find it under winecfg, dont know how to do it in Lutris but i assume the option is there.

DerpFox commented on 8 December 2018 at 8:19 pm UTC

Hi,

Sorry for the mong answer.


xorg.conf : https://framabin.org/p/?fcb5279bc920bb72#t8D27uf0s09HJ7pcLeoDqrQJ/PkVJeUMxbTTvR0w0p4=

I don't have xinemera enabled it make Xorg crash on my computer.

The actual config is one Xorg Screen with 3 monitor in it. I tried 3 Screen with one Monitor in each but it crash Xorg.

Xpander commented on 8 December 2018 at 10:57 pm UTC

So does it work if you disable all your other screens (aka unplug)? so we can confirm if its a screen setup issue somewhere.

also did you try virtual wine desktop?

DerpFox commented on 8 December 2018 at 11:25 pm UTC

I didn't needed to unplug my monitors just disabling them via Cinnamon monitor settings worked. But 2 out of 3 need to be disable only disabling one doesn't work.

I never used a virtual winbe desktop. I don't enven know how wine work by it self I only use Play on Linux, Lutris, or Steam. Windows thing tend to give me a headache.

For exemple it's been 3 weeks I'm trying to setup a Samba share (but that is an other story for an other time) so playing with wine advanced settings as things generaly work as is with PoL or Lutris was not a plan at the moment. :p

But I'm not closed to do it if given instructions or directed to the good ressources. As my goal is by the end of 2019 to not need Windows any more (a not so easy goal for my needs) I'm ready to do things the right way.


---------------------------------------------------------

This is a big edit. Investigation went on, on an other forum. This has been tested on different version of wine.

Wine logs give us the following error :

007e:err:winediag:xrandr12_init_modes Broken NVIDIA RandR detected, falling back to RandR 1.0. Please consider using the Nouveau driver instead.

Some reasearch gave me different solution none worked.

In the wine prefix setting the following options made things worst (src: link || link)
winetricks orm=backbuffer glsl=disable

image

As you can see the resolution and proportion are the good ones but the orm change make everything else going bad. So we are back to our starting point.

As suggest by this nvidia forum post Wine seem confused wen presented with mutiple possible resolution for one monitor. To counter that (as showed here) we should set the following option in our xorg.conf file so Xorg doesn't out put them and only the native resolution of said monitor.

Option "IncludeImplicitMetaModes" "off"

Now doing :
xrandr --q1

Give us :

$ xrandr --q1 SZ: Pixels Physical Refresh *0 6400 x 1440 (1505mm x 341mm ) *50 Current rotation - normal Current reflection - none Rotations possible - normal left inverted right Reflections possible - X Axis Y Axis

Now we are getting at the heart of the problem!
In the actual config of Xorg it is considering the 3 monitors ad one big screen of 6400*1440 outputting that as its native resolution. Wine seem to take that quite literally.

As using Xinerama to setup 3 screens with 3 monitors make Xorg crash I don't know what to do any more. (this is an other problem the may not have a solution)

Do you think using Wine virtual desktop might change something?

Xpander commented on 9 December 2018 at 8:41 am UTC

Something still must be off. xrandr --q1 reports like that for sure. i get with 2 monitors enabled (have third one also but its TV)

Spoiler, click me
$ xrandr --q1 SZ: Pixels Physical Refresh *0 5120 x 1440 (1733mm x 487mm ) *50 1 1920 x 1080 ( 650mm x 365mm ) 51 52 53 54 55 2 1600 x 1200 ( 541mm x 406mm ) 56 3 1440 x 900 ( 487mm x 304mm ) 57 4 1400 x 1050 ( 474mm x 355mm ) 58 5 1360 x 850 ( 460mm x 287mm ) 59 6 1360 x 768 ( 460mm x 260mm ) 60 7 1280 x 1024 ( 433mm x 346mm ) 61 62 8 1280 x 960 ( 433mm x 325mm ) 63 9 1280 x 768 ( 433mm x 260mm ) 64 10 1280 x 720 ( 433mm x 243mm ) 65 66 11 1152 x 864 ( 390mm x 292mm ) 67 12 1024 x 768 ( 346mm x 260mm ) 68 69 70 13 800 x 600 ( 270mm x 203mm ) 71 72 73 74 14 720 x 576 ( 243mm x 195mm ) 75 15 720 x 480 ( 243mm x 162mm ) 76 16 640 x 480 ( 216mm x 162mm ) 77 78 79 17 1680 x 1050 ( 568mm x 355mm ) 80 18 1366 x 768 ( 462mm x 260mm ) 81 19 1280 x 800 ( 433mm x 270mm ) 82 Current rotation - normal Current reflection - none Rotations possible - normal left inverted right Reflections possible - X Axis Y Axis


that shouldnt confuse wine.

anyway lets try the virtual desktop thingy. you have to find you winecfg and then use this:

image

it will make 1 monitor sized virtual window, inside that LoL launcher and everything will start.
NOTE! you might want to enable the mouse capture also from there if that becomes a problem with this game.

If that works, then i think you have some weird configuration with your system displays, as it shouldnt matter how many of them you have connected, games should still be able to pick up correct resolutions

DerpFox commented on 9 December 2018 at 3:22 pm UTC

So that worked, its not perfect but its still better than disabling my two other monitors.

I have some ideas of what is happening but I can't confirm anything I'm not a vrsed enought in linux secrets to confirm anything.

When plugged one of my 3 monitors isn't "properly" detected I see something like ! Asus VS 238 + Acer XB270HU + Unknown. But left and right are the two same monitors. I see no reason why the third one isn't detected properly, it could be from Xorg, nvidia drivers, or even Asus not properly writing metadatas in its monitors making Xorg not understanding why the same monitor is plugged on two different outputs.

It could also be the fact that I use two diffrent type of output and xorg want only the same one used in a multi head setup.

It could be so many things ...

Xpander commented on 9 December 2018 at 3:37 pm UTC

you can try and nuke your xorg.conf or make a backup of it.

sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.backup sudo rm /etc/X11/xorg.conf

then go into your nvidia-settings and set everything up properly again like you want your monitors be

and at the end run:

sudo nvidia-xconfig

and reboot, see if that helps

edit: about "Unknown monitor" reporting, that might be a cable issue also. If possible, try with different cable. Can be ofc monitor issue that its not reporting information correctly, but that sounds rather rare case.

  Go to:

Due to spam you need to Register and Login to comment.


Or login with...

Livestreams & Videos
Community Livestreams
  • Puzzle Tiles: „Blocks That Matter“
  • Date:
See more!
Popular this week
View by Category
Contact
Latest Comments
Latest Forum Posts