Check out our Monthly Survey Page to see what our users are running.
Games no longer starting under Proton with second HDD
cwbutcher 27 Mar, 2019


I wonder if anyone might be able to help me at all.

Many games I have previously played under Proton and that seem to work well still for others according to are no longer even opening for me.

For example Deus Ex: Human Revolution I played through extensively back in August and September (nearly 60 hours without a problem) but now when I try to open it it says running, then syncing and then nothing happens. Various games do exactly the same thing while others still work perfectly.

The only thing I can think of as having changed is that I updated my system from Xubuntu 18.04 to 18.10. Not sure if that would have an impact? Any ideas or suggestions?

Thanks in advance.

Edit: I realised since my initial post that the addition of a second HDD caused the problem. No idea why though.

cwbutcher 27 Mar, 2019

I've tried other versions of proton too and have the same problem with them. Plenty of games are still working with proton though, 4.2 or otherwise. Just strange that a lot seem to have stopped working at some point.

cwbutcher 29 Mar, 2019

That has worked. Thank you so much for your help. I thought I'd tried that already but must not have removed all of the previous versions I guess.

I was thinking about reinstalling Ubuntu 18.04 over 18.10 as I'd convinced myself that must have been it. So you've saved me a lot of bother, thank you again.

Sorry to hear you're having issues with crazy taxi in the latest proton hopefully they'll sort it in the next one.

cwbutcher 3 Apr, 2019

I think I spoke too soon. While some games like Deus Ex:Human Revolution started working again I later found many others did not. Mostly the big AAA games.

After much messing around and fiddling I remembered I'd installed a second hard drive to accommodate my growing steam library a while back so I now have / on a smallish SSD and /home on a much larger HDD.

It turns out that although Linux native games and lots of proton games (especially smaller indie ones) work fine from the second drive most of the AAA ones with huge installs need to be on the smaller SSD to work.

I set up a folder /data/craig on the SSD and gave it ownership and permissions for myself and anything installed there or moved there from within steam works fine but moving games back to the default location /home/craig/.steam/steam/SteamApps/common on the HDD causes them to stop working again.

Frustratingly nearly all the games with enormous installs only work on the tiny drive. I've tried googling this and can only find people having issues with NTFS whereas mine are both Ext4 filesystem. Anybody else encountered this issue? Any idea how to resolve it whilst still keeping the 2 drives? Can't afford a large capacity SSD so for now I'm limited in what I can install there.

Redface 3 Apr, 2019

I do have at least 2 disks for steam on my linux computers and have not seen that problem.

Could be that the path gets to long, a lot of Windows programs can not handle paths longer than 260 characters

/home/craig/.steam/steam/SteamApps/common is around 40 characters, while the path on the SSD is shorter. I do not know enough about how wine handles paths to files, maybe it does use the complete linux path when calling win apis, maybe its only the windows path. But it is easy for you to check. create a new folder on your large disk called /games or something and add a stem library there.

Also how are the disks mounted, do you have any special flags on the large disk?

How large are the filesystems? The biggest filesystem I have a Steam library on is 961GB, but I do not think I have any proton games there, they go on a filesystem that is 759GB big.

I read about that steam on linux has problem with really large ZFS filesystems, but not on ext4 as far as I remember.

g000h 3 Apr, 2019

Sharing my own recent Proton experience: I have 16 Proton games installed. My Steam client set up is to "Enable Steam Play for Supported Titles" but the "Enable Steam Play for all other titles" is unticked. This is fine however, because you can individually go into each game's properties and set the game to use a specific version of Proton (e.g. The latest 4.2-2)

In order to use Proton in this way, I found that I needed to manually install the Proton Tool in the TOOLS part of the Steam Library. As I am writing this, I have Proton 3.16 Beta installed and Proton 4.2 (meaning 4.2-2) in the TOOLS list.

I have just gone through the various Proton enabled titles, and updated each of them to use Proton 4.2-2 and in some cases, when I tried to launch the game it would hang. However, a repeat attempt, and occasionally a restart of Steam Client, and eventually they are all up and running again (well, the ones that I don't have issue with.)

Here are the titles I have installed: Antihero (* never worked), Blades of Time, Braveland Heroes, Card Quest, Elder Scrolls Skyrim SE (* NPC audio still doesn't work), Fallout 3, Legend of Grimrock 2, Monster Slayers, Redout Demo, Risen, Runestone Keeper, Styx: Shards of Darkness, Super House of Dead Ninjas, Superflight, Tales of Candlekeep: Tomb of Annihilation.

Of those titles, Antihero has never worked, Skyrim SE is somewhat improved with recent Proton but I still have the NPC audio being silent problem, and Fallout 3 GOTY used to fail completely until a more recent Proton release (e.g. 4.x). The 14 games listed above with no asterisk (*) after their name all work near perfectly.

Noting that I am running Debian Linux 10 Buster (Testing) and have enabled the Experimental repository but only permitted (manually installed) the Nvidia graphics drivers/libraries from it (version 415.27).

I have all my Steam games on a second /home partition, not the primary root file-system.

cwbutcher 4 Apr, 2019

Hi Redface, thanks for your response.

I'm pretty certain it isn't the length of the path for a couple of reasons. First, when I only had the one drive everything was still installed in the longer default path and worked. Second, some of the ones that still work under proton on the HDD have longer paths than some others that do not work. I think I'll still try what you suggested if I get a bit of time over the weekend and move to /games or similar on the HDD. Just to be certain plus it is a bit tidier.

I'm not sure about any special flags I'm afraid. I'll paste my fstab below and perhaps you'll be able to see from that?

# /etc/fstab: static file system information.
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda2 during installation
UUID=3fe46b9b-06c5-4f1d-9203-41935a7bd2a9 /               ext4    errors=remount-ro 0       1
# /boot/efi was on /dev/sda1 during installation
UUID=52A9-7D84  /boot/efi       vfat    umask=0077      0       1
# /data was on /dev/sda4 during installation
UUID=9edc38e1-2d13-4edb-aa7d-4fba6b29a70f /data           ext4    defaults        0       2
# /home was on /dev/sdb1 during installation
UUID=b1d9bee5-a039-483a-9a3b-e79dec4cf835 /home           ext4    defaults        0       2
# swap was on /dev/sda3 during installation
UUID=5d921ce7-40ee-4c15-9309-c743830c8662 none            swap    sw              0       0

As for sizes my / partition is 20GB /data is 200+GB and /home is about 2TB and all 3 are ext4 so hopefully no problem there.

Hi g000h, I have tried various proton versions up to and including 4.2-2 installed through the tools library and certain games won't work on any version at all from my /home partition on the big HDD yet will on any version of proton from the / or /data partitions of the SDD.

For example DOOM (2016), DOOM 3 BFG, Alien Rage, Borderlands, Thief, Bioshock remastered and Infested planet which is unusual in that it is a much smaller game than all the rest. Also some games with native Linux versions that I've tried running under proton instead have the same trouble, namely Dying Light, Dead Island and Dead Island definitive edition. Like I said though plenty of other native and proton games work quite happily no matter where they are installed which is really quite puzzling.

I'm running Xubuntu 18.10 and Nvidia driver 418.56 but even tried Ubuntu and Xubuntu both 18.04 and 18.10 and also a couple versions of mint but all give me the same problem. I also tried Nvidia versions from 390.something up to 418.56 all the same issue.

Really don't understand it.

damarrin 4 Apr, 2019

I think it may have something to do with the location of there a given version of Proton is installed versus where the game is installed.

I have two Steam libraries where I install games (one in my home, the other in /opt for other people on the machine, both on the same drive) and while all native games were starting just fine, I noticed some Proton games would randomly stop starting (for me and/or other users on the system), in other words a problem similar to yours.

I thought it was due to permissions of the /opt folder, but then I noticed I had Proton installed in both Steam libraries and removing from one would make the game start (and almost always break it for another user). So it may be that, Valve have probably not taken multiple game libraries into account (yet?) with Proton and it's causing problems.

adamhm 13 Apr, 2019

If you're still having problems you could try running them via SteamPlay Menu. The download link can be found here (bottom of the post). My script doesn't care much about where Proton is installed, or where the game is installed as long as it can find them.

Extract the archive somewhere then simply run If you know the AppID for the game you can specify that with appid=<appid>, otherwise it'll allow you to search through (or list all of) the games that are installed via SteamPlay. It should automatically identify and locate the Proton version it's supposed to use for the selected game and it will print this information to the terminal.

I'd recommend running the script with no options first (besides appid=) to make sure that it's detecting everything correctly. Then try starting the game with:

./ appid=<appid> desktop=d runwine : <command>

This will try to run the game with a virtual desktop forced by the start script (remove desktop=d to run it without forcing a virtual desktop). If it doesn't work then check the terminal for any error messages - you might also want to run it again with WINEDEBUG="" set.

By default it'll run the command in the game's install directory, but if the game doesn't normally use its root directory as its working directory you can specify that with cd=<path>, where <path> is either an absolute path or a path relative to the game's root directory. If you're unsure about the game's launch options you can find out the details about them by using the view app info option from the script's menu - launch options are detailed under appinfo/config/launch

If the game freezes you can terminate it using the command:

./ appid=<appid> kill

Read the release notes for more information on how to use it - it works much the same as my GOG wrappers :)

While you're here, please consider supporting GamingOnLinux on:

Patreon, Liberapay or PayPal Donation.

We have no adverts, no paywalls, no timed exclusive articles. Just good, fresh content. Without your continued support, we simply could not continue!

You can find even more ways to support us on this dedicated page any time. If you already are, thank you!
Login / Register

Or login with...
Sign in with Steam Sign in with Twitter Sign in with Google
Social logins require cookies to stay logged in.