Check out our Monthly Survey Page to see what our users are running.
Seems like Nvidia Driver is not perfect installed (glitches in Prey)
Page: «2/3»
  Go to:
Spirimint 12 Oct, 2020
Hey no worries about late answer :)

/usr/share/vulkan/icd.d/nvidia_icd.json looks like

 {
    "file_format_version" : "1.0.0",
    "ICD": {
        "library_path": "libGLX_nvidia.so.0",
        "api_version" : "1.2.133"
    }
}


in the other Forum they suggest to use "prime-run %command%" in Steam LAUNCH OPTIONS, but its not working.

Last edited by Spirimint on 12 October 2020 at 6:51 pm UTC
Redface 13 Oct, 2020
Is this the other thread https://ubuntuforums.org/showthread.php?t=2451397 ?

It seems you have a problem with vulkan while using the Nvidia GPU, but OpenGL works for it, and with Intel you can use both OpenGL and Vulkan.

I would focus on running either performance mode with only Nvidia for now while gathering more info, and then poersave for only Intel until the problem is solved. then you at least are sure which GPU actually is used.

While in performance mode run

 
vulkaninfo


If you do not have the command install vulkan-tools

Does that gives pages after pages off output? It does that when Vulkan works at least.

If you only get some couple of lines please put them all here, if its a very long output then use a paste site, like https://paste.ubuntu.com/ and post the link here.

If it errors out after a few lines then try

 
sudo vulkaninfo


If that works then its maybe because of https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-390/+bug/1769857

That was a bug my laptop was hit with a while ago, but that has been fixed a long time and at least since 20.04 is out. For my laptop at least.

A workaround was to either not use gdm3 or not set nvidia-drm.modeset=1

To check if its set run

 sudo cat /sys/module/nvidia_drm/parameters/modeset

If it says N then its not set, with Y it is set.

My laptop needs it to not have tearing on the laptop screen so I went with lightdm, until I noticed the bug was gone with gdm3
Spirimint 13 Oct, 2020
Yes this is the thread. And its really confusing me:D You say i should use performance mode (which makes sense to me) and in the forum they are telling me the opposite :D

vulkaninfo:

https://paste.ubuntu.com/p/bfB9YsMfR4/
sudo cat /sys/module/nvidia_drm/parameters/modeset
N



How can i change it to yes?

Last edited by Spirimint on 13 October 2020 at 6:30 pm UTC
Redface 13 Oct, 2020
My idea with performance mode now is to simplify things to be sure Nvidia is used.

And your vulkaninfo does say

driverID = DRIVER_ID_NVIDIA_PROPRIETARY
driverName = NVIDIA
driverInfo = 450.80.02

and has thousands of features and no error, so I am running out of ideas.

To set modeset but that is , I believe, only to not get tearing from the laptop inbuilt screen, so if you do not have a problem with that you could leave it, else see http://ubuntuhandbook.org/index.php/2018/07/fix-screen-tearing-ubuntu-18-04-optimus-laptops/

Did you try vkcube and a vulkan game after getting that vulkaninfo output?

And start them from a terminal to see if there are errors in the terminal after.

And collect your Xorg log from cat /var/log/Xorg.0.log and upload that too to https://paste.ubuntu.com unless they suddenly work.
Spirimint 13 Oct, 2020
vkcube gives mit in performance mode just a black window after the vulkaninfo output . Only works in demand mode.

So far i have no tearing probs so i guess i can leave it like it is.

cat /var/log/Xorg.0.log:

https://paste.ubuntu.com/p/VQhSbhPMXH/
Redface 13 Oct, 2020
I do not see anything wrong in your xorg log, except at the end with that sddm error, but you do have a working desktop right? Btw sddm is the login manager for KDE where you login and then start the destop from.

But look what I found: https://insider.razer.com/index.php?threads/new-2020-stealth-linux-support.57151/#post-612849

Try what that user did to get the laptop you have working under Ubuntu with i915.modeset=0
and skip the autologin part for gdm, the gnome login manager since you use sddm
Spirimint 13 Oct, 2020
Ok i'm scared to break something so i hope its ok to ask if its correct like i would try it:

" boot the system, and in the grub menu press "e" again and add "i915.modeset=0" to the line that starts with "linux" and has the "quiet splash" parameters. "

in this line i have

linux /boot/vmlinux-5.8.14-xanmod1 root=UUID=595fd6b6-3c11-46a7-9d57-0711ade485c6 ro quiet splash srt_handoff

now the want include "i915.modeset=0"

like this ?

linux /boot/vmlinux-5.8.14-xanmod1 i915.modeset=0 root=UUID=595fd6b6-3c11-46a7-9d57-0711ade485c6 ro quiet splash srt_handoff?
Redface 14 Oct, 2020
I am not sure how much the ordering matters, but when you press e in the grub menu the changes are only active for that boot, they do not get saved.

When you look at their point 4 for the permanent changes they suggest to put i915.modeset=0 at the end.

So try that too when you test it with 'e'
Spirimint 14 Oct, 2020
Ok so i tried to put in i915.modeset=0, but then the laptopn won't boot at all. :D


So i guess i need to live with it.
Redface 14 Oct, 2020
I would not give up, but you could ask on that razor forum where others have Ubuntu 20.04 running with your model.

Also have you tried it with the default kernel from20.04 instead of vmlinux-5.8.14-xanmod1?
While you're here, please consider supporting GamingOnLinux on:

Patreon, Liberapay or PayPal Donation.

This ensures all of our main content remains totally free for everyone with no article paywalls. We also don't have tons of adverts, there's also no tracking and we respect your privacy. Just good, fresh content. Without your continued support, we simply could not continue!

You can find even more ways to support us on this dedicated page any time. If you already are, thank you!
Login / Register

Or login with...
Sign in with Steam Sign in with Twitter Sign in with Google
Social logins require cookies to stay logged in.