Check out our Monthly Survey Page to see what our users are running.
Weird Flickering in Anno 1800
Hehe-Miss-Boits 28 Nov, 2021
Hi there. It took me a while to get Anno 1800 working on Linux but when I want to play it I get this weird flickering shown here: https://youtu.be/HE2e8R8fozU
I have found this https://steamcommunity.com/app/916440/discussions/1/5717866822610988515 post to which the resolutions seems to be to turn the shadows down but that didn't help me. The game is running using DX11 and I can't switch to DX12 since then the game doesn't start.
Could you please help me getting this to work properly?
metalinux 29 Nov, 2021
I had a look on ProtonDB and there are multiple users reporting graphical issues, so the issue isn't only with your setup. Some of the graphical issues were reported with Proton6.3-6.

One user on Proton6.3-7 had Esync and Fsync disabled. You could try adding this to the game's launch options:
 PROTON_NO_ESYNC=1 PROTON_NO_FSYNC=1 %command%

Otherwise try playing around with the game's resolution and graphic settings. It seems whatever the issue is, it is likely it hasn't been fixed upstream by the WINE team or from Valve themselves as of yet. Hope you get it working.
While you're here, please consider supporting GamingOnLinux on:

Patreon, Liberapay or PayPal Donation.

This ensures all of our main content remains totally free for everyone with no article paywalls. We also don't have tons of adverts, there's also no tracking and we respect your privacy. Just good, fresh content. Without your continued support, we simply could not continue!

You can find even more ways to support us on this dedicated page any time. If you already are, thank you!
Login / Register

Or login with...
Sign in with Steam Sign in with Twitter Sign in with Google
Social logins require cookies to stay logged in.

Livestreams & Videos
Community Livestreams