You can sign up to get a daily email of our articles, see the Mailing List page.
[SOLVED] Proton fails to run games
Page: 1/2»
  Go to:
mindbound Jun 28, 2023
After not running Steam for a while (around 2 weeks), I'm finding that I can't run Windows games through Proton any more (all my native ones run fine). My Arch system is up to date (yay -Syu). I'm normally using but the same issue remains after switching to a different Proton version (I've tried Experimental, 7.0, and 5.13).

Details (from inxi -F):

  Info: 8-core model: AMD Ryzen 7 4800H with Radeon Graphics bits: 64
  Device-1: NVIDIA TU117M [GeForce GTX 1650 Ti Mobile] driver: nvidia
    v: 535.54.03
  Device-2: AMD Renoir driver: amdgpu v: kernel

Using prime-run glxinfo, I'm getting the correct renderer string:

OpenGL renderer string: NVIDIA GeForce GTX 1650 Ti/PCIe/SSE2

Everything outside Proton seems to be running fine. Reinstalling proton-ge-custom-bin doesn't help, neither does cleaning Steam's shader cache. The command I'm running my games in Steam is just prime-run %command% and has worked correctly before.

This is a typical log file (obtained by appending PROTON_LOG=1 to launch options) from Neon Abyss, I'm getting very similar output from all my Proton-launched games:, where in all cases the logs contain lines similar to these:

11812.754:00cc:00d0:err:winediag:nodrv_CreateWindow Application tried to create a window, but no driver could be loaded.
11812.754:00cc:00d0:err:winediag:nodrv_CreateWindow L"Make sure that your X server is running and that $DISPLAY is set correctly."

Please advise.

Last edited by mindbound on 19 July 2023 at 8:37 pm UTC
This topic has an answer marked - jump to answer.
g000h Jun 28, 2023
Might be linked to issues between Nvidia graphics and the Wayland compositor. You could switch to X (compositor) and see if that helps. Noting that Steam client had a pretty big change recently, and that messed up font sizes for me (which I needed to resolve with a new desktop shortcut).
mindbound Jun 28, 2023
I am only using X11.

$DISPLAY is also what you might expect, :0.0

Unlike in, rebuilding the shader cache has no effect.

Last edited by mindbound on 28 June 2023 at 12:42 pm UTC
g000h Jun 28, 2023
Not a perfect solution, but I'm suggesting it as a possible way forwards:

Whenever I set up a PC with Linux, I mostly use LVM to structure the drive volumes, and I tend to leave a reasonable block of unused space (e.g. 40GB). As such, it is easy for me to add a second bootable system onto the same drive. For instance, one could have an Arch and a Debian dual-bootable system. (Or even 2 copies of Arch)

With the same thought in mind, I tend to set up a separate "home" volume, which can be shared by each bootable option.
Ehvis Jun 28, 2023
Since the nvidia driver you're running is less than two weeks old, this would be the thing to investigate. Maybe it has an issue or maybe there is a compatibility issue other components on your system. I suggest rolling it back to a previous version.
whizse Jun 28, 2023
As I understand it, Steam needs to copy things like drivers and utilities like prime-run into the container for them to work. I'm guessing after an upgrade either the nvidia driver or prime-run needs a library not in the runtime.


- Launching Steam from a terminal and read the output. It is usually quite verbose about missing libraries.

- Launching the game without prime-run. Either just using the the other GPU, or setting DRI_PRIME and lauching from a terminal. Or using PrefersNonDefaultGPU from the .desktop shortcut.
mindbound Jun 28, 2023
Unfortunately, I'm not able to launch a game when I switch to the integrated GPU (i.e., without prime-run) and/or a different Proton version as well.

When running Steam from the command line and using Proton-GE, I'm getting a lot of GStreamer warnings:

(wine:371618): GStreamer-WARNING **: 23:05:34.330: Failed to load plugin '/usr/share/steam/compatibilitytools.d/proton-ge-custom/files/lib64/gstreamer-1.0/': /usr/share/steam/compatibilitytools.d/proton-ge-custom/files/lib64/gstreamer-1.0/ wrong ELF class: ELFCLASS64

(wine:371618): GStreamer-WARNING **: 23:05:34.330: Failed to load plugin '/usr/share/steam/compatibilitytools.d/proton-ge-custom/files/lib64/gstreamer-1.0/': /usr/share/steam/compatibilitytools.d/proton-ge-custom/files/lib64/gstreamer-1.0/ wrong ELF class: ELFCLASS64

(wine:371618): GStreamer-WARNING **: 23:05:34.330: Failed to load plugin '/usr/share/steam/compatibilitytools.d/proton-ge-custom/files/lib64/gstreamer-1.0/': /usr/share/steam/compatibilitytools.d/proton-ge-custom/files/lib64/gstreamer-1.0/ wrong ELF class: ELFCLASS64

(wine:371618): GStreamer-WARNING **: 23:05:34.330: Failed to load plugin '/usr/share/steam/compatibilitytools.d/proton-ge-custom/files/lib64/gstreamer-1.0/': /usr/share/steam/compatibilitytools.d/proton-ge-custom/files/lib64/gstreamer-1.0/ wrong ELF class: ELFCLASS64

(wine:371618): GStreamer-WARNING **: 23:05:34.330: Failed to load plugin '/usr/share/steam/compatibilitytools.d/proton-ge-custom/files/lib64/gstreamer-1.0/': /usr/share/steam/compatibilitytools.d/proton-ge-custom/files/lib64/gstreamer-1.0/ wrong ELF class: ELFCLASS64

(wine:371618): GStreamer-WARNING **: 23:05:34.330: Failed to load plugin '/usr/share/steam/compatibilitytools.d/proton-ge-custom/files/lib64/gstreamer-1.0/': /usr/share/steam/compatibilitytools.d/proton-ge-custom/files/lib64/gstreamer-1.0/ wrong ELF class: ELFCLASS64


and the following message upon crashing:

Game process updated : AppID 788100 "/home/mindbound/.local/share/Steam/ubuntu12_32/reaper SteamLaunch AppId=788100 -- /home/mindbound/.local/share/Steam/ubuntu12_32/steam-launch-wrapper -- '/mnt/lud/SteamLibrary/steamapps/common/SteamLinuxRuntime_sniper'/_v2-entry-point --verb=waitforexitandrun -- '/usr/share/steam/compatibilitytools.d/proton-ge-custom'/proton waitforexitandrun  '/mnt/lud/SteamLibrary/steamapps/common/Neon Abyss/NeonAbyss.exe'", ProcID 371545, IP
Setting breakpad minidump AppID = 788100
Steam_SetMinidumpSteamID:  Caching Steam ID:  76561198001841821 [API loaded no]

(steam:370552): GLib-GObject-CRITICAL **: 23:05:36.331: g_object_ref: assertion 'G_IS_OBJECT (object)' failed

(steam:370552): GLib-GObject-CRITICAL **: 23:05:36.331: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
Mono path[0] = 'Z:/mnt/lud/SteamLibrary/steamapps/common/Neon Abyss/NeonAbyss_Data/Managed'
Mono config path = 'Z:/mnt/lud/SteamLibrary/steamapps/common/Neon Abyss/MonoBleedingEdge/etc'
pid 371547 != 371546, skipping destruction (fork without exec?)
ThreadGetProcessExitCode: no such process 371634
ThreadGetProcessExitCode: no such process 371621
ThreadGetProcessExitCode: no such process 371600
ThreadGetProcessExitCode: no such process 371585
ThreadGetProcessExitCode: no such process 371579
ThreadGetProcessExitCode: no such process 371564
ThreadGetProcessExitCode: no such process 371554
ThreadGetProcessExitCode: no such process 371551
ThreadGetProcessExitCode: no such process 371542
ThreadGetProcessExitCode: no such process 371403
Game process removed: AppID 788100 "/home/mindbound/.local/share/Steam/ubuntu12_32/reaper SteamLaunch AppId=788100 -- /home/mindbound/.local/share/Steam/ubuntu12_32/steam-launch-wrapper -- '/mnt/lud/SteamLibrary/steamapps/common/SteamLinuxRuntime_sniper'/_v2-entry-point --verb=waitforexitandrun -- '/usr/share/steam/compatibilitytools.d/proton-ge-custom'/proton waitforexitandrun  '/mnt/lud/SteamLibrary/steamapps/common/Neon Abyss/NeonAbyss.exe'", ProcID 371545 
ThreadGetProcessExitCode: no such process 371545

When using Proton 7.0-6, I'm getting the following:

Spoiler, click me
fsync: up and running.
wine: Using setpriority to control niceness in the [-11,11] range
ThreadGetProcessExitCode: no such process 371998
ThreadGetProcessExitCode: no such process 371996
ThreadGetProcessExitCode: no such process 371995
ThreadGetProcessExitCode: no such process 371994
ThreadGetProcessExitCode: no such process 371879
wine: Unhandled page fault on execute access to 00007F54507E2430 at address 00007F54507E2430 (thread 00cc), starting debugger...
Unhandled exception: page fault on execute access to 0x00007f54507e2430 in 64-bit code (0x00007f54507e2430).
Register dump:
 rip:00007f54507e2430 rsp:000000000021dec8 rbp:000000000021dfe0 eflags:00010246 (  R- --  I  Z- -P- )
 rax:00007f54507e2430 rbx:0000000000000000 rcx:000000007db55780 rdx:0000000000000000
 rsi:00007f54511243e0 rdi:0000000000000003  r8:0000000000000000  r9:0000000000000000 r10:0000000000000003
 r11:0000000000000000 r12:000000007db55750 r13:0000000000000000 r14:0000000000510050 r15:0000000001010038
Stack dump:
0x000000000021dec8:  00007f5451062f3b 0000000001010038
0x000000000021ded8:  00000003af6a4d61 000000007d9f99a0
0x000000000021dee8:  00000003af6a4d61 000000026b50d000
0x000000000021def8:  0000000001010038 0000000000000000
0x000000000021df08:  0000000000000000 0000000000000000
0x000000000021df18:  0000000000000000 0000000000000000
0x000000000021df28:  0000000000000000 0000000000000000
0x000000000021df38:  0000000000000000 0000000000000000
0x000000000021df48:  0000000000000000 0000000000000000
0x000000000021df58:  0000000000000000 0000000000000000
0x000000000021df68:  0000000000000000 0000000000000000
0x000000000021df78:  0000000000000000 0000000000000000
=>0 0x00007f54507e2430 (0x000000000021dfe0)
0x00007f54507e2430: -- no code accessible --
Module Address Debug info Name (15 modules)
PE 000000007b000000-000000007b0da000 Deferred        kernelbase
PE 000000007b600000-000000007b814000 Deferred        kernel32
PE 0000000140000000-0000000140020000 Deferred        explorer
PE 0000000170000000-00000001700a1000 Deferred        ntdll
PE 00000001c8db0000-00000001c8e47000 Deferred        msvcrt
PE 000000021a7e0000-000000021a855000 Deferred        setupapi
PE 0000000231ae0000-0000000231b62000 Deferred        rpcrt4
PE 000000023d820000-000000023da6e000 Deferred        user32
PE 000000026b4c0000-000000026b53a000 Deferred        gdi32
PE 00000002f1fa0000-00000002f1fae000 Deferred        version
PE 000000032a700000-000000032a72a000 Deferred        sechost
PE 0000000330260000-00000003302a0000 Deferred        advapi32
PE 0000000375610000-0000000375648000 Deferred        win32u
PE 00000003af670000-00000003af730000 Deferred        ucrtbase
PE 00000003afd00000-00000003afd1a000 Deferred        imm32
process  tid      prio (all id:s are in hex)
00000024    0
00000028 wineboot.exe
0000002c    0
00000030 services.exe
00000034    0
00000038    0
00000044    0
00000048    0
00000054    0
00000068    0
00000074    0
00000098    0
000000b0    0
0000003c winedevice.exe
00000040    0
0000004c    0
00000050    0
00000058    0
0000005c    0
000000bc    0
00000060 winedevice.exe
00000064    0
0000006c    0
00000070    0
00000078    0
0000007c    0
00000080    0
00000084    0
0000008c    0
00000090 plugplay.exe
00000094    0
0000009c    0
000000a0    0
000000a4    0
000000a8 svchost.exe
000000ac    0
000000b4    0
000000b8    0
000000c0 rundll32.exe
000000c4    0
000000c8 (D) C:\windows\system32\explorer.exe
000000cc    0 <==
000000d8    0
System information:
    Wine build: wine-7.0
    Platform: x86_64
    Version: Windows 10
    Host system: Linux
    Host version: 6.3.9-arch1-1
ThreadGetProcessExitCode: no such process 372043
ThreadGetProcessExitCode: no such process 372090
ThreadGetProcessExitCode: no such process 372060
wine: configuration in L"/mnt/lud/SteamLibrary/steamapps/compatdata/788100/pfx" has been updated.
ThreadGetProcessExitCode: no such process 372098
ThreadGetProcessExitCode: no such process 372093
ThreadGetProcessExitCode: no such process 372001
Game process updated : AppID 788100 "/home/mindbound/.local/share/Steam/ubuntu12_32/reaper SteamLaunch AppId=788100 -- /home/mindbound/.local/share/Steam/ubuntu12_32/steam-launch-wrapper -- '/mnt/lud/SteamLibrary/steamapps/common/SteamLinuxRuntime_soldier'/_v2-entry-point --verb=waitforexitandrun -- '/mnt/lud/SteamLibrary/steamapps/common/Proton 7.0'/proton waitforexitandrun  '/mnt/lud/SteamLibrary/steamapps/common/Neon Abyss/NeonAbyss.exe'", ProcID 371997, IP
Setting breakpad minidump AppID = 788100
Steam_SetMinidumpSteamID:  Caching Steam ID:  76561198001841821 [API loaded no]
wine: Unhandled page fault on execute access to 00007F04508A3430 at address 00007F04508A3430 (thread 0114), starting debugger...
wine: Unhandled page fault on execute access to 00007FA585C52380 at address 00007FA585C52380 (thread 011c), starting debugger...
Mono path[0] = 'Z:/mnt/lud/SteamLibrary/steamapps/common/Neon Abyss/NeonAbyss_Data/Managed'
Mono config path = 'Z:/mnt/lud/SteamLibrary/steamapps/common/Neon Abyss/MonoBleedingEdge/etc'
ThreadGetProcessExitCode: no such process 372113
ThreadGetProcessExitCode: no such process 372100
ThreadGetProcessExitCode: no such process 372037
ThreadGetProcessExitCode: no such process 372031
ThreadGetProcessExitCode: no such process 372006
ThreadGetProcessExitCode: no such process 372003
ThreadGetProcessExitCode: no such process 371993
pid 371999 != 371998, skipping destruction (fork without exec?)
Game process removed: AppID 788100 "/home/mindbound/.local/share/Steam/ubuntu12_32/reaper SteamLaunch AppId=788100 -- /home/mindbound/.local/share/Steam/ubuntu12_32/steam-launch-wrapper -- '/mnt/lud/SteamLibrary/steamapps/common/SteamLinuxRuntime_soldier'/_v2-entry-point --verb=waitforexitandrun -- '/mnt/lud/SteamLibrary/steamapps/common/Proton 7.0'/proton waitforexitandrun  '/mnt/lud/SteamLibrary/steamapps/common/Neon Abyss/NeonAbyss.exe'", ProcID 371997 
ThreadGetProcessExitCode: no such process 372015
ThreadGetProcessExitCode: no such process 371997
ThreadGetProcessExitCode: no such process 371878

Last edited by mindbound on 28 June 2023 at 8:27 pm UTC
whizse Jun 28, 2023
More straw grasping: Try skimming the Runtime System Information for errors or missing libraries? Help -> System Runtime System Information.

Also, you mentioned glxinfo, but have you also double checked that Vulkan is in fact working outside of Steam?
mindbound Jun 28, 2023
Well, vulkaninfo returns seemingly normal results for both GPUs:

Steam's Help -> System Information reports only the integrated card but that's likely because Steam itself isn't launched via prime-run and the native games all start normally, so that's likely not a problem.

Help -> Steam Runtime Diagnostics returns the following, at the first glance seems normal to me but I could be missing something:

Last edited by mindbound on 28 June 2023 at 10:33 pm UTC
whizse Jun 28, 2023
Quoting: mindbound
Not working for some reason.
mindbound Jun 28, 2023
Weird. Re-pasted.
While you're here, please consider supporting GamingOnLinux on:

Reward Tiers: Patreon. Plain Donations: PayPal.

This ensures all of our main content remains totally free for everyone! Patreon supporters can also remove all adverts and sponsors! Supporting us helps bring good, fresh content. Without your continued support, we simply could not continue!

You can find even more ways to support us on this dedicated page any time. If you already are, thank you!
Login / Register

Or login with...
Sign in with Steam Sign in with Google
Social logins require cookies to stay logged in.