Don't want to see articles from a certain category? When logged in, go to your User Settings and adjust your feed in the Content Preferences section where you can block tags!
Road Rash (1994) on Linux?
sobinsiril Nov 18, 2023
Anyone here have any luck with Road Rash on Linux throgh WINE? I tried it but can't fullscreen it (this might be a wayland issue but I'm not sure).

Other than that, input is extremely laggy in the menus, gameplay and MIDI audio is fine though.

Thanks in advance :)
This topic has an answer marked - jump to answer.
redman Nov 18, 2023
Have you checked the options they say here:
It has silver 🥈
whizse Nov 18, 2023
Quoting: sobinsirilOther than that, input is extremely laggy in the menus
This seems to be a problem with the game running on multi-CPU systems (i.e. anything even remotely modern). Forcing the game to use a single CPU gives you a working menu. I used something like this:

taskset -c 0 wine RoadRash.exe

I didn't have any fullscreen issues in X11, so it might be related to Wayland, or the specific compositor you are using. gamescope is a pretty good workaround for these issues.

(FWIW I also had to configure a virtual CD-ROM with winecfg or the game refused to start!)

Tested with Wine 8.20.

Last edited by whizse on 18 November 2023 at 9:47 pm UTC
sobinsiril Nov 19, 2023
Quoting: redmanHave you checked the options they say here
The Registry Tweaks and NO-CD Patches were applied so no issues on that end.

Quoting: whizsegamescope is a pretty good workaround for these issues.
Using gamescope solved the resolution issue. Here's what I did,

gamescope -w 640 -h 480 -W 1920 -H 1080 -f wine ROADRASH.exe

Taskset didn't fix the menu lag though.
whizse Nov 19, 2023
Quoting: sobinsirilTaskset didn't fix the menu lag though.
Odd. Guess I had a different issue with the menu.

You might want to try turning csmt off. It sometimes causes problems with really old titles. Instructions here:
sobinsiril Nov 21, 2023
Quoting: whizseYou might want to try turning csmt off.
Sadly that didn't fix it either.

Actually I should've been more specific about the problem. There is no "lag" but after selecting an option in the game menu, the screen doesn't change. It only redraws after the next keypress (any key works). Unfortunately I don't know anything about wine debugging so I'm temporarily admitting defeat. It might just be a Wayland thing after all.
sobinsiril Dec 1, 2023
I have resolved all the issues I had using a Combination of Wine Wayland Driver and CnC-ddraw. No more dependency on gamescope. That said a minor annoyance still exists which causes FMVs to spawn new windows but I disabled the videos for now.

Here's everything I did,

1. Create the registry key HKEY_CURRENT_USER\Software\Wine\Drivers\Graphics="x11,wayland"
2. Unset the DISPLAY env. variable, i.e, DISPLAY= wine ROADRASH.exe to force the use of the Wayland driver
3. Downloaded CnC-ddraw and copied ddraw.ini and ddraw.dll to the game directory.
4. Edited ddraw.ini by setting
maintas=true and fixchilds=0
5. Profit

Source for the registry tip.
While you're here, please consider supporting GamingOnLinux on:

Reward Tiers: Patreon. Plain Donations: PayPal.

This ensures all of our main content remains totally free for everyone! Patreon supporters can also remove all adverts and sponsors! Supporting us helps bring good, fresh content. Without your continued support, we simply could not continue!

You can find even more ways to support us on this dedicated page any time. If you already are, thank you!
Login / Register

Or login with...
Sign in with Steam Sign in with Google
Social logins require cookies to stay logged in.