Check out our Monthly Survey Page to see what our users are running.
Many Steam games will stuck at fullscreen
MaximB Jun 15
I've recently reinstalled Linux Mint 21.3 (kept my home folder) and installed Steam via the steam .deb from Steam website.
Some Steam proton games run fine,
But others have a very strange issue - when I run them via Steam proton, they stuck at fullcreen, however when I do alt+tab (and after a minute it tabs to desktop), I can see the game resumes it's run on desktop thumbnails and appears to run fine.
When I alt+tab to the game again - it sucks again.

I even upgraded the Nvidia drivers to 550...but it didn't help.
And changed several proton versions, still same issue.

Those games used to run fine before the OS reinstall.

Last edited by MaximB on 15 June 2024 at 5:37 pm UTC
Pengling Jun 16
That sounds irritating! Just a quick thought: Did you install Steam in the same way on your previous install, or did you use steam-installer from the Mint repos instead last time?
MaximB Jun 16
I think I've installed it the same way, from Steam website.
MaximB Jun 16

  Kernel: 5.15.0-112-generic x86_64 bits: 64 compiler: gcc v: 11.4.0 Desktop: Cinnamon 6.0.4
    tk: GTK 3.24.33 wm: muffin vt: 7 dm: LightDM 1.30.0 Distro: Linux Mint 21.3 Virginia
    base: Ubuntu 22.04 jammy
  Type: Desktop Mobo: ASUSTeK model: ROG CROSSHAIR VIII HERO (WI-FI) v: Rev X.0x
    serial: <superuser required> UEFI: American Megatrends v: 0901 date: 08/27/2019
  Device-1: hidpp_battery_0 model: Logitech Wireless Keyboard serial: <filter>
    charge: 50% (should be ignored) rechargeable: yes status: N/A
  Device-2: hidpp_battery_1 model: Logitech Wireless Mouse serial: <filter>
    charge: 55% (should be ignored) rechargeable: yes status: Discharging
  Info: 12-core model: AMD Ryzen 9 3900X bits: 64 type: MT MCP smt: enabled arch: Zen 2 rev: 0
    cache: L1: 768 KiB L2: 6 MiB L3: 64 MiB
  Speed (MHz): avg: 2373 high: 4311 min/max: 2200/3800 boost: enabled cores: 1: 3722 2: 2030
    3: 2011 4: 2194 5: 2191 6: 2197 7: 2193 8: 2196 9: 2195 10: 2193 11: 2195 12: 2196 13: 4311
    14: 2003 15: 2030 16: 2196 17: 2195 18: 2193 19: 3670 20: 2075 21: 2195 22: 2196 23: 2196
    24: 2195 bogomips: 182066
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Device-1: NVIDIA TU102 [GeForce RTX 2080 Ti Rev. A] vendor: ASUSTeK driver: nvidia v: 550.67
    pcie: speed: 8 GT/s lanes: 8 ports: active: none off: HDMI-A-1 empty: DP-1,DP-2,Unknown-1
    bus-ID: 0a:00.0 chip-ID: 10de:1e07 class-ID: 0300
  Display: x11 server: X.Org v: driver: X: loaded: nvidia
    unloaded: fbdev,modesetting,nouveau,vesa gpu: nvidia display-ID: :0 screens: 1
  Screen-1: 0 s-res: 3840x2160 s-dpi: 58 s-size: 1682x946mm (66.2x37.2") s-diag: 1930mm (76")
  Monitor-1: HDMI-0 res: 3840x2160 dpi: 59 size: 1660x930mm (65.4x36.6") diag: 1903mm (74.9")
  OpenGL: renderer: NVIDIA GeForce RTX 2080 Ti/PCIe/SSE2 v: 4.6.0 NVIDIA 550.67
    direct render: Yes
  Device-1: NVIDIA TU102 High Definition Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel
    pcie: speed: 8 GT/s lanes: 8 bus-ID: 0a:00.1 chip-ID: 10de:10f7 class-ID: 0403
  Device-2: AMD Starship/Matisse HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel pcie:
    speed: 16 GT/s lanes: 16 bus-ID: 0c:00.4 chip-ID: 1022:1487 class-ID: 0403
  Sound Server-1: ALSA v: k5.15.0-112-generic running: yes
  Sound Server-2: PulseAudio v: 15.99.1 running: yes
  Sound Server-3: PipeWire v: 0.3.48 running: yes
  Device-1: Realtek RTL8125 2.5GbE vendor: ASUSTeK driver: r8169 v: kernel pcie: speed: 5 GT/s
    lanes: 1 port: e000 bus-ID: 04:00.0 chip-ID: 10ec:8125 class-ID: 0200
  IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-2: Intel I211 Gigabit Network vendor: ASUSTeK driver: igb v: kernel pcie:
    speed: 2.5 GT/s lanes: 1 port: d000 bus-ID: 05:00.0 chip-ID: 8086:1539 class-ID: 0200
  IF: enp5s0 state: down mac: <filter>
  Device-3: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel pcie: speed: 5 GT/s lanes: 1
    bus-ID: 06:00.0 chip-ID: 8086:2723 class-ID: 0280
  IF: wlp6s0 state: down mac: <filter>
  Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 1-6:3 chip-ID: 8087:0029
    class-ID: e001
  Report: hciconfig ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 3.0 lmp-v: 5.2
    sub-v: 237e hci-v: 5.2 rev: 237e
  Local Storage: total: 22.74 TiB used: 20.68 TiB (91.0%)
  ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 970 EVO Plus 2TB size: 1.82 TiB speed: 31.6 Gb/s
    lanes: 4 type: SSD serial: <filter> rev: 2B2QEXM7 temp: 51.9 C scheme: GPT
  ID-2: /dev/sda vendor: Western Digital model: WD60EFAX-68JH4N0 size: 5.46 TiB speed: 6.0 Gb/s
    type: HDD rpm: 5400 serial: <filter> rev: 0A82 scheme: GPT
  ID-3: /dev/sdb type: USB vendor: Seagate model: M3 Portable size: 3.64 TiB speed: <unknown>
    type: N/A serial: <filter> rev: 9300 scheme: GPT
  ID-4: /dev/sdc type: USB vendor: Western Digital model: WD Elements 2620 size: 4.55 TiB
    speed: <unknown> type: N/A serial: <filter> rev: 1023 scheme: GPT
  ID-5: /dev/sdd type: USB vendor: Western Digital model: WD My Passport 25E2 size: 3.64 TiB
    speed: <unknown> type: N/A serial: <filter> rev: 4005 scheme: GPT
  ID-6: /dev/sde type: USB vendor: Western Digital model: WD My Passport 25E2 size: 3.64 TiB
    type: N/A serial: <filter> rev: 4004 scheme: GPT
  ID-1: / size: 45.53 GiB used: 16.74 GiB (36.8%) fs: ext4 dev: /dev/nvme0n1p3
  ID-2: /boot size: 917.7 MiB used: 369.8 MiB (40.3%) fs: ext4 dev: /dev/nvme0n1p5
  ID-3: /boot/efi size: 94.8 MiB used: 6.1 MiB (6.4%) fs: vfat dev: /dev/nvme0n1p2
  ID-4: /home size: 1.74 TiB used: 1.58 TiB (90.6%) fs: ext4 dev: /dev/nvme0n1p4
  ID-1: swap-1 type: file size: 2 GiB used: 0 KiB (0.0%) priority: -2 file: /swapfile
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 6 rev: 2.0 speed: 480 Mb/s
    chip-ID: 1d6b:0002 class-ID: 0900
  Hub-2: 1-5:2 info: Genesys Logic Hub ports: 4 rev: 2.0 speed: 480 Mb/s power: 100mA
    chip-ID: 05e3:0610 class-ID: 0900
  Device-1: 1-5.1:4 info: Corsair H115iRGBPROXT type: Keyboard driver: hid-generic,usbhid
    interfaces: 1 rev: 2.0 speed: 12 Mb/s power: 100mA chip-ID: 1b1c:0c21 class-ID: 0300
  Device-2: 1-5.3:5 info: ASUSTek AURA LED Controller type: HID driver: hid-generic,usbhid
    interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 16mA chip-ID: 0b05:18f3 class-ID: 0300
    serial: <filter>
  Device-3: 1-6:3 info: Intel AX200 Bluetooth type: Bluetooth driver: btusb interfaces: 2
    rev: 2.0 speed: 12 Mb/s power: 100mA chip-ID: 8087:0029 class-ID: e001
  Hub-3: 2-0:1 info: Super-speed hub ports: 4 rev: 3.1 speed: 10 Gb/s chip-ID: 1d6b:0003
    class-ID: 0900
  Device-1: 2-3:2 info: Western Digital My Passport (WD40NMZW) type: Mass Storage
    driver: usb-storage interfaces: 1 rev: 3.1 speed: 5 Gb/s power: 896mA chip-ID: 1058:25e2
    class-ID: 0806 serial: <filter>
  Device-2: 2-4:3 info: Western Digital My Passport (WD40NMZW) type: Mass Storage
    driver: usb-storage interfaces: 1 rev: 3.0 speed: 5 Gb/s power: 896mA chip-ID: 1058:25e2
    class-ID: 0806 serial: <filter>
  Hub-4: 3-0:1 info: Hi-speed hub with single TT ports: 6 rev: 2.0 speed: 480 Mb/s
    chip-ID: 1d6b:0002 class-ID: 0900
  Hub-5: 3-2:2 info: ASMedia ASM1074 High-Speed hub ports: 4 rev: 2.1 speed: 480 Mb/s
    power: 100mA chip-ID: 174c:2074 class-ID: 0900
  Device-1: 3-4:3 info: Logitech Unifying Receiver type: Keyboard,Mouse
    driver: logitech-djreceiver,usbhid interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 98mA
    chip-ID: 046d:c534 class-ID: 0301
  Hub-6: 4-0:1 info: Super-speed hub ports: 4 rev: 3.1 speed: 10 Gb/s chip-ID: 1d6b:0003
    class-ID: 0900
  Hub-7: 4-2:2 info: ASMedia ASM1074 SuperSpeed hub ports: 4 rev: 3.0 speed: 5 Gb/s power: 8mA
    chip-ID: 174c:3074 class-ID: 0900
  Hub-8: 5-0:1 info: Hi-speed hub with single TT ports: 2 rev: 2.0 speed: 480 Mb/s
    chip-ID: 1d6b:0002 class-ID: 0900
  Hub-9: 6-0:1 info: Super-speed hub ports: 4 rev: 3.1 speed: 10 Gb/s chip-ID: 1d6b:0003
    class-ID: 0900
  Hub-10: 7-0:1 info: Hi-speed hub with single TT ports: 4 rev: 2.0 speed: 480 Mb/s
    chip-ID: 1d6b:0002 class-ID: 0900
  Hub-11: 7-2:2 info: Atmel 4-Port Hub ports: 4 rev: 1.1 speed: 12 Mb/s power: 100mA
    chip-ID: 03eb:0902 class-ID: 0900
  Hub-12: 8-0:1 info: Super-speed hub ports: 4 rev: 3.1 speed: 10 Gb/s chip-ID: 1d6b:0003
    class-ID: 0900
  Device-1: 8-3:2 info: Seagate RSS LLC Maxtor M3 Portable type: Mass Storage driver: uas
    interfaces: 1 rev: 3.0 speed: 5 Gb/s power: 144mA chip-ID: 0bc2:61b7 class-ID: 0806
    serial: <filter>
  Device-2: 8-4:3 info: Western Digital Elements 2620 type: Mass Storage driver: usb-storage
    interfaces: 1 rev: 3.2 speed: 5 Gb/s power: 896mA chip-ID: 1058:2620 class-ID: 0806
    serial: <filter>
  System Temperatures: cpu: N/A mobo: N/A gpu: nvidia temp: 46 C
  Fan Speeds (RPM): N/A gpu: nvidia fan: 31%
  Packages: 2407 apt: 2400 flatpak: 7
  No active apt repos in: /etc/apt/sources.list
  Active apt repos in: /etc/apt/sources.list.d/brave-browser-release.list
    1: deb [signed-by=/usr/share/keyrings/brave-browser-archive-keyring.gpg] https: // stable main
  Active apt repos in: /etc/apt/sources.list.d/official-package-repositories.list
    1: deb https: // virginia main upstream import backport
    2: deb http: // jammy main restricted universe multiverse
    3: deb http: // jammy-updates main restricted universe multiverse
    4: deb http: // jammy-backports main restricted universe multiverse
    5: deb http: // jammy-security main restricted universe multiverse
  No active apt repos in: /etc/apt/sources.list.d/steam-beta.list
  Active apt repos in: /etc/apt/sources.list.d/steam-stable.list
    1: deb [arch=amd64,i386 signed-by=/usr/share/keyrings/steam.gpg] https: // stable steam
    2: deb-src [arch=amd64,i386 signed-by=/usr/share/keyrings/steam.gpg] https: // stable steam
  Active apt repos in: /etc/apt/sources.list.d/vscode.list
    1: deb [arch=amd64,arm64,armhf] https: // stable main
  Processes: 496 Uptime: 13h 17m wakeups: 58 Memory: 62.7 GiB used: 6.53 GiB (10.4%) Init: systemd
  v: 249 runlevel: 5 Compilers: gcc: 11.4.0 alt: 11/12 Client: Cinnamon v: 6.0.4 inxi: 3.3.13

Steam (from cli)
maxim@Maxim-HQ:~$ steam[58420]: Running Steam on linuxmint 21.3 64-bit[58420]: STEAM_RUNTIME is enabled automatically[58585]: Steam runtime environment up-to-date![58420]: Steam client's requirements are satisfied
[2024-06-16 09:21:08] Startup - updater built Jun 13 2024 18:39:06
[2024-06-16 09:21:08] Startup - Steam Client launched with: '/home/maxim/.local/share/Steam/ubuntu12_32/steam' '-srt-logger-opened'
06/16 09:21:08 minidumps folder is set to /tmp/dumps
06/16 09:21:08 Init: Installing breakpad exception handler for appid(steam)/version(1718305227)/tid(58656)
[2024-06-16 09:21:08] Loading cached metrics from disk (/home/maxim/.local/share/Steam/package/steam_client_metrics.bin)
[2024-06-16 09:21:08] Using the following download hosts for Public, Realm steamglobal
[2024-06-16 09:21:08] 1., /, Realm 'steamglobal', weight was 1000, source = 'update_hosts_cached.vdf'
[2024-06-16 09:21:08] 2., /client/, Realm 'steamglobal', weight was 1, source = 'update_hosts_cached.vdf'
[2024-06-16 09:21:08] 3., /client/, Realm 'steamglobal', weight was 1, source = 'baked in'
[2024-06-16 09:21:08] Verifying installation...
[2024-06-16 09:21:08] Verification complete
UpdateUI: skip show logo
Steam logging initialized: directory: /home/maxim/.local/share/Steam/logs

XRRGetOutputInfo Workaround: initialized with override: 0 real: 0xf0f71370
XRRGetCrtcInfo Workaround: initialized with override: 0 real: 0xf0f6fcc0
/usr/share/themes/Mint-Y-Orange/gtk-2.0/main.rc:1053: error: unexpected identifier 'direction', expected character '}'
CAppInfoCacheReadFromDiskThread took 279 milliseconds to initialize
Steam Runtime Launch Service: starting steam-runtime-launcher-service
Steam Runtime Launch Service: steam-runtime-launcher-service is running pid 58742
BRefreshApplicationsInLibrary 1: 210ms
BuildCompleteAppOverviewChange: 1447 apps
RegisterForAppOverview 1: 123ms
RegisterForAppOverview 2: 126ms
chdir "/Storage/Games/Steam/steamapps/common/SongsOfConquest"
ERROR: object '/home/maxim/.local/share/Steam/ubuntu12_32/' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
ERROR: object '/home/maxim/.local/share/Steam/ubuntu12_32/' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
Adding process 60401 for gameID 867210
ERROR: object '/home/maxim/.local/share/Steam/ubuntu12_32/' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
Adding process 60402 for gameID 867210
ERROR: object '' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS64): ignored.
ERROR: object '/home/maxim/.local/share/Steam/ubuntu12_64/' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS64): ignored.
ERROR: object '/home/maxim/.local/share/Steam/ubuntu12_32/' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
ERROR: object '/home/maxim/.local/share/Steam/ubuntu12_32/' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
ERROR: object '/home/maxim/.local/share/Steam/ubuntu12_32/' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
Adding process 60409 for gameID 867210
Adding process 60410 for gameID 867210
x86_64-linux-gnu-capsule-capture-libs: warning: Dependencies of not found, ignoring: Missing dependencies: Could not find "" in LD_LIBRARY_PATH "/usr/lib/x86_64-linux-gnu/libfakeroot:/lib/i386-linux-gnu:/usr/local/lib:/lib/x86_64-linux-gnu:/lib:/Storage/Games/Steam/steamapps/common/SongsOfConquest",, DT_RUNPATH or fallback /lib:/usr/lib
ERROR: object '' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
ERROR: object '' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
ERROR: object '' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
Adding process 60514 for gameID 867210
ProtonFixes[60514] INFO: Running protonfixes
ProtonFixes[60514] INFO: Running checks
ProtonFixes[60514] INFO: All checks successful
ProtonFixes[60514] INFO: Using global defaults for "Songs of Conquest" (867210)
ProtonFixes[60514] INFO: No global protonfix found for "Songs of Conquest" (867210)
ERROR: object '' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
ERROR: object '' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
ERROR: object '' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
ERROR: object '' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
ERROR: object '' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
esync: up and running.
Adding process 60515 for gameID 867210
Adding process 60516 for gameID 867210
ERROR: object '' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
ERROR: object '' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
Adding process 60517 for gameID 867210
Adding process 60520 for gameID 867210
ERROR: object '' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
Adding process 60530 for gameID 867210
Adding process 60533 for gameID 867210
ERROR: object '' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
Adding process 60543 for gameID 867210
ERROR: object '' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
Adding process 60556 for gameID 867210
ERROR: object '' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
Adding process 60562 for gameID 867210
ERROR: object '' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
ERROR: object '' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
ERROR: object '' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
Adding process 60575 for gameID 867210
Setting breakpad minidump AppID = 867210
Steam_SetMinidumpSteamID:  Caching Steam ID:  76561198067546150 [API loaded no]
ERROR: object '' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
Adding process 60592 for gameID 867210
ERROR: object '' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
Adding process 60595 for gameID 867210
Fossilize INFO: Overriding serialization path: "/Storage/Games/Steam/steamapps/shadercache/867210/fozpipelinesv6/steamapprun_pipeline_cache".
[2024-06-16 09:23:09] Background update loop checking for update. . .
[2024-06-16 09:23:09] Checking for available updates...
[2024-06-16 09:23:09] Downloading manifest:
[2024-06-16 09:23:09] Manifest download: send request
[2024-06-16 09:23:09] Manifest download: waiting for download to finish
[2024-06-16 09:23:10] Manifest download: finished
[2024-06-16 09:23:10] Download skipped: /steam_client_ubuntu12?t=886800768 version 1718305227, installed version 1718305227, existing pending version 0
[2024-06-16 09:23:10] Nothing to do
pid 60518 != 60517, skipping destruction (fork without exec?)
Game 867210 created interface STEAMAPPLIST_INTERFACE_VERSION001 / AppList
Game 867210 created interface STEAMAPPS_INTERFACE_VERSION008 / Apps
Game 867210 created interface STEAMHTMLSURFACE_INTERFACE_VERSION_005 / HTMLSurface
Game 867210 created interface STEAMHTTP_INTERFACE_VERSION003 / HTTP
Game 867210 created interface STEAMINVENTORY_INTERFACE_V003 / Inventory
Game 867210 created interface STEAMMUSICREMOTE_INTERFACE_VERSION001 / MusicRemote
Game 867210 created interface STEAMMUSIC_INTERFACE_VERSION001 / Music
Game 867210 created interface STEAMPARENTALSETTINGS_INTERFACE_VERSION001 / ParentalSettings
Game 867210 created interface STEAMREMOTEPLAY_INTERFACE_VERSION001 / RemotePlay
Game 867210 created interface STEAMREMOTESTORAGE_INTERFACE_VERSION016 / RemoteStorage
Game 867210 created interface STEAMSCREENSHOTS_INTERFACE_VERSION003 / Screenshots
Game 867210 created interface STEAMUGC_INTERFACE_VERSION017 / UGC
Game 867210 created interface STEAMUSERSTATS_INTERFACE_VERSION012 / UserStats
Game 867210 created interface STEAMVIDEO_INTERFACE_V002 / Video
Game 867210 created interface SteamController008 / 
Game 867210 created interface SteamFriends017 / Friends
Game 867210 created interface SteamInput006 / 
Game 867210 created interface SteamInput006 / Controller
Game 867210 created interface SteamMatchGameSearch001 / GameSearch
Game 867210 created interface SteamMatchMaking009 / Matchmaking
Game 867210 created interface SteamMatchMakingServers002 / MatchmakingServers
Game 867210 created interface SteamNetworking006 / Networking
Game 867210 created interface SteamNetworkingMessages002 / 
Game 867210 created interface SteamNetworkingSockets012 / 
Game 867210 created interface SteamNetworkingUtils004 / 
Game 867210 created interface SteamParties002 / Parties
Game 867210 created interface SteamUser023 / User
Game 867210 created interface SteamUtils010 / 
Game 867210 created interface SteamUtils010 / Utils
Game 867210 method call count for IClientNetworkingUtilsSerialized::GotLocationString : 2
Game 867210 method call count for IClientNetworkingSocketsSerialized::GetSTUNServer : 2
Game 867210 method call count for IClientNetworkingSocketsSerialized::GetCachedRelayTicketCount : 1
Game 867210 method call count for IClientNetworkingSocketsSerialized::GetCertAsync : 1
Game 867210 method call count for IClientHTTP::ReleaseHTTPRequest : 2
Game 867210 method call count for IClientHTTP::GetHTTPResponseBodyData : 2
Game 867210 method call count for IClientHTTP::SendHTTPRequest : 2
Game 867210 method call count for IClientHTTP::SetHTTPRequestHeaderValue : 1
Game 867210 method call count for IClientHTTP::CreateHTTPRequest : 2
Game 867210 method call count for IClientUserStats::GetAchievement : 54
Game 867210 method call count for IClientUserStats::GetStat : 14
Game 867210 method call count for IClientUserStats::RequestCurrentStats : 1
Game 867210 method call count for IClientUserStats::GetAchievementName : 54
Game 867210 method call count for IClientUserStats::GetNumAchievements : 55
Game 867210 method call count for IClientAppManager::GetCurrentLanguage : 1
Game 867210 method call count for IClientAppManager::GetLaunchCommandLine : 1
Game 867210 method call count for IClientAppManager::GetActiveBeta : 1
Game 867210 method call count for IClientUtils::RecordSteamInterfaceCreation : 32
Game 867210 method call count for IClientUtils::InitFilterText : 1
Game 867210 method call count for IClientUtils::GetAPICallResult : 7
Game 867210 method call count for IClientUtils::GetAppID : 36
Game 867210 method call count for IClientUtils::GetIPCountry : 1
Game 867210 method call count for IClientFriends::GetFriendPersonaName_Public : 1
Game 867210 method call count for IClientFriends::ClearRichPresence : 1
Game 867210 method call count for IClientFriends::SetRichPresence : 3
Game 867210 method call count for IClientFriends::RequestUserInformation : 1
Game 867210 method call count for IClientFriends::IsUserInSource : 1
Game 867210 method call count for IClientFriends::GetPersonaName : 1
Game 867210 method call count for IClientUser::BIsSubscribedApp : 1
Game 867210 method call count for IClientUser::GetEncryptedAppTicket : 1
Game 867210 method call count for IClientUser::RequestEncryptedAppTicket : 1
Game 867210 method call count for IClientUser::CancelAuthTicket : 1
Game 867210 method call count for IClientUser::GetAuthTicketForWebApi : 1
Game 867210 method call count for IClientUser::GetSteamID : 3
Game 867210 method call count for IClientUser::BLoggedOn : 2
Uploaded AppInterfaceStats to Steam
Removing process 60595 for gameID 867210
Removing process 60592 for gameID 867210
Removing process 60575 for gameID 867210
Removing process 60562 for gameID 867210
Removing process 60556 for gameID 867210
Removing process 60543 for gameID 867210
Removing process 60533 for gameID 867210
Removing process 60530 for gameID 867210
Removing process 60520 for gameID 867210
Removing process 60517 for gameID 867210
Removing process 60516 for gameID 867210
Removing process 60515 for gameID 867210
Removing process 60514 for gameID 867210
Removing process 60410 for gameID 867210
Removing process 60409 for gameID 867210
Removing process 60402 for gameID 867210
Removing process 60401 for gameID 867210
[2024-06-16 09:24:36] Shutdown

The games freeze on loading, (and resume loading when I exit full screen )alt+tab))
Well, if you're not able to solve your issue, you could always use Gamescope...

In Launch Options, set:

gamescope -- %command%

Now you can use SUPER+ALT+F to fullscreen and unfullscreen. I use this for games where fullscreen is broken.

Last edited by pleasereadthemanual on 17 June 2024 at 7:49 am UTC
MaximB Jun 17
I've installed MATE desktop environment and the games run fine there.
So the issue is with Cinnamon.

Still not sure how to fix this if I don't want to use MATE.
LoudTechie Jun 18
Have you installed the 32 bit wine libraries
LoudTechie Jun 18
These people have the same problem and several fixes.

Last edited by LoudTechie on 18 June 2024 at 1:37 pm UTC
MaximB Jun 18

I have installed the 32-bit libs,
I do not use Gamescope,
All games start on Steam, but after starting some games stuck at 1st screen (main menu or before) on fullscreen,
If I alt+tab, they continue to run and I can see them run in thumbnail preview window,
It only seems to happen in Cinnamon desktop manager,
When I switch to MATE or XFCE, the problem disappears and games run fine.
While you're here, please consider supporting GamingOnLinux on:

Reward Tiers: Patreon. Plain Donations: PayPal.

This ensures all of our main content remains totally free for everyone! Patreon supporters can also remove all adverts and sponsors! Supporting us helps bring good, fresh content. Without your continued support, we simply could not continue!

You can find even more ways to support us on this dedicated page any time. If you already are, thank you!
Login / Register

Or login with...
Sign in with Steam Sign in with Google
Social logins require cookies to stay logged in.