Join us on our own very special Reddit: /r/Linuxers
Today steam client could not see my 2nd library disk
Stoney_Fish 4 Nov, 2015
Ubuntu 15.10
2nd HDD : 3TB disk ext4 , with about 1.4TB of steam games.

It's has be fine for 1yr +

Today in the steam client it looked like all the library was not installed.
Steam client -> Settings -> downloads -> Library folders not longer showed the 2nd path to the 3TB
Tried to add it back and got the message.
"New Steam library folder must be on a filesystem mounted with executable permissions"
To add it I first needed to rename the folder SteamApps to be lower case.

/media/my_user/Data/Steam/SteamApps
to
/media/my_user/Data/Steam/steamapps

Now it works again.
StianTheDark 5 Nov, 2015
Why was it uppercase?
Stoney_Fish 5 Nov, 2015
The directory name was mixed case "SteamApps" and had been working fine, the client had created it like that a year or so ago.

Yesterday my Steam client gave a strange message about "...mounted with executable permissions"

It was actually resolved by renaming the folder to "steamapps"
While you're here, please consider supporting GamingOnLinux on:

Patreon, Liberapay or PayPal Donation.

We have no adverts, no paywalls, no timed exclusive articles. Just good, fresh content. Without your continued support, we simply could not continue!

You can find even more ways to support us on this dedicated page any time. If you already are, thank you!
Login / Register

Or login with...
Sign in with Steam Sign in with Twitter Sign in with Google
Social logins require cookies to stay logged in.

Livestreams & Videos
Community Livestreams
Latest Forum Posts