You can sign up to get a daily email of our articles, see the Mailing List page!
Support us on Patreon to keep GamingOnLinux alive. This ensures we have no timed articles and no paywalls. Just good, fresh content! Alternatively, you can donate through Paypal, Flattr and Liberapay.!
  Go to:
[Fixed, needs testing] Dying Light refuses to launch
skyrrd commented on 30 May 2017 at 9:40 pm UTC

Like already written in the comments of recent Dying Light news i'm unable to launch the game no matter what.

About my setup:

i5 4690S
r9 290
16gb ram
games on seperate ext4 partition

I'm running Gentoo 64bit with 4.11 kernel and amdgpu kernel module.
Mesa, LLVM and LibDRM are all -9999 (git/dev versions)
I have installed Steam via overlay and already run esteam to install dependencies.
I don't have this issue with other games.

What happens:

When launching the game with "MESA_GL_VERSION_OVERRIDE=4.5 MESA_GLSL_VERSION_OVERRIDE=450 %command%" from steam there is a short flash of a corrupted windows (approx. the size of graphics driver waring without override or the logo) then nothing happens, but Dying Light is still listed as running.

terminal output:

Game update: AppID 239140 "Dying Light", ProcID 6146, IP >>> Adding process 6146 for game ID 239140 ERROR: object '/home/tom/.local/share/Steam/ubuntu12_32/' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored. ERROR: object '/home/tom/.local/share/Steam/ubuntu12_32/' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored. >>> Adding process 6148 for game ID 239140 Installing breakpad exception handler for appid(gameoverlayui)/version(20170425224519) Installing breakpad exception handler for appid(gameoverlayui)/version(1.0) Setting breakpad minidump AppID = 239140 Steam_SetMinidumpSteamID: Caching Steam ID: 76561198059609792 [API loaded no] Installing breakpad exception handler for appid(gameoverlayui)/version(1.0) Fontconfig error: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 70: non-double matrix element Fontconfig error: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 70: non-double matrix element Fontconfig warning: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 78: saw unknown, expected number Installing breakpad exception handler for appid(gameoverlayui)/version(1.0) Setting breakpad minidump AppID = 769 Steam_SetMinidumpSteamID: Caching Steam ID: 76561198059609792 [API loaded no] [0530/] Widevine registration is not supported after context initialization Generating new string page texture 170: 16x256, total string texture memory is 2,94 MB Generating new string page texture 171: 512x256, total string texture memory is 3,47 MB

crash log:

{23:16:17.507} INFO: [INFO] > [OpenGL] Extensions = {23:16:17.507} INFO: [INFO] | GL_AMD_conservative_depth GL_AMD_draw_buffers_blend GL_AMD_performance_monitor GL_AMD_pinned_memory {23:16:17.507} INFO: [INFO] | GL_AMD_seamless_cubemap_per_texture GL_AMD_shader_stencil_export GL_AMD_shader_trinary_minmax GL_AMD_vertex_shader_layer {23:16:17.507} INFO: [INFO] | GL_AMD_vertex_shader_viewport_index GL_ANGLE_texture_compression_dxt3 GL_ANGLE_texture_compression_dxt5 GL_ARB_ES2_compatibility {23:16:17.507} INFO: [INFO] | GL_ARB_ES3_1_compatibility GL_ARB_ES3_2_compatibility GL_ARB_ES3_compatibility GL_ARB_arrays_of_arrays {23:16:17.507} INFO: [INFO] | GL_ARB_base_instance GL_ARB_blend_func_extended GL_ARB_buffer_storage GL_ARB_clear_buffer_object {23:16:17.507} INFO: [INFO] | GL_ARB_clear_texture GL_ARB_clip_control GL_ARB_color_buffer_float GL_ARB_compressed_texture_pixel_storage {23:16:17.507} INFO: [INFO] | GL_ARB_compute_shader GL_ARB_compute_variable_group_size GL_ARB_conditional_render_inverted GL_ARB_conservative_depth {23:16:17.507} INFO: [INFO] | GL_ARB_copy_buffer GL_ARB_copy_image GL_ARB_cull_distance GL_ARB_debug_output {23:16:17.507} INFO: [INFO] | GL_ARB_depth_buffer_float GL_ARB_depth_clamp GL_ARB_derivative_control GL_ARB_direct_state_access {23:16:17.507} INFO: [INFO] | GL_ARB_draw_buffers GL_ARB_draw_buffers_blend GL_ARB_draw_elements_base_vertex GL_ARB_draw_indirect {23:16:17.507} INFO: [INFO] | GL_ARB_draw_instanced GL_ARB_enhanced_layouts GL_ARB_explicit_attrib_location GL_ARB_explicit_uniform_location {23:16:17.507} INFO: [INFO] | GL_ARB_fragment_coord_conventions GL_ARB_fragment_layer_viewport GL_ARB_fragment_shader GL_ARB_framebuffer_no_attachments {23:16:17.507} INFO: [INFO] | GL_ARB_framebuffer_object GL_ARB_framebuffer_sRGB GL_ARB_get_program_binary GL_ARB_get_texture_sub_image {23:16:17.507} INFO: [INFO] | GL_ARB_gpu_shader5 GL_ARB_gpu_shader_fp64 GL_ARB_gpu_shader_int64 GL_ARB_half_float_pixel {23:16:17.507} INFO: [INFO] | GL_ARB_half_float_vertex GL_ARB_indirect_parameters GL_ARB_instanced_arrays GL_ARB_internalformat_query {23:16:17.507} INFO: [INFO] | GL_ARB_internalformat_query2 GL_ARB_invalidate_subdata GL_ARB_map_buffer_alignment GL_ARB_map_buffer_range {23:16:17.507} INFO: [INFO] | GL_ARB_multi_bind GL_ARB_multi_draw_indirect GL_ARB_occlusion_query2 GL_ARB_pipeline_statistics_query {23:16:17.507} INFO: [INFO] | GL_ARB_pixel_buffer_object GL_ARB_point_sprite GL_ARB_program_interface_query GL_ARB_provoking_vertex {23:16:17.507} INFO: [INFO] | GL_ARB_query_buffer_object GL_ARB_robust_buffer_access_behavior GL_ARB_robustness GL_ARB_sample_shading {23:16:17.507} INFO: [INFO] | GL_ARB_sampler_objects GL_ARB_seamless_cube_map GL_ARB_seamless_cubemap_per_texture GL_ARB_separate_shader_objects {23:16:17.507} INFO: [INFO] | GL_ARB_shader_atomic_counter_ops GL_ARB_shader_atomic_counters GL_ARB_shader_ballot GL_ARB_shader_bit_encoding {23:16:17.507} INFO: [INFO] | GL_ARB_shader_clock GL_ARB_shader_draw_parameters GL_ARB_shader_group_vote GL_ARB_shader_image_load_store {23:16:17.507} INFO: [INFO] | GL_ARB_shader_image_size GL_ARB_shader_objects GL_ARB_shader_precision GL_ARB_shader_stencil_export {23:16:17.507} INFO: [INFO] | GL_ARB_shader_storage_buffer_object GL_ARB_shader_subroutine GL_ARB_shader_texture_image_samples GL_ARB_shader_texture_lod {23:16:17.507} INFO: [INFO] | GL_ARB_shader_viewport_layer_array GL_ARB_shading_language_420pack GL_ARB_shading_language_packing GL_ARB_stencil_texturing {23:16:17.507} INFO: [INFO] | GL_ARB_sync GL_ARB_tessellation_shader GL_ARB_texture_barrier GL_ARB_texture_buffer_object {23:16:17.507} INFO: [INFO] | GL_ARB_texture_buffer_object_rgb32 GL_ARB_texture_buffer_range GL_ARB_texture_compression_bptc GL_ARB_texture_compression_rgtc {23:16:17.507} INFO: [INFO] | GL_ARB_texture_cube_map_array GL_ARB_texture_float GL_ARB_texture_gather GL_ARB_texture_mirror_clamp_to_edge {23:16:17.507} INFO: [INFO] | GL_ARB_texture_multisample GL_ARB_texture_non_power_of_two GL_ARB_texture_query_levels GL_ARB_texture_query_lod {23:16:17.507} INFO: [INFO] | GL_ARB_texture_rectangle GL_ARB_texture_rg GL_ARB_texture_rgb10_a2ui GL_ARB_texture_stencil8 {23:16:17.507} INFO: [INFO] | GL_ARB_texture_storage GL_ARB_texture_storage_multisample GL_ARB_texture_swizzle GL_ARB_texture_view {23:16:17.507} INFO: [INFO] | GL_ARB_timer_query GL_ARB_transform_feedback2 GL_ARB_transform_feedback3 GL_ARB_transform_feedback_instanced {23:16:17.507} INFO: [INFO] | GL_ARB_uniform_buffer_object GL_ARB_vertex_array_bgra GL_ARB_vertex_array_object GL_ARB_vertex_attrib_64bit {23:16:17.507} INFO: [INFO] | GL_ARB_vertex_attrib_binding GL_ARB_vertex_shader GL_ARB_vertex_type_10f_11f_11f_rev GL_ARB_vertex_type_2_10_10_10_rev {23:16:17.507} INFO: [INFO] | GL_ARB_viewport_array GL_ATI_blend_equation_separate GL_ATI_meminfo GL_ATI_texture_float {23:16:17.507} INFO: [INFO] | GL_ATI_texture_mirror_once GL_EXT_abgr GL_EXT_blend_equation_separate GL_EXT_depth_bounds_test {23:16:17.507} INFO: [INFO] | GL_EXT_draw_buffers2 GL_EXT_draw_instanced GL_EXT_framebuffer_blit GL_EXT_framebuffer_multisample {23:16:17.507} INFO: [INFO] | GL_EXT_framebuffer_multisample_blit_scaled GL_EXT_framebuffer_sRGB GL_EXT_packed_depth_stencil GL_EXT_packed_float {23:16:17.507} INFO: [INFO] | GL_EXT_pixel_buffer_object GL_EXT_polygon_offset_clamp GL_EXT_provoking_vertex GL_EXT_shader_integer_mix {23:16:17.507} INFO: [INFO] | GL_EXT_texture_array GL_EXT_texture_compression_dxt1 GL_EXT_texture_compression_rgtc GL_EXT_texture_compression_s3tc {23:16:17.507} INFO: [INFO] | GL_EXT_texture_filter_anisotropic GL_EXT_texture_integer GL_EXT_texture_mirror_clamp GL_EXT_texture_sRGB {23:16:17.507} INFO: [INFO] | GL_EXT_texture_sRGB_decode GL_EXT_texture_shared_exponent GL_EXT_texture_snorm GL_EXT_texture_swizzle {23:16:17.507} INFO: [INFO] | GL_EXT_timer_query GL_EXT_transform_feedback GL_EXT_vertex_array_bgra GL_IBM_multimode_draw_arrays {23:16:17.507} INFO: [INFO] | GL_KHR_context_flush_control GL_KHR_debug GL_KHR_no_error GL_KHR_robust_buffer_access_behavior {23:16:17.507} INFO: [INFO] | GL_KHR_robustness GL_MESA_pack_invert GL_MESA_shader_integer_functions GL_MESA_texture_signed_rgba {23:16:17.507} INFO: [INFO] | GL_NVX_gpu_memory_info GL_NV_conditional_render GL_NV_depth_clamp GL_NV_packed_depth_stencil {23:16:17.507} INFO: [INFO] | GL_NV_texture_barrier GL_NV_vdpau_interop GL_OES_EGL_image GL_S3_s3tc {23:16:17.507} INFO: [INFO] | {23:16:17.507} INFO: [INFO] > [OpenGL] MajorVersionDetected=4 MinorVersionDetected=5 {23:16:17.508} INFO: [INFO] > [OpenGL] Extension ARB_debug_output is supported {23:16:17.508} INFO: [INFO] > [OpenGL] Extension ARB_blend_func_extended is supported {23:16:17.508} INFO: [INFO] > [OpenGL] Video memory detected: 0 [MB]! {23:16:17.513} INFO: [INFO] > Caught signal 11 (Segmentation fault). {23:16:17.514} INFO: [INFO] > /lib64/ [0x7fa5074b4180] {23:16:17.514} INFO: [INFO] | /lib64/ [0x7fa50ee4f5e0] {23:16:17.514} INFO: [INFO] | /usr/lib64/dri/ [0x7fa4fbdf6070] {23:16:17.514} INFO: [INFO] | /usr/lib64/dri/ [0x7fa4fbdf60d8] {23:16:17.514} INFO: [INFO] | /lib64/ [0x7fa5074b6a88] {23:16:17.514} INFO: [INFO] | /lib64/ [0x7fa5074b6ad5] {23:16:17.514} INFO: [INFO] | /home/tom/.local/share/Steam/steamapps/common/Dying Light/ [0x7fa4ec0b4edc] {23:16:17.514} INFO: [INFO] | /home/tom/.local/share/Steam/steamapps/common/Dying Light/ [0x7fa4ec0b596f] {23:16:17.514} INFO: [INFO] | /home/tom/.local/share/Steam/steamapps/common/Dying Light/ [0x7fa50927584f] {23:16:17.514} INFO: [INFO] | /home/tom/.local/share/Steam/steamapps/common/Dying Light/ [0x7fa508d6b9d8] {23:16:17.514} INFO: [INFO] | /home/tom/.local/share/Steam/steamapps/common/Dying Light/DyingLightGame(main+0xa45) [0x43dfb5] {23:16:17.514} INFO: [INFO] | /lib64/ [0x7fa5074a1790] {23:16:17.514} INFO: [INFO] | /home/tom/.local/share/Steam/steamapps/common/Dying Light/DyingLightGame() [0x44228c]

i am really puzzled what else i could try and would be happy if someone could help ;)

sr_ls_boy commented on 31 May 2017 at 7:47 pm UTC

What version of LLVM are you running?

EDIT: I haven't had much luck getting the game to work either.
I have done exactly what you have done and get the same output.
That 'short flash of a corrupted window' is suppose to be the
Dying Light logo. But it's corrupted for me as well. When you
start the game, two processes with two separate PID's start
running. One time, I happen to kill the right one and the
game popped up.

By trial and error,uh..,or hit or miss, the game will work.
But the main menu is so graphically corrupt for me that I
can't even start a game.

skyrrd commented on 31 May 2017 at 9:00 pm UTC

This sounds very interesting. Will try it sometime.

Should be llvm-4

sr_ls_boy commented on 31 May 2017 at 10:38 pm UTC

Where are you finding these crash logs?

EDIT: Nevermind. I found them.
This from my logs. Mesa isn't reporting any video memory.
{21:54:20.616} INFO: [INFO] > [OpenGL] Video memory detected: 0 [MB]! {21:54:20.620} INFO: [INFO] > Caught signal 11 (Segmentation fault).

This is a working log from Nvidia with closed drivers(375.39).
{02:12:49.638} INFO: [INFO] > [OpenGL] Video memory detected: 2048 [MB]! {02:12:49.702} INFO: [INFO] > [OpenGL] GPU's vendor id: 1 [0x0001]; GPU's device id: 2 [0x0002]. {02:12:49.702} INFO: [INFO] > [OpenGL] Shader binary dir = 4_5_0_NVIDIA_375_39. {02:12:49.702} INFO: [INFO] > [OpenGL] GL_UNIFORM_BUFFER_OFFSET_ALIGNMENT = 256 {02:12:49.702} INFO: [INFO] > [OpenGL] GL_MAX_UNIFORM_BLOCK_SIZE = 65536 {02:12:49.798} INFO: [INFO] > Texture streaming lowest priority distance set to 100m {02:12:49.846} INFO: [INFO] > [SDL::WindowMode] Current SwapInterval: 1 {02:12:49.848} INFO: [INFO] > [SDL::SetWindowMode] Setting no vsync resulted in: 0 SDL_GetError: {02:12:49.849} INFO: [INFO] > [SDL::WindowMode] Current SwapInterval: 0 {02:12:49.887} INFO: [INFO] > [SDL] Resizing window to 1600x900 f:1 v:0 {02:12:53.303} INFO: [INFO] > Texture streaming buffer set to 400MB

Maybe there is an override reporting video memory.

sr_ls_boy commented on 31 May 2017 at 11:22 pm UTC

I filed a mesa bug report.

g000h commented on 1 June 2017 at 7:01 pm UTC

Just been testing and my Dying Light is working fine (Nvidia closed source binary).

sr_ls_boy commented on 1 June 2017 at 7:51 pm UTC

I posted a working nvidia log.

sr_ls_boy commented on 2 June 2017 at 12:33 am UTC

DL Works on Ubuntu with Mesa. I can only look
at the logs and compare them with my favorite
linux distro(Linux from Scratch). I'd really
would like to try and fix this rather than
use Ubuntu.

This is a splicing of LFS & Ubuntu.
Two things: Ubuntu reports zero video memory
as well. Ubuntu correctly id's my video cards
pciid as [0x1002:0x67ef]. But nvidia also gives

Spoiler, click me

> MajorVersionDetected=4 MinorVersionDetected=5
> Extension ARB_debug_output is supported
> Extension ARB_blend_func_extended is supported
> Video memory detected: 0 [MB]!

<seg fault occurs here>

some additional lines dumped after the fault
> GPU's vendor id: 1 [0x0001]; GPU's device id: 2 [0x0002].
> Shader binary dir = 4_5_Core_Profile_Mesa_17_2_0-devel_git-55d1550d35_.

Ubuntu continues on with these extra lines not in my log

> Texture streaming lowest priority distance set to 100m
> [SDL::WindowMode] Current SwapInterval: 1
> [SDL::SetWindowMode] Setting no vsync resulted in: 0 SDL_GetError:
> [SDL::WindowMode] Current SwapInterval: 0
> [SDL] Resizing window to 1600x900 f:1 v:0
> Texture streaming buffer set to 400MB

Ubuntu also gives different gpu id's
GPU's vendor id: 4098 [0x1002] not 1
GPU's device id: 26607 [0x67ef] and not 2

The steam console with mesa debugging turned up
some interesting lines.

Spoiler, click me

Steam: An X Error occurred
X Error of failed request: BadWindow (invalid Window parameter)
Major opcode of failed request: 40 (X_TranslateCoords)
Resource id in failed request: 0x1000fce
Serial number of failed request: 25757
xerror_handler: X failed, continuing
.Mesa: User error: GL_INVALID_OPERATION in unsupported function called (unsupported extension or deprecated function?)
Mesa: 4 similar GL_INVALID_OPERATION errors
Mesa: User error: GL_INVALID_ENUM in glEnable(GL_TEXTURE_2D)
Mesa: User error: GL_INVALID_ENUM in glDisable(GL_TEXTURE_2D)

So, after all of that, I still don't know anything.
I'm at a loss to explain this. I can't even be sure
that this is a mesa-related problem at all or
something else. All other games run fine in Mesa.

My specs:
CLFS SYSVINIT-20170517-x86_64-Multilib
glibc(version 2.25)
LLVM 5.0-git
Mesa 17.2-git
X Server 1.19.3
LXDE desktop
kernel 4.12.0-rc3( with amdgpu module)

blendi-93 commented on 2 June 2017 at 7:42 am UTC

i had the same issue, to fix it i emerged steam-meta and run it.
steam meta installed and downgraded some packages (including glew) this fixed it for me.

sr_ls_boy commented on 2 June 2017 at 2:06 pm UTC

I'm not using gentoo. I don't really know what steam-meta is. Is it the steam bootstrapper?
Is it an executable? Is it a set of system libraries?

'skyrrd' if you do follow this hint, make note of which libraries are installed when emerging.

I ran this inside the DL game folder:
find -name "*.so" -exec ldd {} \; | grep not | sort -u
Then I just pulled some libraries from the steam runtime and placed in my system folder.
That allowed me to run the game without using steam runtime but it didn't fix the crash.

sr_ls_boy commented on 2 June 2017 at 5:02 pm UTC

I set up a topic on tracing steam games.

  Go to:

Due to spam you need to Register and Login to comment.

Or login with...

Livestreams & Videos
Community Livestreams
See more!
Popular this week
View by Category
Latest Comments
Latest Forum Posts