You can sign up to get a daily email of our articles, see the Mailing List page!
Support us on Patreon to keep GamingOnLinux alive. This ensures we have no timed articles and no paywalls. Just good, fresh content! Alternatively, you can donate through Paypal, Flattr and Liberapay!
Steam controller doesn't work reliably
jay commented on 23 August 2017 at 5:59 am UTC

I am running Ubuntu 17.04 and have been experiencing inconsistent behavior with the steam controller. I am running Steam in Big Picture Mode, and I added the following udev rules (which I found via Google):

SUBSYSTEM=="usb", ATTRS{idVendor}=="28de", MODE="0666" KERNEL=="uinput", MODE="0660", GROUP="gamers", OPTIONS+="static_node=uinput" KERNEL=="hidraw*", ATTRS{idVendor}=="28de", MODE="0666" KERNEL=="hidraw", KERNELS=="28DE:*", MODE="0666"

Note: I made sure to add myself to the "Gamers" group.

Here's what's strange. In the BPM interface, the controller works fine. When running Portal 2, no issues whatsoever. The controller is great.

Where it breaks down is when I'm running Axiom Verge and Hollow Knight. The Steam controller isn't recognized at all. Even if I select a controller profile, it just doesn't work at all.

If I plug in an Xbox 360 controller, it will work fine on those games with no issues. I'd rather use my Steam controller, though.

I have had a chance to try the Steam controller on Windows with Axiom Verge for example, it works fine. So I'm not sure what's different about Ubuntu to prevent this from working.

I'm hoping someone else has run across this and may be able to offer guidance.

silmeth commented on 23 August 2017 at 6:21 pm UTC

Do you have any other controllers plugged in? I had problems with my Steam Controller not being recognized in Shadow of Mordor when I had my Xbox360 controller plugged in and configured using xboxdrv. When I unplugged the X360 controller and turned xboxdrv off, it worked.

The issue, apparently, was that Steam Controller was not recognized as the first (main) controller, and this particular game did not like it, while some other ones worked (and allowed me to choose which controller I want to use). Also changing the order in Steam settings did not help.

By the way, instead of manually setting udev rules, in Ubuntu you can just install the steam-devices package which does it for you.

jay commented on 24 August 2017 at 8:00 am UTC

silmethDo you have any other controllers plugged in? I had problems with my Steam Controller not being recognized in Shadow of Mordor when I had my Xbox360 controller plugged in and configured using xboxdrv. When I unplugged the X360 controller and turned xboxdrv off, it worked.

The issue, apparently, was that Steam Controller was not recognized as the first (main) controller, and this particular game did not like it, while some other ones worked (and allowed me to choose which controller I want to use). Also changing the order in Steam settings did not help.

By the way, instead of manually setting udev rules, in Ubuntu you can just install the steam-devices package which does it for you.
Thank you! It's working now.

I'm not entirely sure what fixed it. I did a combination of what you mentioned, but I also added a reboot in there too. I'm wondering if perhaps I needed to reboot in order for the order of controller preference to be reset? I originally removed my X360 controller and restarted Steam, but that didn't fix it by itself. I also installed the package you mentioned (after removing my manual file) and then I also installed the steam-devices package you mentioned. That still didn't fix it, but after a reboot, something must have cleared. So I'll give you credit for the resolution, since what you said was probably the culprit.

Thanks!

Due to spam you need to Register and Login to comment.


Or login with...

Livestreams & Videos
Community Livestreams
  • Friday Livestream with Samsai
  • Date:
See more!
Popular this week
View by Category
Contact
Latest Comments
Latest Forum Posts