You can sign up to get a daily email of our articles, see the Mailing List page!
GTA under Wine
vito 15 Oct, 2017

I've been trying to go through my old games on CDs and see if I can get them running under Wine. So far I had good luck, however for some reason none of the GTA3 (Grand Theft Auto) based games work (GTAIII, San Andreas, Vice City).

It always crashes right after the Nvidia logo and the backtrace shows "winegstreamer" as the module it crashes in.

Has anyone had good luck getting these games to work and do you have any tips?

Ketil 15 Oct, 2017

I had no issues with SA with the steam versions following the instructions on appdb.winehq.org although it has been a while since I tried it. It is possible that it worked better with older wine versions. I don't remember if I played Vice City in Wine or if I only played it before I switched to linux. I never tried GTA3 so I have no idea how well that worked.

Generally look at the appdb entry for the game, and see if there are any bugs that might affect it.

Avehicle7887 15 Oct, 2017

Try adding winegstreamer to your override list and set it as disabled.

Fallout 3, New Vegas and TES Oblivion have the same issue and are fixed using the same override method.

vito 15 Oct, 2017

Thanks for the response - I did try all the suggested fixes on the app db but so far none of them worked. This is why I posted here. It is possible that the Steam version of GTA has been updated and works, however I do not have a Steam version of GTA3. Lately, I have been voting with my wallet and purchasing only games that have native Linux support so this is why I was looking at the CD version. It is possible that I have too new version of Wine as well (tried 2.17 and 2.18), although I tried the Play On Linux beta San Andreas script that uses older wine version and that failed as well with the same error. It is strange that I keep seeing that "winegstreamer" error - makes me wonder if there is something wrong with that on my setup.

Ehvis 15 Oct, 2017

The only problem that I recall is that the intro video won't play. But clicking a couple of times moves you on to the menu. Otherwise no issues as far as I can remember.

vito 15 Oct, 2017

When I disable winegstreamer module, it goes further but still crashes, this time in devenum (see below). I'm going to dig around a bit about devenum problems. Thanks guys

Unhandled exception: page fault on read access to 0x00000000 in 32-bit code (0x6338f4db).
Register dump:
CS:0023 SS:002b DS:002b ES:002b FS:0063 GS:006b
EIP:6338f4db ESP:0172ef40 EBP:0172f1a8 EFLAGS:00010246( R- -- I Z- -P- )
EAX:00000000 EBX:6339c000 ECX:0172f1b4 EDX:00000000
ESI:00000000 EDI:0172f1cc
Stack dump:
0x0172ef40: 7bd06000 0172f0fc 0172ef68 00000118
0x0172ef50: 00430008 0053004c 00440049 64ecaf00
0x0172ef60: 7bd06000 7e868be8 036d2930 032bf768
0x0172ef70: 00000000 0172f0fc 0172ef98 7bc7ffba
0x0172ef80: 0172efa0 7e899000 0172efb8 7e932483
0x0172ef90: 00300030 00300041 7e91c141 7e932483
Backtrace:
=>0 0x6338f4db in devenum (+0xf4db) (0x0172f1a8)
1 0x35542138 in quartz (+0x42137) (0x0172f1d8)
2 0x3553c1c2 in quartz (+0x3c1c1) (0x0172f208)
3 0x3553c9fa in quartz (+0x3c9f9) (0x0172f268)
4 0x3553862a in quartz (+0x38629) (0x0172f294)
5 0x3553840b in quartz (+0x3840a) (0x0172f2ec)
6 0x35538358 in quartz (+0x38357) (0x0172f308)
7 0x35539b14 in quartz (+0x39b13) (0x0172f368)
0x6338f4db: movzwl 0x0(%edx),%eax

While you're here, please consider supporting GamingOnLinux on:

Patreon, Liberapay or PayPal Donation.

We have no adverts, no paywalls, no timed exclusive articles. Just good, fresh content. Without your continued support, we simply could not continue!

You can find even more ways to support us on this dedicated page any time. If you already are, thank you!

You need to Register and Login to comment, submit articles and more.


Or login with...