Support us on Patreon to keep GamingOnLinux alive. This ensures we have no timed articles and no paywalls. Just good, fresh content! Alternatively, you can donate through Paypal, Flattr and Liberapay!
  Go to:
404 errors?
liamdawe commented on 1 February 2013 at 10:36 pm UTC

Has anyone been experiencing random 404 errors?

Xpander commented on 5 February 2013 at 8:21 pm UTC

i do experience

"This is not the page you where looking for...404 Not Found oh noes! You may have followed an old link from the old website.

Most pages are now at a new address since the switch from xenforo to custom software!

Please update your links!

Click here to return.

Referring Url: http://www.gamingonlinux.com/index.php"

its when im letting my browser to be on some topic and that topic gets some new comments. when i click refresh (f5) then it brings me to this error message. so i have to go to the index page and then back to the topic to see the new updated comments.

same thing happens on the main index page.. if the tab is open and there is new content updates and i press the refresh(f5) it throws me that error to go back to index page where i am actually.

pretty nasty thing. this was introduced with the new webpage.

liamdawe commented on 5 February 2013 at 8:44 pm UTC

It's a hard bug to track down as it's nothing to do with the PHP or MySQL it's either a bug with how I do my mod_rewrite or it's my host's security - which i think it is.

I've seen in my error log urls being blocked for being too long (i'm guessing because of article titles), i've been in touch and they where supposed to turn it off but it seems not.

Hamish commented on 5 February 2013 at 11:44 pm UTC

In a word (or three): all the time. Not very helpful, I know. It does seem to be somewhat related to the URL redirecting you did for the transition from the old website though, at least for me.

liamdawe commented on 6 February 2013 at 11:23 am UTC

I have removed redirect for older articles, please let me know if that helps at all.

Xpander commented on 6 February 2013 at 2:47 pm UTC

still same

liamdawe commented on 6 February 2013 at 2:48 pm UTC

Right next time it happens, get me a screenshot.

Xpander commented on 6 February 2013 at 3:36 pm UTC

ok here we go:
the article i was on was: http://www.gamingonlinux.com/articles/psychonauts-and-closure-in-steam-linux-and-big-sale-planned.1712

it was open for like 20-30 min, then i came back to that tab and hit F5 to refresh it
and then that comes up

https://dl.dropbox.com/u/28788188/Screenshot%20from%202013-02-06%2017%3A33%3A55.png

it seems that it redirects to

http://www.gamingonlinux.com/articles/index.php when i hit refresh and the real arcticle ...psychonauts-and-closure-in-steam-linux-and-big-sale-planned.1712 dissapears.

liamdawe commented on 6 February 2013 at 8:42 pm UTC

I sent that to my host, they have re-built apache and added another 512mb ram as we where going into swap for some reason.

If it carries on let me know and keep screenshotting.

liamdawe commented on 8 February 2013 at 9:15 pm UTC

This should be fixed now.

What I think it was - the auto login stuff that searches for a cookie after setting you as logged in it redirected to "index.php" (so which would log you in again when a session expires).

Set it to go to the same page the user was on before.

Xpander commented on 8 February 2013 at 9:55 pm UTC

seems to be fixed now yeah.
thanks

  Go to:

Due to spam you need to Register and Login to comment.


Or login with...

Livestreams & Videos
Community Livestreams
  • RPGoodness: „Dragon Age: Origins“ (via Wine)
  • Date:
See more!
Popular this week
View by Category
Contact
Latest Comments
Latest Forum Posts