You can sign up to get a daily email of our articles, see the Mailing List page!
Support us on Patreon to keep GamingOnLinux alive. This ensures we have no timed articles and no paywalls. Just good, fresh content! Alternatively, you can donate through Paypal, Flattr and Liberapay.!
Dying Light OpenGl
DreamArch commented on 29 March 2018 at 7:51 am UTC

So I had the OpenGL 3.0 Mesa error on Dying Light, and I got rid of the error message with some launch options. Then the screen was black on launch, although the audio was fine. Now I see that mesa was updated, and try to install it, but...

==> lib32-mesa-git dependencies: - lib32-gcc-libs (already installed) [makedepend] - lib32-libdrm (already installed) - lib32-wayland (already installed) - lib32-libxxf86vm (already installed) - lib32-libxdamage (already installed) - lib32-libxshmfence (already installed) - lib32-elfutils (already installed) - lib32-libxml2 (already installed) [makedepend] - lib32-libx11 (already installed) [makedepend] - lib32-gcc-libs (already installed) [makedepend] - lib32-libelf (already installed) [makedepend] - git (already installed) [makedepend] - lib32-libgcrypt (already installed) [makedepend] - lib32-systemd (already installed) [makedepend] - wayland-protocols (already installed) [makedepend] - mesa-git (building from AUR) [makedepend] - lib32-llvm-libs-svn (building from AUR) [makedepend] - lib32-libunwind (package found) - python2-mako (package found) [makedepend] - xorgproto (package found) [makedepend] - lib32-libvdpau (package found) [makedepend] - lib32-llvm-svn (building from AUR) [makedepend] - mesa-git (building from AUR) [makedepend] - lib32-llvm-libs-svn (building from AUR) [makedepend] - lib32-libglvnd (package found) [makedepend] ==> lib32-mesa-git conflicts: - lib32-mesa-17.0.1-1 ==> Continue building lib32-mesa-git ? [Y/n] ==> ---------------------------------------- ==> y ==> Building and installing package ==> Install or build missing dependencies for lib32-mesa-git: resolving dependencies... looking for conflicting packages... :: xorgproto and compositeproto are in conflict. Remove compositeproto? [y/N] n error: unresolvable package conflicts detected error: failed to prepare transaction (conflicting dependencies) :: xorgproto and compositeproto are in conflict ==> Restart building lib32-mesa-git ? [y/N] ==> --------------------------------------- ==>

xorgproto is in conflict with EVERYTHING. Help?

Lolo01 commented on 30 March 2018 at 10:16 am UTC

Have you tried MESA_GL_VERSION_OVERRIDE=4.5 MESA_GLSL_VERSION_OVERRIDE=450 %command% ?
%command% is part of the launch command....

sr_ls_boy commented on 30 March 2018 at 8:13 pm UTC

Dying Light is not a good title to run a sanity check on your opengl install.
Which distro are you using? What is the output of glxinfo? How about 'inxi -bM' ?

Any problems with any other games?

sr_ls_boy commented on 30 March 2018 at 8:17 pm UTC

xorgproto is a part of the dependencies for the X server which was completely
revamped. It breaks compatibility with older version of the X server. You may
need to downgrade.

DreamArch commented on 7 April 2018 at 5:59 pm UTC

Lolo, Yes I have tried that. Error was gone, but the game launched, the bar at the bottom loaded, then the screen was black. I could even hear the intro, just couldn't see it.


glxinfo:

OpenGL vendor string: X.Org OpenGL renderer string: Gallium 0.4 on AMD POLARIS10 (DRM 3.9.0 / 4.10.1-1-ARCH, LLVM 3.9.1) OpenGL core profile version string: 4.5 (Core Profile) Mesa 17.0.1 OpenGL core profile shading language version string: 4.50 OpenGL core profile context flags: (none) OpenGL core profile profile mask: core profile OpenGL core profile extensions: OpenGL version string: 3.0 Mesa 17.0.1 OpenGL shading language version string: 1.30 OpenGL context flags: (none) OpenGL extensions: OpenGL ES profile version string: OpenGL ES 3.1 Mesa 17.0.1 OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.10 OpenGL ES profile extensions:

sr_ls_boy commented on 9 April 2018 at 3:01 am UTC

Your version of Mesa is too old. You need at least 7.2 to run DL.

LINK

bidinou commented on 20 November 2018 at 10:12 pm UTC

Hi ! Hmm, even when using "MESA_GL_VERSION_OVERRIDE=4.5 MESA_GLSL_VERSION_OVERRIDE=450 %command%", both games (Dead Island Definitive Edition and Dying Light) instacrash after the initial progress bar is complete.

Any idea ?

I'm using an RX 560 under KDE Neon (based on Ubuntu 18.04) with the daily MESA PPA...

Cheers !

chui2ch commented on 21 November 2018 at 2:59 pm UTC

You need to download a file and put it in the Dying light folder. https://www.gamingonlinux.com/forum/topic/2766/post_id=18112

Due to spam you need to Register and Login to comment.


Or login with...

Livestreams & Videos
Community Livestreams
  • Slash 'Em: „Torchlight II“
  • Date:
See more!
Popular this week
View by Category
Contact
Latest Comments
Latest Forum Posts