You can sign up to get a daily email of our articles, see the Mailing List page!
How to mount a disk IMG file from the GUI??
Comandante Ñoñardo commented on 14 May 2018 at 7:17 am UTC

You know... Right click on the xxxxx.IMG file and voilá, mounted..

I tried with right click "Open With", and select “Disk Image Mounter.” and it throw me an error..

Error mounting /dev/loop0p6 at /media/carlos/Videos: Command-line `mount -t "ntfs" -o "uhelper=udisks2,nodev,nosuid,uid=1001,gid=1001" "/dev/loop0p6" "/media/carlos/Videos"' exited with non-zero exit status 21: ntfs-3g-mount: mount failed: Permiso denegado
Failed to sync device /dev/loop0p6: Error de entrada/salida
Failed to close volume /dev/loop0p6: Error de entrada/salida
 (udisks-error-quark, 0)

Ehvis commented on 14 May 2018 at 9:50 am UTC

Disk Image Mounter is a bit picky about the images that it will mount. A simple "mount -o loop file.img /mnt" (as root) accepts much more.

ageres commented on 14 May 2018 at 1:25 pm UTC

I used gCDEmu.

Comandante Ñoñardo commented on 14 May 2018 at 3:27 pm UTC

ageresI used gCDEmu.

Is an image of en entire NTFS HDD with few partitions what I want to mount.


EhvisDisk Image Mounter is a bit picky about the images that it will mount. A simple "mount -o loop file.img /mnt" (as root) accepts much more.

It didn't work... mount: Hitachi-HTS545025B9A300-2018-05-13-2339.img: failed to setup loop device: No existe el archivo o el directorio


The image file is on an external drive, by the way.

Update: I made a typing mistake in the console with the name of the image...

Now I have another error...

Failed to mount '/dev/loop0': Argumento inválido
The device '/dev/loop0' doesn't seem to have a valid NTFS.
Maybe the wrong device is used? Or the whole disk instead of a
partition (e.g. /dev/sda, not /dev/sda1)? Or the other way around?

Xpander commented on 14 May 2018 at 4:16 pm UTC

theres acetone iso named program try that maybe. i used to use it back in the days when disk image mounter gave troubles.

haven't noticed any problems with the default one lately though, just doubleclick on iso and its mounted

Comandante Ñoñardo commented on 14 May 2018 at 4:39 pm UTC

When I type
fdisk -l Hitachi-HTS545025B9A300-2018-05-13-2339.img

This is what I got:
Disk Hitachi-HTS545025B9A300-2018-05-13-2339.img: 232,9 GiB, 250059350016 bytes, 488397168 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x0f3f0f3f

Disposit.                                    Inicio     Start     Final  Sectores  Size Id Tipo
Hitachi-HTS545025B9A300-2018-05-13-2339.img1             2048  24578047  24576000 11,7G 27 WinRE N
Hitachi-HTS545025B9A300-2018-05-13-2339.img2 *       24578048  24782847    204800  100M  7 HPFS/NT
Hitachi-HTS545025B9A300-2018-05-13-2339.img3         24782848 150611967 125829120   60G  7 HPFS/NT
Hitachi-HTS545025B9A300-2018-05-13-2339.img4        150611968 381308927 230696960  110G  f W95 Ext
Hitachi-HTS545025B9A300-2018-05-13-2339.img5        150614016 171585535  20971520   10G  7 HPFS/NT
Hitachi-HTS545025B9A300-2018-05-13-2339.img6        171587584 276445183 104857600   50G  7 HPFS/NT
Hitachi-HTS545025B9A300-2018-05-13-2339.img7        276447232 297418751  20971520   10G  7 HPFS/NT
Hitachi-HTS545025B9A300-2018-05-13-2339.img8        297420800 318392319  20971520   10G  7 HPFS/NT
Hitachi-HTS545025B9A300-2018-05-13-2339.img9        318394368 381308927  62914560   30G  7 HPFS/NT

crt0mega commented on 14 May 2018 at 8:12 pm UTC

https://www.c-r-t.tk/?action=view&url=mount-a-single-partition-inside-a-disk-image

I had to do the same a while ago. You can't mount the whole disk at once.

Comandante Ñoñardo commented on 15 May 2018 at 1:24 am UTC

crt0megahttps://www.c-r-t.tk/?action=view&url=mount-a-single-partition-inside-a-disk-image

I had to do the same a while ago. You can't mount the whole disk at once.

With that, will the mounted partition appear on desktop like a USB drive?

slaapliedje commented on 15 May 2018 at 2:49 am UTC

crt0megahttps://www.c-r-t.tk/?action=view&url=mount-a-single-partition-inside-a-disk-image

I had to do the same a while ago. You can't mount the whole disk at once.

Interesting. While I know kpartx works with an LVM device on Linux, I've never tried it on a .img with multiple partitions. I'll have to give it a shot and see if it does, because that'd simplify this.

Or you could try it kpartx -av $image_file

crt0mega commented on 15 May 2018 at 4:09 am UTC

Comandante ÑoñardoWith that, will the mounted partition appear on desktop like a USB drive?
Basically, yes. I had to mount partitions somewhere at /media to let them show up in Thunar but you can also navigate to your mountpoint anytime.

slaapliedjeInteresting. While I know kpartx works with an LVM device on Linux, I've never tried it on a .img with multiple partitions. I'll have to give it a shot and see if it does, because that'd simplify this.

Or you could try it kpartx -av $image_file
I'm gonna have a look at kpartx later. That might be indeed simpler!

You need to Register and Login to comment, submit articles and more.


Or login with...

Livestreams & Videos
None currently, submit yours here!
See more!
Popular this week
View by Category
Contact
Latest Comments
Latest Forum Posts