You can sign up to get a daily email of our articles, see the Mailing List page!
RX 580: Low FPS in F1 2017
14 14 Sep, 2018
Hello everybody,

It's driving me crazy that I can't run F1 2017 and get similar FPS as either Phoronix or a friend with a GTX 970 at Ultra settings. That's not the only discrepancy. FPS are also lower in Dota 2 and ETL and Tesseract. For example, my friend with the 970 will get about 77 GPS running the F1 benchmark where I'll only get 47! I traded a GTX 1060 so I could go AMD and run open source; this is driving me nuts! Any ideas of something I could do to get my FPS up?

My card:

vbios_version (this is stock as far as I know):

My grub line:
GRUB_CMDLINE_LINUX_DEFAULT="quiet rcutree.rcu_idle_gp_delay=1 reboot=r,w usbhid.quirks=0x1B1C:0x1B17:0x20000000 radeon.cik_support=0 amdgpu.cik_support=1 amdgpu.dpm=1 amdgpu.dc=1"

The only thing that I can think of right now is my power cap is 165w while the MSI spec says it should be 185w. If I try to change that simply using terminal, it doesn't accept changes. If I try to change max wattage with OhGodATool, my computer freezes.

I have also tried booting into a fresh Ubuntu installation and my F1 benchmark results were the same without tweaking anything. I only installed dependencies like Vulkan.

I'm about an inch away from trading back to an Nvidia card. :(

EDIT: I should note that my processor is an Intel Core i5-3570K. My friend's is a Core i7-2600K.
Xpander 14 Sep, 2018
even with that power limit, it seems lower than it should.that 20W shouldn't make that huge difference. Are you able to check your GPU utilization and clocks during gaming?. Psensor can so graphs about utilization but i dont thin it has clocks. Maybe something is wrong with the power states. also check PCI-E link speed just in case or check if all power cables attached to the GPU are working correctly.

Other than that what driver version you are running and what kernel?
14 15 Sep, 2018
I made a video of the F1 2017 benchmark with GPU load included. It was a good thing to look at I think. It acts pretty strange. It's like it aggressively tries to bounce down to 0% load. That doesn't happen when I run the Unigine Heaven benchmark for example. You know, now that I think about it, I think I got a warning from the F1 2017 game saying that my video card wasn't supported. I'm sure that I suppressed that warning a long time ago. That doesn't explain the lower Dota 2 and ETL FPS compared to Phoronix. Could my CPU be the hindrance in those cases? :/

FYI, this is how I monitored the GPU load and clock speeds:
cat /sys/kernel/debug/dri/0/amdgpu_pm_info

Kernel: 4.18.6-arch1-1-ARCH (x86_64)
OpenGL: 4.5 Mesa 18.1.8 (LLVM 6.0.1)
Display Driver: modesetting 1.20.1
Xpander 15 Sep, 2018
Dota 2 is CPU bound indeed, phoronix tests with i7 8700K which has much more IPC and higher clocks than your 3570K, so the difference comes from there. Still a weird stuff with F1 though, even if your card is not supported.
lucinos 15 Sep, 2018
Quoting: GuestYou should use the amdgpu driver, not modesetting.
Nice I did not know that. I have Arch on my laptop (intel HD) but Manjaro on my desktop and it was an out of the box experience
> inxi -G
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Baffin [Radeon RX 550 640SP / RX 560/560X] driver: amdgpu 
           v: kernel 
           Display: x11 server: X.Org 1.20.1 driver: amdgpu,ati unloaded: modesetting 
           resolution: 1920x1080~60Hz 
           OpenGL: renderer: Radeon RX 560 Series (POLARIS11 DRM 3.26.0 4.18.6-1-MANJARO LLVM 6.0.1) 
           v: 4.5 Mesa 18.1.8 
14 15 Sep, 2018
Quoting: GuestMainline Mesa and kernels do have a buggy and partially implemented amdgpu driver. Use Oibaf ppa Mesa git and the
AMD drm-next-4.20-wip kernel: AMD wip kernel

You should use the amdgpu driver, not modesetting.

xfce@ryzenpc:~$ inxi -bM
  Host: ryzenpc Kernel: 4.19.0-rc1+ x86_64 bits: 64 Desktop: Xfce 4.12.4 
  Distro: Debian GNU/Linux buster/sid 
  Type: Desktop Mobo: ASUSTeK model: PRIME B350M-K v: Rev X.0x 
  serial: <root required> UEFI: American Megatrends v: 4013 date: 06/22/2018 
  6-Core: AMD Ryzen 5 1600 type: MT MCP speed: 2722 MHz 
  Device-1: AMD Baffin [Polaris11] driver: amdgpu v: kernel 
  Display: x11 server: X.Org 1.20.1 driver: amdgpu,ati 
  unloaded: fbdev,modesetting,vesa resolution: 1920x1080~60Hz 
  OpenGL: renderer: Radeon RX 560 Series (POLARIS11 DRM 3.27.0 4.19.0-rc1+ 
  LLVM 7.0.0) 
  v: 4.5 Mesa 18.3.0-devel 
Hmm... thanks for that information. I am not sure that I'm willing to go custom kernel, but maybe Mesa.

I will look up how to switch from modesetting to amdgpu. Thanks. I thought I followed the Arch Wiki page on amdgpu correctly. *shrug*
14 16 Sep, 2018
Alright, I don't have modeset showing up anymore. I was using phoronix-test-suite system-info to look previously. Now, it doesn't show a Display Driver at all.

This utility that you guys used shows amdgpu now. I monkeyed with /etc/mkinitcpio.conf and xorg.conf to switch it from modesetting.
Quoteinxi -G
Graphics: Card-1: Advanced Micro Devices [AMD/ATI] Ellesmere [Radeon RX 470/480/570/570X/580/580X]
driver: amdgpu v: kernel
Display: x11 server: X.Org 1.20.1 driver: amdgpu resolution: 1920x1080~60Hz
OpenGL: renderer: Radeon RX 580 Series (POLARIS10 DRM 3.26.0 4.18.6-arch1-1-ARCH LLVM 6.0.1)
v: 4.5 Mesa 18.1.8

But I'm not convinced that modesetting shouldn't be included. I can't change my refresh rate to 144Hz anymore. The problem in F1 2017 still happens, while Unigine Heaven runs exactly as before.

EDIT: It lets me change the refresh rate if I disable my secondary monitor.
lucinos 16 Sep, 2018
Quoting: 14Alright, I don't have modeset showing up anymore. I was using phoronix-test-suite system-info to look previously. Now, it doesn't show a Display Driver at all.
strange, I installed phoronix-test-suite and it says modesetting :S:
inxi still says amdgpu, ati and modesetting as unloaded.
ok, I have no idea.
14 16 Sep, 2018
I rebuilt my computer with new mobo, CPU, and RAM today (yay!), and F1 doesn't act so strange anymore! :) I average 70 FPS on the Ultra settings benchmark and the GPU load stays at 100% most of the time. Wattage is also near max like I'd expect instead of hovering around 90W-100W like it was before.

Phoronix Test Suite v8.0.1
System Information

  PROCESSOR:          AMD Ryzen 7 2700X Eight-Core @ 3.70GHz
    Core Count:       8
    Thread Count:     16
    Extensions:       SSE 4.2 + AVX2 + AVX + RDRAND + FSGSBASE
    Cache Size:       512 KB
    Microcode:        0x8008204
    Scaling Driver:   acpi-cpufreq powersave

  GRAPHICS:           MSI AMD Radeon RX 580 8192MB
    OpenGL:           4.5 Mesa 18.1.8 (LLVM 6.0.1)
    Monitor:          BenQ GL2460 + BenQ XL2420TE
    Screen:           1920x1080

    BIOS Version:     F2
    Chipset:          AMD Family 17h
    Audio:            AMD Ellesmere
    Network:          Intel I211 Gigabit Connection

  MEMORY:             16384MB

  DISK:               2 x 120GB OCZ VECTOR150 + 60GB OCZ VERTEX2 + 1000GB Seagate ST1000DM003-1CH1 + 2000GB Hitachi HDS72302
    File-System:      ext4
    Mount Options:    relatime rw stripe=256
    Disk Scheduler:   CFQ
    Disk Details:     raid0 sda1[0] sdb1[1]

  OPERATING SYSTEM:   Arch rolling
    Kernel:           4.18.6-arch1-1-ARCH (x86_64)
    Desktop:          KDE Plasma 5.13.5
    Display Server:   X Server 1.20.1
    Compiler:         GCC 8.2.1 20180831
    Security:         __user pointer sanitization + Full AMD retpoline IBPB + SSB disabled via prctl and seccomp Protection
While you're here, please consider supporting GamingOnLinux on:

Patreon, Liberapay or PayPal Donation.

This ensures all of our main content remains totally free for everyone with no article paywalls. We also don't have tons of adverts, there's also no tracking and we respect your privacy. Just good, fresh content. Without your continued support, we simply could not continue!

You can find even more ways to support us on this dedicated page any time. If you already are, thank you!
Login / Register

Or login with...
Sign in with Steam Sign in with Twitter Sign in with Google
Social logins require cookies to stay logged in.

Livestreams & Videos
Community Livestreams
Latest Forum Posts