You can sign up to get a daily email of our articles, see the Mailing List page!
Wine/proton games crash randomly and freeze the whole system
Rinkutux 29 Oct, 2018

I got this issue lately (since 1 week or something). Any game I launch with wine or with proton randomly crashes and freezes my system. The only thing I can do is manually reboot.

The freeze can happen after 1 hour of gaming or after 30 seconds. I'm currently using the 396.54.09 nvidia driver but upgrading to the latest 410 didn't fix anything. I also tried different DXVK versions to use with wine but nothing changed. Same with different wine versions.

Here's the list of games that crashed :
The Witcher 3 (Wine 3.19 + DXVK 0.90),
Skyrim Special Edition (same),
SoulCalibur VI (Steam/Proton 3.16)

There's no errors on the d3d11.log/dxgi.log after the crash.

Any idea ? Thanks

Xpander 29 Oct, 2018

sounds like system instability somewhere, power draw, heat, ram issues or whatever.

if possible set up a ssh and if it hangs/freezes check with other computer.
dmesg messages to read hardware stuff for example are good place to start


forgot to mention that you can use journalctl to check your previous boot messages also

journalctl -o short-precise -k -b -1

or 2 boots prior
journalctl -o short-precise -k -b -2

and so on

Rinkutux 30 Oct, 2018

I checked journalctl and I figured I got an error message :

kernel: NVRM: GPU at PCI:0000:01:00: GPU-fca04bca-a1f2-7c70-a509-71d087f335af
kernel: NVRM: Xid (PCI:0000:01:00): 79, GPU has fallen off the bus.
kernel: NVRM: GPU at 00000000:01:00.0 has fallen off the bus.
kernel: NVRM: A GPU crash dump has been created. If possible, please run as root to collect this data before the NVIDIA kernel module is unloaded.

Then I tried to run a game with lower clocks/memory (-200/-500) but still crashes with the same error. No idea what do. It suddenly happened like 1 week ago without doing anything specific. My temps are around 80 on full load, which is kinda average for a laptop.

Xpander 30 Oct, 2018

how is this laptop gpu connected to the motherboard? does it have pci-e extender cable? maybe something is loose a bit or has been overheating and is a bit smelted or similar.

though error 79 and GPU has fallen off the bus is most likely a PSU issue or in general defective hardware

Rinkutux 30 Oct, 2018

It's a soldered gpu, sadly.
Tho it might be a PSU issue since when I heavily downclock (-200/-2000) games doesn't crash anymore. Is there any way to check if there's something wrong with the PSU (230W) ?

Xpander 30 Oct, 2018

Quoting: RinkutuxIt's a soldered gpu, sadly.
Tho it might be a PSU issue since when I heavily downclock (-200/-2000) games doesn't crash anymore. Is there any way to check if there's something wrong with the PSU (230W) ?

no idea, best would be to buy a wall plug that can read the output and then just run it and see if it goes up there. Did you run your system with OC for longer periods of time? 230W PSU seems really limited even though its just a Laptop, but this GPU is usually around 150-200W itself, if you overclocked it at some point it might have killed something. Maybe you have a friend with similar powerbrick and can try with his or somehting?

Rinkutux 30 Oct, 2018

Yea I used to have a permanent slight OC (+100 core / +500 memory). Maybe the PSU didn't support it in the long term. I don't have any other 230w to test with. I guess I'll just stick with these lower clocks, it's not really a big deal. Atleast I figured how to stop the crashes, thanks for that :)

Xpander 30 Oct, 2018

Maybe you can look for a new powerbrick, shouldn't be that expensive i imagine. But yeah, running OC on laptops is not really good idea long term as they usually have pretty limited power to cope with it.

Rinkutux 5 Dec, 2018

I changed my power brick but sadly it didn't fix it.
New thing I figured out, the crash only occurs when using Vulkan. I tried the Rise of the tomb raider integrated benchmark tool to check on a native Vulkan game, and the "gpu has fallen off the bus" after the 2nd attempt of running the benchmark, without any overclocking.

So I also tried Superposition benchmark which uses OpenGL and it worked just fine multiple times, even with a slight overclock.

So it might be a Vulkan related issue. If someone experienced it before and has a fix for it, it would be nice.

damarrin 5 Dec, 2018

It does look like a hardware problem, but maybe try a completely clean system off a USB drive or the like to rule out any software issues?

Have you tried cleaning the computer and/or removing the heatsink from the GPU and reapplying (good) thermal paste?

Rinkutux 5 Dec, 2018

Yea I did everything you mentioned. I installed a fresh ubuntu 18.04 with only nvidia driver and steam to check on a proton game (skyrim SE), and it crashed within 30 seconds.

I also cleaned and reapplied thermal paste, but didn't fix anything.

I'm aware it might be an hardware issue, that's just weird it happens only with Vulkan. And also, everything works when I underclock. So it crashes when there is a 100% Vulkan usage on the gpu.

While you're here, please consider supporting GamingOnLinux on:

Patreon, Liberapay or PayPal Donation.

We have no adverts, no paywalls, no timed exclusive articles. Just good, fresh content. Without your continued support, we simply could not continue!

You can find even more ways to support us on this dedicated page any time. If you already are, thank you!
Login / Register

Or login with...
Sign in with Steam Sign in with Twitter Sign in with Google
Social logins require cookies to stay logged in.